10. MIDIノートとベロシティを編集する

LiveのMIDIクリップは、MIDIインストゥルメントの再生に必要なノートとコントローラーデータを含んでいます。このインストゥルメントは、MIDIトラックのデバイスチェーン(19) のバーチャルインストゥルメントである場合と、トラックの出力ルーティング(15) を介して接続される外部シンセである場合があります。MIDIクリップ(4.7) は、ノートピッチ、長さ、ポジション、ダイナミクス(MIDI用語でベロシティと呼ばれます)を指定する音楽スコアをデバイスに供給します。MIDIは、LiveのMIDIエディターで作成または編集できます。

10.1 空のMIDIクリップを作成する

MIDIクリップは、以下の方法で作成されます。

  • 録音する(17)
  • MIDIをキャプチャする(17.10)
  • MIDIトラックの空のセッションスロットをダブルクリックする
  • MIDIトラックの空のセッションスロットをダブルクリックし、[作成]メニューの[MIDIクリップを挿入]コマンドを選択する
  • アレンジメントビューのMIDIトラックのトラックディスプレイをダブルクリックする
  • アレンジメントビューで、MIDIトラック内の時間範囲を選択し、[作成]メニューの[MIDIクリップを挿入]コマンドを選択する

10.2 MIDIエディター

MIDIエディターを開くには、MIDIクリップをダブルクリックしてクリップビューを開きます。その後、タブヘッダーをクリックするか次のキーコンビネーションを使用して、クリップビューの3つのタブのいずれかから選択できます。

  • ALT+1でノートタブに切り替える
  • ALT+2でエンベロープタブに切り替える
  • ALT+3でエクスプレッションタブに切り替える

どのクリックビューが選択されているかにより、クリップビューに表示される情報は異なります。タブについて詳しくは、クリップビューの章(8) をご参照ください。

MIDIエディター

ノートタブが表示されている場合、MIDIエディターは2つの編集ウィンドウに分割されます。上のノートエディターと、下のエクスプレッションエディター(MIDIベロシティとMIDIチャンスエディターの各レーン)です。

デフォルトではベロシティエディターレーンが表示されますが、左のセレクタートグルボタンで、このレーンとチャンスエディターレーン(下で詳述)の両方を表示または非表示にすることができます。レーンセレクタートグルボタンの下には三角形のトグルボタンがあり、有効なレーンすべてを同時に表示または非表示にできます。両方のレーンセレクターが非表示の場合、三角形のトグルボタンを押すと両方のレーンが一度に表示されます。

これらのボタンでベロシティ/チャンスエディターレーンの表示を切り替える

ベロシティ/チャンスエディターレーンは分割線を使用して個別にサイズを変更したり、レーンとMIDIノートエディターの間の分割線をドラッグして同時にサイズを変更したりできます。

コントロールバーのドローモードスイッチ

コントロールバーのドローモードスイッチをオンにして、ドローモードに切り替えます。これで、マウスを使ってノートエディターにMIDIノートを描画することができます。ドローモードをオフにすると、クリップボードの操作またはクリック&ドラッグでノートを選択し動かすことができます。垂直方向に動かすとトランスポーズを変更し、水平方向に動かすとタイム位置を変更することができます。MIDIノートは、ドローモードがオフのときにダブルクリックして追加または削除することもできます。

[Record/Warp/Launch]環境設定の[ピッチロックありのドローモード]トグルでは、ドローモードを使用する方法を2種類から選択できます。有効な場合、MIDIノートの描画は一度にひとつのキートラック(またはピッチ)に制約されます。Altキーを押したまま操作するとフリーハンドでメロディを描画できます。無効な場合、ドローモードはデフォルトではフリーハンドのメロディ描画になり、Altキーを押したまま奏さするとピッチがロックされた状態の描画が有効になります。メロディのドローモードは既存のノートの上からスタートすることでノートを消去するのに使用できます。MIDIノートエディターにフォーカスがある場合、[オプション]およびコンテキストメニューのドローモードには現在選択されている[ピッチロックありのドローモード]設定の状態が[ピッチロック オン/オフ]で表示されます。

MIDIノートをプレビューする

MIDIトラックのデバイスチェーンにインストゥルメント(19) が含まれている場合、MIDIエディターのプレビュースイッチをオンにし、ノートを選択・移動しながら試聴することができます。MIDIトラックが録音可能な場合、新規ノートをクリップにステップ録音(17.3.4) することができます。プレビュースイッチのオン/オフ状態は、Liveセット内のすべてのMIDIトラックに適用されます。

いくつかノートを描いて移動させたら、ノートエディターの操作法について学びましょう。編集について詳しく説明する前に、MIDIエディターのナビゲーションについて説明します。

10.3 MIDIエディターのナビゲーションとトランスポート

ノートのポジションは垂直方向に、ビート時間は水平方向に表示される

MIDIエディターには、垂直方向と水平方向のナビゲーションがあります。水平軸に沿うタイムルーラーは、タイムラインでのノートポジションを表示しています。垂直軸には、オクターブをC2からC8で表示するノートルーラーと鍵盤(ピアノロール)が示されています。ピアノロールの一番上にあるプレビュースイッチがオンの場合、ピアノロールの再生を耳で確認することができます。

MIDIエディターのナビゲーション
  1. タイムのズームの度合いをスムーズに変更するには、タイムルーラーを垂直方向にドラッグします。タイムルーラーを左から右へスクロールするには、ルーラー内を水平方向にドラッグします。マウスホイールを上下にスクロールする際、CTRL(PC)/CMD(Mac)キーを押したままだと水平に、Altキーを押したままだと垂直にそれぞれズームできます。
  2. 表示されるオクターブを変更するには、ノートルーラー内を垂直方向ににドラッグします。MIDIノートとキーボードの垂直方向のズームの度合いを変更するには、水平方向にドラッグします。
  3. クリック&ドラッグして1つ以上のノートを、または、エディター背景の一部を選択してタイムの一定範囲を選択することができます。その後、ノートルーラーまたはタイムルーラー上をダブルクリックすると、選択範囲が自動的にズームされます。何も選択されていない場合、ノートルーラーをダブルクリックするとクリップ内の一番低いノートから一番高いノートの範囲にズームし、タイムルーラーをダブルクリックするとズームアウトし最初と最後のノートの間のタイムを表示します。CTRL(PC)/ALT(Mac)キーを上下矢印キーと組み合わせて使用して、ノート選択を変更できます。
  4. 現在選択されている範囲でズームインとアウトを行うには、コンピューターキーボードの+キーと-キーを使います。
  5. MIDIエディターのすぐ下にあるクリップオーバービューもナビゲーションに使用できます。オーバービューは、選択されたMIDIクリップをすべて表示しています。黒の長方形の外枠は、現在エディターに表示されているクリップ部分を示しています。スクロールするには、外枠内をクリックし左右にドラッグします。ズームインとアウトは、上下にドラッグして行います。
  6. エディター内に表示されている部分の長さを変更するには、クリップオーバービューの外枠の左右端をドラッグします。
  7. エディター内に表示されている部分を素早く変更するには、クリップオーバービュー内の確認したい部分をクリックし、下方向にドラッグしてズームするか、左右にドラッグしてスクロールします。

コントロールバーの自動スクロールスイッチ

ノートエディターに表示されるこの部分は、コントロールバーの自動スクロールスイッチを使って、再生と同時にスクロールするよう設定することが可能です。[自動スクロール]は、ノートエディター内で編集を行うと一時停止し、再生を停止または再開するか、アレンジメントまたはクリップのスクラブエリア内をクリックすると再開します。

Liveの[Look/Feel]環境設定で[常設スクラブエリア]が[オン]に設定されている場合、ビートタイムルーラー下のスクラブエリア内をクリックすると、クリックした位置へ再生がジャンプします。再生のタイミングは、グローバルのクオンタイズ設定に従います。(ヒント:[オプション]メニューの[MIDIノートを追跡]コマンドを有効にすると、MIDIノートのスタートタイム後にプレイバックが開始する場合にもMIDIノートが再生されます。)

[常設スクラブエリア]が[オフ]に設定されている場合も、Shiftキーを押しながらスクラブエリアまたはビートタイムルーラーをクリックすることでスクラブできます。ループ/リージョンコントロール(8.4) とショートカットについて知っておくと、MIDIエディターや再生の選択範囲の操作の際に便利です。

MIDIを操作していると、スクリーンのスペースが足りないと感じることがあります。その場合は、セッションビューまたはアレンジメントビューを分割するウィンドウを垂直方向にドラッグし、MIDIエディターを拡大することができます。

セッションビューとクリップビューを分割するウィンドウをドラッグしてMIDIエディターを拡大します。

10.4 MIDIを編集する

10.4.1 ノンディストラクティブ編集

[編集]メニューの[取り消す]コマンドを使えば、いつでもMIDIクリップを前の状態に戻すことができます。さらに、編集されたMIDIクリップがハードドライブ内のMIDIファイルから作成された場合も、編集作業内容はもとのMIDIファイルに変更を加えません。Liveは、取り込みの際にLiveセットにその内容を組み込みます。

10.4.2 スケール、折りたたみ表示、ループ

MIDIクリップのピアノロールで特定のノートを強調表示させると、スケールモードで選択したスケール内でメロディを簡単に書くことができます。スケールモードはクリップボックスのスケールボタンで切り替えることができます。スケールボタンの右にある根音とスケール名セレクターでは、選択されているクリップに対して根音とスケールを設定できます。

MIDIクリップのスケールモード設定

選択されているクリップでスケールモードが有効で、スケールが選択されている場合、そのスケールに属するノートがピアノロール内で強調表示されます。デフォルトでは、選択したスケールに属するキートラックがMIDIノートエディターで強調表示され、その根音がピアノロールで強調表示されます。スケールの強調表示は、MIDIノートエディターにフォーカスがある際にKのショートカットキーを押すか、コンテキストメニューまたは[表示]メニュー項目の[クリップスケールを強調表示]を選択してオンとオフを切り替えることができます。

選択されているスケールに属するキートラックは強調表示される

新規作成されたMIDIクリップは、スケールモードが無効であっても、以前に編集または表示されたクリップスケールを継承します。キーやスケールの設定が異なる複数のクリップを編集すると、スケールモードが有効な前景のクリップにより、新規クリップの作成に使用されたグローバル設定が更新されます。

選択されているクリップでスケールモードが有効で、スケールが選択されている場合、展開ボタンの右にあるスケールボタンを押すと、選択されているスケールに属するキートラックのみ表示されます。現在のスケールにないノートを含むキートラックも表示されます。

クリップのノートをフラット、シャープ、またはその両方を用いて表記するよう設定するには、ピアノロールのコンテキストメニューから行います。スケールモードが有効でない場合、この設定はすべてのノートに適用されますが、スケールモードが有効な場合、この設定は選択されているスケール外のノートにのみ適用され、スケール内のノートの臨時記号は維持されます。追加の[自動]オプションでは、五度圏内の根音の位置に応じてフラットまたはシャープが自動で選択されます。

クリップのノートの表記を設定する

MIDIエディターの重要な機能に、左上部に配置されたフォールドボタンがあります。このボタンを有効にすると、各MIDIクリップ内にMIDIノートを含まないすべての行またはキートラックが非表示になります。つまり、そのクリップ内に存在するノートに応じて、セット内の各クリップで使用可能なキートラックは異なります。

この機能は、例えばパーカッションキットを操作しているときに大変便利です。パーカッションキットは、しばしばキーボードに沿ってパーカッションタイプ(ハイハットシンバルから2オクターブ下にセットされたスネアなど)に対応するセクションにマッピングされています。このようなマッピングによって作成されたMIDIファイルを操作する場合は、各タイプのパーカッションサウンドが1、2つ使われており、キーボードの全範囲を表示する必要があります。(注:ノートエディターの畳み込みは、複数のクリップの編集時は不可能です(10.5) 。)

展開ボタンを押すと、ノートを含んだキートラックが表示される

MIDIを編集する際、クリップの現在聞こえている部分を変更したり、繰り返して聞くためにループを設定したいと思うことがあります。それには、ループ/リージョンマーカー(8.2.5) を使います。

ループ/リージョンマーカーを使ってクリップの再生範囲を選択する

Drum Rack(20.6) を含むトラック上で[Fold]が無効な場合、MIDIノートエディターには、デバイスがあるパッドに対応するノートの列のみ表示されます。[Fold]が有効な場合、ノートが含まれる列のみ表示されます。

ヒント:MIDIクリップのループブレースを選択してCtrl+D(PC)/Cmd+D(Mac)を押すと、ループブレース自体の長さが2倍になり、ループ全体を表示させるのに必要な分だけズームされます。ループの右のノートがすべて移動し、ループエンドからの相対位置を維持します。

10.4.3 グリッドへのスナップ

MIDIエディターのほとんどの機能は、グリッドスナップ(6.9) に影響されます。しかし、イベントをマウスで調整すると、グリッドは「マグネティック」になります。つまり、イベントの位置は前または次のグリッド線まで自由に移動することができますが、ドラッグを続けるとスナップします。Alt(PC)/Cmd(Mac)キーを押したまま操作を行うと、グリッドのスナップを一時的に無効にすることができます。

ノートの移動は、グリッドに相対するノートのもとの配置に基づく「オフセット」に吸着されます。必ずしも「矯正」する必要のないグルーブやルーズな再生スタイルを保つのに便利です。

10.4.4 ノートを編集する

MIDIエディターでの編集は、アレンジメント(6.8) での編集に似ています。どちらの場合も、選択して実行します。つまり、マウスを使ってアイテムを選択し、カット・コピー・ペースト・複製などのメニューコマンドを実行するという方法です。

それでは、どのように選択するのかを見ていきましょう。

  • ノートをクリックすると、ノートが選択されます。複数のノートを同時に選択することもできます。「ラバーバンド」選択は、空のスペースをクリックするマウス操作一つで複数のノートを選択し、ドラッグして表示されたラインにノートを取り込むことができます。[Escキーですべてのノートの選択を解除します。
  • MIDIエディターの背景をクリックするとタイム位置が選択されます。選択された位置は点滅する挿入マーカーで表示されます。
  • タイム範囲を選択するには、背景をクリック&ドラッグします。タイム範囲と、タイム範囲内でスタートする任意のノートの間で選択対象を切り替えるには、Enterキーを押します。

挿入マーカーを置いたら、コンピューターのキーボードを使って操作することができます。

  • グリッド設定に合わせて挿入マーカーを左右に移動するには、矢印キーを押します。Ctrl(PC)/Alt(Mac)キーと矢印キーを使って挿入マーカーを次のノート境界まで移動します。
  • 挿入マーカーを動かして選択したタイム範囲を伸ばしたり縮めたりするには、Shiftキーを押したまま矢印キーを押します。[選択範囲を逆側から伸ばしたり縮めたりするには、Shiftキーを押したまま矢印キーを押します。
  • 挿入マーカーは、[Home]を押してMIDIクリップの開始部分へ、[End]キーを押して終了部分へ移動することができます。

これまで見てきたように、MIDIエディター内のノートは水平方向(時間上のポジション変更)にも垂直方向(音程の変更)にも動かすことができます。ドラッグ、あるいはコンピューターキーボードの矢印キーを使ってロケーターを移動することができます。矢印キーで移動したノートは常にグリッドスナップとオフセットスナップに従いますが、マウスでドラッグしたノートは前または次のグリッドまたはオフセット位置に到達するまで自由に移動させることができます。ノートを編集中にクリップを再生すると、アサインを変更中に新しいアサインでノートを聞くことができます。

ノート編集にもいくつかのキーを使用します。

  • 選択したノートをオクターブ単位でトランスポーズするには、Shiftキーを押したまま上下矢印キーを押します。
  • グリッド設定に合わせて選択したノートの長さを伸ばしたり縮めたりするには、Shiftキーを押したまま左または右矢印キーを押します。ノートをグリッドにスナップ伸ばしたり縮めたりする場合は、Alt(PC)/Cmd(Mac)キーを押したまま操作します。
  • 選択を現在のノートから同じキートラックの次のノートに変更するには、Ctrl(PC)/Alt(Mac)キーを押したまま左または右矢印キーを押します。[選択をタイムライン上の次のノートに変更するには、Ctrl(PC)/Alt(Mac)キーを押したまま上または下矢印キーを押します。
  • ノートをグリッドに吸着させないでナッジするには、Alt(PC)/Cmd(Mac)キーを押したまま左または右矢印キーを押します。
  • Shiftキーを使って、各ノートや「ラバーバンド」で選択された部分を現在の選択部分に追加することができます。Shiftキーを押しながらノートをクリックし、単一のノートを選択部分から取り除くこともできます。Shiftキーを押したままピアノロールをクリックすると、1つのキートラックのすべてのノートを現在の選択範囲に追加できます。ノートがすでに選択されている場合はそれらが削除されます。

ノート(単独あるいは複数)を選択すると、[編集]メニューのコピーやペーストといったコマンドが利用できます。クリップボードのノートは、挿入マーカーの位置からペーストされます。ノートのコピーを新しい位置にクリック&ドラッグするのにCtrl(PC)/Alt(Mac)キーを使うこともできます。クリック&ドラッグでノートを移動した後、移動するのではなくコピーしたいと思った場合は、ドラッグを開始した後にCtrl(PC)/Alt(Mac)キーを押してもコピーすることができます。

ドラッグまたはドローすることにより、新しいノートを既存のノートの上に配置することがあります。新しいノートがもとからあるノートの始まり部分と重なった場合、もとのノートは画面上から消えてしまいします。新しいノートがもとのノートの終わり部分に重なると、もとのノートの長さが変更し、新しいノートが始まるまでもとのノートが続きます。

10.4.5 ノートの長さを変更する

ノートの左右端をドラッグします。長さはドローモードがオフのときにのみ変更可能です。ノート位置同様、ノートの長さも前または次のグリッド線まで自由に調整できますが、ノートの長さは、ドラッグ時にAlt(PC)/Cmd(Mac)キーを押したまま操作しなければ、クオンタイズされます。

ノートの長さを変更する

ヒント:同じ長さのノートをグループに設定するには、まずすべてを選択し、一番長いノートの最後をクリックして長さがゼロになるまでドラッグしてからのばします。

10.4.6 MIDIエディターの[タイムを...]コマンド

カット、コピー、ペーストなどクリップボードの一般的なコマンドは、現在選択されているノート(またはタイム選択範囲内のノート)にのみ影響します。しかし、アレンジメント編集(6.10) での操作同様、タイムを挿入または削除することによりMIDIクリップ全体に影響する[タイムを...]コマンドがあります。

クリップのスタートとエンド位置やループブレースの設定は変更されませんのでご注意ください。

  • [タイムを複製]は、クリップ内で選択したタイム範囲のコピーを作成します。その際、含まれているノートも複製されます。
  • [タイムを削除]は、MIDIクリップからタイム選択範囲を削除します。削除すると、削除された部分の両側にあるタイムライン上のノートが互いに接近します。
  • [無音部分を挿入]は、クリップ上に選択された範囲分の無音部分を選択された場所の前に挿入します。

10.4.7 ノートをクオンタイズする

LiveでMIDIノートをクオンタイズする方法には3つあります。1つ目は、MIDIノートを録音しながらクオンタイズする方法です(17.5) 。2つ目は、すでに説明した通り、ノートを動かして可視グリッドにスナップさせる方法です。3つ目は、1つのノートまたは複数のノートを選択してから、[編集]メニューの[クオンタイズ]コマンドを選択するか、Ctrl+U(PC)/Cmd+U(Mac)のホットキーを使用する方法です。初めてこの動作を行う際、クオンタイズのオプションを選択するダイアログボックスが開きます。この場合、デフォルト設定またはあらかじめ適用されている設定を使ってクオンタイズします。

クオンタイズのパラメーターを調整するには、[編集]メニューの[クオンタイズ設定]ダイアログを開きます。

MIDIノートをクオンタイズする

ここに表示されたオプションを使って、現在のグリッドサイズまたは特定のクオンタイズ値を選択しノート開始または終了(あるいはどちらも)がクオンタイズされるよう設定することができます。ノート終了をクオンタイズするとノートがストレッチされ、選択された単位で終了するようになります。ノートをクオンタイズ値のパーセントで動かす、[Amount]コントロールを使ってノートをクオンタイズすると、クオンタイズを感じさせない自然なクオンタイズが行えます。

10.4.8 ベロシティを編集する

MIDIノートのベロシティを変更するには、ベロシティエディター内の関連するマーカーをドラッグします。(マウスがMIDIノートのベロシティマーカーの上を通ると、Liveはマーカーを反転させるので簡単にロケートすることができます。) ベロシティ値はベロシティエディターのレーンヘッダーに数値で表示されます。

ノートベロシティを変更する

ノートエディター内の操作と同じように、Shiftキーを押しながら複数のベロシティマーカーを選択し変更することができます。

ヒント:同じベロシティのノートをグループに設定するには、ベロシティエディターのマーカーを選択し、ベロシティ最大値または最小値まで上下にドラッグし、希望の値に調整します。

先に見た通り、ドローモードでは、すべてのノートに全く同じベロシティをドローすることができます。ドローモードでは、ベロシティのドローは現在選択されているノートに限られます。ひとつひとつマーカーを(例えばクレッシェンドと一緒に)ドローするには、Ctrl+4(PC)/Cmd+4(Mac)のショートカットを使ってグリッド吸着を無効にするか、Alt(PC)/Cmd(Mac)キーを押したまま操作します。

均一なベロシティ(左)とクレッシェンド(右)をドローする

ヒント:同じキートラックにあるノートを持つベロシティ傾斜をドローするには、ピアノロールの鍵をクリックして希望のキートラック内のノートすべてを選択します。ドローモードがオンであることを確認し、ベロシティエディター内で線を描画します。この操作は選択されているノートにのみ作用します。

ヒント2:選択されているノートにわたって直線状のベロシティカーブを描画するには、まずノートを選択します(隣り合わないノートを選択するにはShiftキーを使用します)。ドローモードがオフになっていることを確認し、Ctrl(PC)/Alt(Mac)キーを押したままベロシティエディター内で線を描画します。

ノートエディターのノートは、それぞれの色でベロシティを表示します。つまり、明るい色で表示されているノートはソフトに再生されます。ベロシティエディターを開かずにノートや選択部分のベロシティを変更するには、Alt(PC)/Cmd(Mac)キーを押しながら垂直方向にドラッグします。

Ctrl(PC)/Cmd(Mac)キーを押しながらドローモードで垂直方向へ動かして、ベロシティを変更します。つまり、水平方向と垂直方向に動かせば、マウスボタンを解放することなく複数のノートとベロシティをドローすることができます。垂直方向の動きでベロシティを変更すると、Liveは変更内容を記録し、あとで描かれるノートに新しいベロシティを使用します。

ベロシティ値は、まずベロシティマーカーを選択してからキーボードで数値を入力してEnterキーを押すことで、手動で入力することもできます。Shiftキーを押したままにすることで、選択されているベロシティマーカーの値を微調整できます。上下矢印キーをCTRL(PC)/CMD(Mac)を押したまま使用することで、選択されているベロシティマーカーの値を+/-10単位で増減できます。

ベロシティ値をランダマイズするには、まずベロシティエディターレーンをクリックします。これで、ランダマイズレンジスライダーが整数値に変更されます。ランダマイズボタンをクリックすると、選択されているノート(または、選択されているマーカーのあるノート)のベロシティ値がランダマイズされます。マーカーが選択されていない場合、すべてのノートの値がランダマイズされます。

ランダマイズボタン

ランダマイズボタンの右にあるランダマイズレンジスライダーでは、ベロシティ値に適用されるランダマイズの範囲を指定できます。スライダーのランダマイズ範囲はキーボードを使用して数値として入力でき、Enterキーを使用して承認することでランダマイズがトリガーされます。ベロシティ値は、ゼロと、ランダマイズレンジスライダーに表示されている数の間の値でランダムに増減されます。

ランダマイズレンジスライダー

ベロシティレンジスライダーは、各ノートのベロシティの範囲を増やすことで、各ノートの範囲の詳細なコントロールを提供します。ベロシティ値は指定の範囲内からランダムに選択されます。たとえば、ベロシティ値が60、ベロシティ範囲が+20のノートの場合、60〜80の間で任意に選択された値で再生されます。正の値ではベロシティは上がり、負の値ではベロシティは下がります。

ベロシティレンジスライダー

CTRL(PC)/CMD(Mac)を押したままベロシティマーカーを垂直にドラッグすると水平ハンドルが現れ、これを上下にドラッグすることで、ベロシティ範囲値の上限と下限を設定できます。ベロシティ範囲は水平ハンドルとベロシティマーカーの間の網かけエリアで示されます。ベロシティマーカーをダブルクリックすると、範囲は0にリセットされます。

ノートオフベロシティ

デフォルトでは、ベロシティエディターでノートオンベロシティを調節することができます。しかし、エディターの右クリック(PC)/Ctrl-クリック(Mac)コンテキストメニューのオプションからエディターを切り替え、ノートオフベロシティを表示することができます。

ノートオフベロシティを表示するベロシティエディター

ノートオフ(「リリース」)ベロシティは理解するのがいくらか難しいパラメーターであり、一部のデバイスでしかサポートされていませんのでご注意ください。たとえばAbletonのSamplerインストゥルメント(26.7) では、さまざまなパラメーターに対するコントローラーとしてノートオフベロシティを供給します。

10.4.9 確率を変更する

チャンスエディターでは、再生中のクリップ内に生じるMIDIノートの確率を設定できます。チャンスエディターレーンはデフォルトでは非表示で、左のトグルボタンをクリックすると表示されます。

チャンスエディター

MIDIノートの確率を変更するには、チャンスエディター内の関連するマーカーをドラッグします。ノートの確率マーカーを上下にドラッグして、確率値を0〜100%で変更できます。(マウスがMIDIノートの確率マーカーの上を通ると、Liveはマーカーを反転させるので簡単にロケートすることができます。) 確率の変更はチャンスエディターのレーンヘッダーに数値で表示されます。

確率値は、まず確率マーカーを選択してからキーボードで数値を入力してEnterキーを押すことで、手動で入力することもできます。Shiftキーを押したままにすることで、選択されている確率マーカーの値を微調整できます。上下矢印キーをCTRL(PC)/CMD(Mac)を押したまま使用することで、選択されている確率マーカーの値を+/-10単位で増減できます。

確率値をランダマイズするには、まずチャンスエディターレーンをクリックします。これで、ランダマイズレンジスライダーがパーセント値に変わります。ランダマイズボタンをクリックすると、フォーカスされているレーンに応じて、選択されているノート(または選択されているマーカーのあるノート)の確率値がランダマイズされます。マーカーが選択されていない場合、すべてのノートの値がランダマイズされます。

ランダマイズボタン

ランダマイズボタンの右にあるランダマイズレンジスライダーでは、確率値に適用されるランダマイズの範囲を指定できます。スライダーのランダマイズ範囲はキーボードを使用して数値として入力でき、Enterキーを使用して承認することでランダマイズがトリガーされます。確率値は、ゼロと、ランダマイズレンジスライダーに表示されている数の間の値でランダムに増減されます。

ランダマイズレンジスライダー

確率値が100%未満のノートには、左上隅に小さな三角形が表示されます。これはキートラックの高さが十分にある場合にのみ表示され、それ以外の場合には非表示になります。

10.4.10 MIDIノートストレッチ

MIDIノートストレッチマーカー

ノートストレッチマーカーがノートエディターに表示され、ノートをタイムに対して比例的に計測することができます。マーカーは一組のインジケーターで、選択部分の最初と最後のノートにスナップします。

マーカーを水平にドラッグすると、選択されたノートが移動してストレッチし、最初に選択された時点と同じ割合のタイムがキープされます。ノート同様、ノートストレッチマーカーは、前または次のグリッドまたはオフセット位置に到達するまで自由に移動できますが、その後は、グリッドが表示されていない、またはAlt(PC)/Cmd(Mac)キーを押したまま操作したのでない限り、ノートエディターのグリッド線にスナップします。

マウスポインターをノートストレッチマーカーの間に置くと、「擬似」ストレッチマーカーが表示されます。これをドラッグすると、、固定されているマーカーの間の素材を伸縮させることができます。マーカーの外側の素材には影響しません。この擬似ストレッチマーカーも、固定されているマーカーと同じスナップ動作を行います。

ノートが選択されている(がタイムは選択されていない)とき、1つのマーカーをもう1つのマーカーを越えてドラッグすることができます。この場合、ストレッチされたノートの順は、元の並び順を反映します。この現象は、「逆行」動作と呼ばれることもあります。

ノートストレッチマーカーを調整すると、クリップのリンクしているクリップエンベロープのタイミングも調整されます。リンクしていないクリップエンベロープは影響を受けない

10.4.11 MIDIクリップをクロップする

ループブレースの外側のMIDIデータは、[クリップをクロップ]コマンドを使って削除することができます。セッションビューまたはアレンジメントビューのMIDIクリップで右クリック(PC)/Ctrl-クリック(Mac)し、このオプションを選択します。オーディオクリップのクロップ(8.2.8) と異なり、MIDIクリップのクロップでは、ディスク上に新規ファイルは作成されません。

10.4.12 ノートを無効にする

MIDIエディター内のノートを無効にする(ミュートする)には、ノートを選択してから0を押します。[ノートを無効にする]コマンドでは、ノートがミュートされ、ノートが灰色でディスプレイに表示されます。もう一度0を押すとノートが再び有効になります。ピアノロールのキーをクリックしてから0を押すと、1つのキートラック上のすべてのノートを一度に有効または無効にすることができます。

10.4.13 トランスフォームツール

MIDIエディター内の編集機能に加え、[Notes]タブのトランスフォームツール (8.3) でも、MIDIクリップ内のノートをさまざまな方法ですばやく変更できます。

10.5 マルチクリップ編集

ノートエディターでは、複数のMIDIクリップにあるノートを同時に表示させることができます。これは、アイデアを作成、向上させる際に異なるクリップ間でのメロディやリズム上の関連性を理解するのに便利で、複数のトラックやシーンにわたって素材を素早く編集することができます。複数のクリップにわたってノートを編集するだけでなく、選択されているクリップのさまざまなパラメーターを変更できます。

複数のMIDIクリップが選択されている場合:

  • これらのクリップのノートはノートエディター内に一緒に表示されます。選択されている複数のクリップのノートを選択して同時に編集したり、フォーカスモード(10.5.1) を使用して他のクリップをビューに表示させたまま1つのクリップ内のノートを編集したりできます。
  • ループバーがノートエディターの上に表示されます。各ループバーは、現在の選択内のそれぞれのクリップを示しており、ループバーの色はクリップの色に合致します。クリップを編集するにはそのクリップのノートまたはループバースイッチをクリックします。

ノートエディターのマルチクリップループバー

  • 各クリップのループ長はループバーマーカーをクリックしてドラッグすることで調整できます。Ctrl(PC)/Cmd(Mac)キーを押したまま選択されているクリップのループマーカーをクリック&ドラッグして、ループバーを選択して編集できます。Shiftキーを使用するとループバーを続けて選択できます。(注:フォーカスモードが有効な場合、2つ以上のループバーを同時に選択することはできず、既存の複数選択は無視されます。)
  • タイトルバーには、編集用に選択されているクリップの名前が表示されます。これは、同じ色の異なるクリップを識別するのに特に便利です。(注:クリップに名前が付いていない場合、タイトルバーには代わりにそのクリップを含むトラックの名前が表示されます。)
  • クリップボックス(8.1) 内の一部のコントロールは複数のMIDIクリップが選択されると表示され、選択されているクリップすべてに対して編集可能です。これらのコントロールには、ループ設定、クリップの拍子、クリップのグルーヴ設定、スケールモード設定があります。
  • [Fold]と[Scale]設定は選択されているクリップすべてに対して編集できます。
  • ベロシティと確率の値のランダマイズは一度に1つのクリップにのみ適用されます。選択されている全クリップに副舞えるすべてのノートに対するこれらの値をランダマイズすることはできません。
  • ループバーリージョンはノートビューのスクラブエリアのすぐ上をクリック&ドラッグすることでサイズを変更できます。

マルチクリップ編集の動作は、作業中のスペースがセッションビューであるかアレンジメントビューであるかにより異なります。違いについては、この章のセッションビュー(10.5.2) とアレンジメントビュー(10.5.3) のセクションをご覧ください。

10.5.1 フォーカスモード

フォーカスモードでは、複数のクリップを表示させたまま、1つのクリップを選択して編集できます。フォーカスモードは、[Focus]ボタンまたは「N」のキーボードショートカットで切り替えることができます。フォーカスモードが無効な場合、Nを押したままマウスで編集すると一時的にフォーカスモードに切り替わります。マルチクリップ編集は、フォーカスモードが有効であるかどうかに応じて動作が異なります。

フォーカスボタンでフォーカスモードを有効にする

フォーカスモードが有効な場合:

  • アクティブなクリップのノートはそのクリップの色で、アクティブでないクリップのノートは灰色でそれぞれ表示されます。
  • アクティブなクリップのループバーは黒で、アクティブでないクリップのループバーは灰色でそれぞれ表示されます。
  • アクティブなクリップの名前はループバーの下に表示されます。
  • アクティブでないクリップのノートまたはループバーにマウスオーバーすると、そのクリップの色が表示され、編集時に現在の選択範囲内のクリップを選択するのに便利です。クリップを編集するにはそのクリップのノートまたはループバースイッチをクリックします。
  • ループ長コントロールとノートツールはアクティブなクリップの編集に使用できます。
  • スケールモードを有効化すると、現在選択されているクリップの根音とスケール名が表示されます。
  • [Scale]が有効な場合、選択されている全クリップにわたる全スケールが折りたたまれます。[Fold]を有効にすると[Scale]が無効になり、選択されている全クリップにわたる全キートラックが折りたたまれます。
  • ノートタブの[Transpose]、[Reverse]、[Invert]、[Legato]、[Duplicate]の各コントロールはアクティブなクリップにのみ適用されます。

フォーカスモードが無効な場合:

  • すべてのノートは、アクティブな場合そのクリップの色で表示されます。
  • クリップのループバーはクリックすると黒になり、クリップ内のノートのベロシティやチャンスをランダマイズすることができます。選択されていないループブレースはクリップの色で表示されます。
  • スケールモードを有効化すると、全クリップにわたって同じである場合のみ、現在選択されているクリップの根音とスケール名が表示されます。あるいは、別の根音またはスケール名が選択されているところにアスタリスク(*)が表示されます。
  • ノートタブの[Transpose]、[Reverse]、[Invert]、[Legato]の各コントロールは選択されているすべてのクリップに適用されます。[Reverse]、[Invert]、[Legato]のコントロールが機能するには、少なくとも1つのノートが選択されている必要があります。
  • [Duplicate]、[2分の1のテンポで再生]、[2倍のテンポで再生]の各機能は使用不可能になります。使用するには、フォーカスモードを有効にする必要があります。

10.5.2 セッションビューでの編集

セッションビューでは、ループするMIDIクリップを最大8つまで同時に選択、表示できます。ノートエディターでは、ループバーは縦に並びます(まずトラック毎、次にシーン毎)。

長さの異なる複数のクリップが選択されている場合、ノートエディターにはクリップの並べ替えに必要なだけループ反復が表示されます。ループ位置はノートエディターの黒の縦線で示されます。スタートマーカーがループスタートより前に設定されているクリップは、ノートエディターの一番上のバーで示されます。

マルチクリップ編集はさまざまなトラックにわたるクリップを表示させるのに便利ですが、同一のトラック内の複数のクリップを比較、編集する必要がある場合にも便利です。たとえば、ノートをクリップに追加して展開するパターン進行を作成してから、次のシーンにこのクリップのバリエーションを作成しながら、トラック内の他のクリップの概要を確認することができます。

10.5.3 アレンジメントビューでの編集

アレンジメントビューでは、時間選択範囲にわたって最大8トラックのMIDIクリップを選択、表示できます。ノートエディターでは、ループバーはトラック毎に縦、時間毎に横にそれぞれ並びます。

ノートエディターには選択されている複数のクリップの前後に無音は表示されません。代わりに、表示範囲が調整され、選択範囲内の最初のクリップの先頭から最後のクリップの末尾までが表示されます。選択範囲にループするクリップとループしないクリップがある場合、[ループ]ボタンが半分だけ色付きで表示されます。

Live 11マニュアル(PDF)のダウンロード

EnglishDeutsch日本語EspañolFrançaisItaliano简体中文