17. インストゥルメントとエフェクトを使用する

Liveの各トラックには、複数のデバイスを配置することができます。デバイスには3種類あります。

  • MIDIエフェクトは、MIDI信号に作用し、MIDIトラックにのみ置くことができます。
  • オーディオエフェクトは、オーディオ信号に作用し、オーディオトラックに置くことができます。オーディオエフェクトがインストゥルメントの「ダウンストリーム」の場合、MIDIトラックに置くこともできます。
  • インストゥルメントは、MIDIトラックに置かれるデバイスで、MIDIを着信しオーディオを出力します。

トラックビューでは、デバイスを選択されたトラックに挿入・表示・調節することができます。トラック名称をダブルクリックしてトラックを選択し、トラックビューを開いてデバイスにアクセスします。デバイスビューがLiveスクリーン下部に表示されます。

DevicesInDeviceView.png

デバイスビューのデバイス

デバイスビューの表示スペースを確保するには、デバイスのタイトルバーをダブルクリックするか、デバイスの右クリック(PC)/CTRL-クリック(Mac)コンテキストメニューから格納ボタンを選択して表示を折りたたみます。

FoldedDevices.png

デバイスは格納することが可能

デバイスの機能と操作については、Liveオーディオエフェクトリファレンス(チャプター 22)、LiveMIDIエフェクトリファレンス(チャプター 23)、Liveインストゥルメントリファレンス(チャプター 24)をご参照ください。

インストゥルメントとエフェクトのグループ化とその使用方法については、インストゥルメント、ドラム、エフェクトのラックの章(チャプター 18)をご参照ください。

パラメーターをMIDIまたはキーリモートコントロール(チャプター 26)へアサインし、デバイスを「ハンズオン」コントロールできます。

17.1 Liveデバイスを使用する

LiveDevicesInBrowser.png

Liveブラウザーのデバイス

Liveの内蔵デバイスは、ブラウザーで選択できます。Liveのシンセ、オーディオエフェクト、MIDIエフェクトに対して、それぞれ専用のラベルがブラウザーに表示されます。

デバイスをトラックに置く一番簡単な方法は、ブラウザーでデバイスをダブルクリックすることです。新規トラックが作成され、デバイスが置かれます。また、デバイスをおきたいトラックをクリックして選択してから、ブラウザーからデバイスまたはプリセットを選択し、Enterキーを押して選択したトラックに加えることもできます。

また、デバイスをトラックへドラッグしたり、セッションビュー・アレンジメントビュー・デバイスビューへドロップすることもできます。サンプルをMIDIトラックのデバイスビューへドラッグすると、ロードされるサンプルと共にSimplerインストゥルメントが作成されます。

:外部入力信号を使って、Liveトラックへデフォルト設定を供給している場合、トラックのデバイスチェーンのデバイスを通過する入力を聞くには、ミキサー内のトラックのアームボタンを有効にする必要があります。MIDIトラックでは、通常このボタンはインストゥルメントが挿入されると自動的に有効になります。

ArmButtons.png

MIDIとオーディオのトラックアームボタン

こう設定すれば、例えば、生演奏で使用している楽器をトラックのエフェクトに通して再生したり、トラックのインストゥルメントの再生にMIDIキーボードの入力を使うことができます。このセットアップから、新しいクリップの録音(チャプター 16)への移動は簡単です。モニターリング設定が異なる場合の設定については、モニターリングの項(14.1)をご参照ください。

トラックにデバイスを加えるには、トラックへドラッグするか、デバイス名をダブルクリックしデバイスチェーンに加えます。デバイスチェーンの信号は、常に左から右へと移動します。

オーディオエフェクトは、オーディオトラックのデバイスチェーンの任意の位置にドロップすることができます。エフェクトの並び順は、生じるサウンドに影響しますのでご注意ください。MIDIトラックのデバイスチェーンの場合も同様です。

インストゥルメントをMIDIトラックのデバイスチェーンにドロップすると、インストゥルメントの次にある(右にある)信号はオーディオ信号となり、オーディオエフェクトだけに有効となります。インストゥルメントの前にある(左にある)信号はMIDI信号となり、MIDIエフェクトだけに有効となります。つまり、MIDIトラックのデバイスチェーンには、まずMIDIエフェクト、次にインストゥルメント、最後にオーディオエフェクトと、3種類すべてのデバイスを置くことができます。

DevicesInDeviceView.png

MIDIトラックのデバイスチェーンは、3つのデバイスタイプすべてを含むことができます。

チェーンからデバイスを削除するには、デバイスのタイトルバーをクリックしコンピューターのバックスペースまたはDeleteキーを押すか、[編集]メニューから[削除]を選択します。デバイスの並び順を変更するには、デバイスのタイトルバーをドラッグし、デバイスビューの他のデバイスのそばにドロップします。デバイスビューからセッションまたはアレンジメントビューへドラッグし、デバイスをまとめて他のトラックに移動することもできます。

カット、コピー、ペースト、複製などの[編集]メニューコマンドは、デバイスにも使用できます。ペーストしたデバイスは、選択されているデバイスの前に挿入されます。デバイスチェーンの最後のデバイスのあとの空間をクリックするか、右矢印キーを使って選択を移動させることで、デバイスチェーンの最後にペーストすることができます。デバイスの配置・再配置・削除により、オーディオストリームが中断されることは通常ありません。

DeviceActiveSwitch.png

デバイスアクティベータースイッチ

デバイスは、アクティベータースイッチを使ってオンとオフを切り替えることができます。デバイスをオフに切り替えるのは、デバイスを一時的に削除したような状態です。信号は処理されず、デバイスはCPUを消費しません。Liveデバイスは、通常、オフの場合にはCPUを消費しません。詳細については、CPU負荷に関する項(30.1)をご参照ください。ここで説明されている[トラックをフリーズ]コマンドは、CPU負荷の高いデバイスを使って作業する際に特に便利です。

Liveトラックのデバイスには、入力と出力レベルメーターがあります。このメーターは、デバイスチェーンにある問題のあるデバイスを探し出すのに便利です。信号のレベルが低すぎる場合や、信号が全く着信されない場合、レベルメーターに状況が表示されるので、デバイスをオフにしたり取り外したりして、デバイス設定を調整することができます。

MetersBetweenDevices.png

チェーンのデバイス間のレベルメーター

ヘッドルームは無限なので、デバイス間にクリッピングは生じません。クリッピングは、レベルの異常に高い信号が物理出力に送信された場合やサンプルに書き加えられた場合に発生します。

Liveのトラックタイプについては、ルーティングとI/Oの章(チャプター 14)をご参照ください。リターントラックを使って、単一のデバイスの効果を複数のトラックへアサインする方法などが説明されています。Liveのデバイスの使い方を学んだら、クリップエンベロープの章(チャプター 20)もご参照ください。各クリップのデバイスパラメーターのモジュレート方法が説明されています。

17.1.1 Liveデバイスのプリセット

Liveデバイスは、パラメーター設定をプリセットとして保存し呼び出すことができます。ブラウザーのコンテンツパネルには各デバイスがフォルダーとして表示され、プリセットが保存されています。

PresetsInBrowser.png

ブラウザーのプリセット

コンピューターのキーボードを使って、プリセットをブラウズしロードすることができます。

  • 上下にスクロールするには、上下矢印キーを使用します。
  • デバイスフォルダーを開閉するには、左右矢印キーを使用します。
  • デバイスまたはプリセットをロードするには、Enterキーを押します。

Qキーを押すか、デバイスのホットスワッププリセットボタンをクリックすると、一時的にブラウザーがデバイスにリンクされ、デバイスのプリセットが呼び出されます。デバイスとブラウザーがリンクしている間、プリセットのブラウズ・ロード・視聴が行えます。ホットスワップモードでは、デバイスとプリセットがブラウザー内の選択対象上に自動的にロードされます。デバイスのデフォルトファクトリーセッティングをロードするには、ブラウザーからプリセットの親フォルダー(デバイス名が付いたフォルダー)を選択します。

Qキーを押してホットスワップモードに切り替えると、選択されているトラック上で直前に選択したデバイスからスワップされます。デバイスが選択されていない場合、最初のオーディオエフェクト(オーディオトラック上)またはインストゥルメント(MIDIトラック上)からスワップされます。

BrowsePresetsButton.png

ホットスワッププリセットボタン

ブラウザーとデバイスのリンクは、別のビューが選択されるか、Qキーまたはホットスワップボタンをもう一度押すと切れます。プリセットのホットスワップは、Escキーを押すか、ブラウザー最上部のホットスワップバーのクローズボタンを押すとキャンセルできます。

プリセットは、ブラウザーを介してインポートする方法の他に、エクスプローラー(Windows)/Finder(Mac)からLiveへ直接ドロップすることもできます。

プリセットを保存する

ブラウザーのユーザーライブラリでは、プリセットを好きな数だけ作成し保存することができます。

SavePresetsButton.png

プリセット保存ボタン

プリセット保存ボタンをクリックして、デバイスの現在の設定(独自のインフォテキストを含む)を新規プリセットとして保存することができます。このボタンを使うと、ブラウザーにリダイレクトされます。そこでEnterキーを押し、Liveが自動でつける名前を使用するか、任意で変更します。プリセットの保存をキャンセルするには、Escキーを押します。デバイスのタイトルバーからドラッグし、ブラウザー内の任意の場所にドラッグすることで、プリセットをブラウザーの[Places]セクションの特定のフォルダー(ご使用の「Curent Project」フォルダーなど)に保存することもできます。

ブラウザーの操作に関して、詳しくはファイルとセットの管理の章(チャプター 5)をご参照ください。プロジェクトを特定したプリセットの保管に関して、詳しくは該当の項(5.6.2)をご参照ください。

デフォルトプリセット

ユーザーライブラリ内の[Defaults]フォルダーに保存されているプリセットが一般的なデバイス設定の代わりにロードされます。以下が行える[Defaults]フォルダーもあります。

  • サンプルのドロップ、スライス、オーディオからMIDIへの変換といったさまざまなユーザーの操作に対するLiveの反応をカスタマイズ。
  • 新規作成されたMIDIトラックおよびオーディオトラックを、すでに配置されている特定のデバイスと共にロードし、カスタムのパラメーター設定を適用。
  • VSTとAudio Unitプラグインを、Liveのパネルで設定済みの特定のパラメーターの組み合わせでロード。
DefaultsFolder.png

ユーザーライブラリ内の[Default]プリセットフォルダー

あるデバイスの現在の設定をデフォルトプリセットとして保存するには、デバイスのヘッダーから右クリック(PC)/CTRL-クリック(Mac)コンテキストメニューを開き、[フォルトプリセットとして保存]を選択します。この操作は、Liveのインストゥルメント、MIDIエフェクト、オーディオエフェクト(さまざまな種類のラック(チャプター 18)を含む)すべてに使用できます)。特定のデバイスのデフォルトプリセットがすでに保存されている場合、上書きする前にダイアログが表示されます。

VSTまたはAudio Unitプラグインのデフォルト設定プリセットを作成するには:

  • 選択されているプラグインをトラックにロード
  • プラグインの設定モード(“プラグイン設定モード”)で、希望のパラメーターを設定
  • トラックのヘッダーを右クリック(PC)/CTRL-クリック(Mac)でコンテキストメニューを開き、[デフォルトとして保存]を選択

特定のプラグインをVSTとAudio Unitの両バージョンでインストールしている場合、各タイプに対して別個のデフォルト設定プリセットを作成できます。プラグインのデフォルトプリセットは、設定済みのパラメーターの設定を保存しません。Liveのパネル内にパラメーター設定のみ設定されます。

MIDIトラックとオーディオトラックのデフォルトプリセットを作成するには:

  • デフォルトにしたいデバイスをトラックにロードします(空のトラックをデフォルトトラックにしたい場合はデバイスをロードしません)。
  • デバイスのパラメーターを調整します。
  • トラックのヘッダーを右クリック(PC)/CTRL-クリック(Mac)してコンテキストメニューを開き、[Audio/MIDIトラックのデフォルトとして保存]を選択します。

ドラムラックまたはMIDIトラックのデバイスビューへサンプルをドラッグする際のLiveの動作を指定するには:

  • 空のSimplerまたはSamplerを作成
  • パラメーターを調整
  • 編集したデバイスを[On Drum Rack]または[On Track View]フォルダー(ユーザーライブラリ内の[Defaults]/[Dropping Samples]フォルダーにあります)にドラッグします。ドラムラックのパッドのデフォルトは、ドラムラックのパッドを右クリック(PC)/CTRL-クリック(Mac)してコンテキストメニューのオプションでも保存できます。

オーディオファイルをスライスする際のLiveの動作を調整するには:

  • 空のドラムラックを作成
  • 空のSimplerまたはSamplerをドラムラックへ加え、単一のチェーンを作成
  • MIDIエフェクトまたはオーディオエフェクトをこのチェーンに追加
  • デバイスのいずれかのパラメーターを調整
  • チェーンのデバイス内のいずれかのコントロールにマクロコントロール(18.7)をアサイン
  • ドラムラック全体をユーザーライブラリの[Defaults]/[Slicing]フォルダーへドラッグ

複数のスライスプリセットを作成し、スライスダイアログのスライスプリセットセレクターからいずれかを選択することができます。

スライスは、Live LiteおよびLive Introでは使用できませんのでご注意ください。

ドラム、ハーモニー、メロディをMIDIに変換(11.2)するためのデフォルトプリセットを作成するには:

  • 特定の変換タイプに対するデフォルトとして使用したいインストゥルメントを含むMIDIトラックを作成します。(ドラム変換用のデフォルトプリセットにはDrum Rackが含まれている必要があります)
  • MIDIエフェクトまたはオーディオエフェクトをこのトラックに追加
  • デバイスのいずれかのパラメーターを調整
  • 複数のデバイスを使用している場合、それらをRackにまとめる
  • Rack全体をユーザーライブラリの[Defaults]/[Audio to MIDI]内の適切なフォルダーへドラッグ

これらの「マスター」デフォルトプリセットに加えて、特定のプロジェクト用のデフォルトプリセットを作成することもできます。これは、たとえば特定のセットに対する特別デバイスやトラック設定を使用していて、セットのバリエーションを作成したいとき、セットのこれらのプリセットへのアクセスはそのままに、他の作業用に使用する汎用デフォルトセットを上書きしたくない場合に便利です。プロジェクト指定のデフォルトプリセットを作成するには:

  • プロジェクトフォルダー内に[Defaults]フォルダーとサブフォルダーを再び作成します。
  • 使用したいプロジェクト指定のデフォルトの種類に応じて、対応するデバイスパラメーター、トラック設定などを調整します。
  • デバイスまたはトラックをプロジェクト指定の[Defaults]フォルダー内の適切なフォルダーに保存します。

これで、このプロジェクトからセットをロードするたびに、ユーザーライブラリのプリセットではなく、これらのプロジェクトフォルダーに保存したデフォルトプリセットが使用されます。デフォルトプリセット保存用の右クリック(PC)/CTRL-クリック(Mac)のコンテキストメニューオプションは、メインのユーザーライブラリにプリセットを保存するため、プロジェクト指定のデフォルトの保存には使用できません。

17.2 プラグインを使用する

Liveで使用するデバイスは、プラグインとして追加することができます。Liveは、Steinberg MediaのVSTプラグイン形式と、Audio Units(AU)プラグイン形式(Mac OS Xのみ)に対応しています。

VSTやAudio Unitsプラグインを使った作業は、Liveデバイスを使った作業とほとんど変わりません。VSTとAUインストゥルメントは、LiveのMIDIトラック上に置かれ、Liveインストゥルメントと同様に、MIDIを着信しオーディオ信号を出力します。プラグインオーディオエフェクトは、オーディオトラック上か、後にインストゥルメントが続く場合にのみ使用できます。詳しくは、前出の項「Liveデバイスを使用する」(17.1)をご参照ください。

PlugInBrowser.png

ブラウザーのプラグイン

Audio UnitsとVSTプラグインは、ブラウザーの[Plug-In]ラベルを使用してブラウズしたりインポートできます。プラグインインストゥルメントは、ブラウザーのプラグインエフェクトとは区別して表示されます。インストゥルメントがキーボードアイコンで表示されるのに対して、エフェクトはプラグの形をしたアイコンで表示されます。

プラグインプリセットは、Audio Unitsプラグインのブラウザーでのみ使用可能です。Audio Unitsのファクトリープリセットがブラウザーに表示されないことがあります。その場合、デバイスをトラックに置き、ホットスワップボタンを有効にすると、プリセットが表示されるようになります。

:Liveを初めて起動する場合、[Plug-In]ラベルにプラグインが表示されません。まず、プラグインソースを「有効」にする必要があります。プラグインソースを有効にすると、どのプラグインを使用するか、コンピューターのどこにプラグインがあるかがLiveに伝えられます。プラグインソースの有効と無効に関する詳細は、この章のVSTプラグインフォルダー(17.3.1)とAudio Unitsプラグイン(17.4)の項で説明しています。

Intel® Macを使用する場合:Intel®プロセッサー搭載のMacでは、PowerPCプラットフォーム用VSTおよびAUプラグインをネイティブ実行することはできません。(ユニバーサル)または(Intel®)タイプのプラグインのみ、Liveで使用することができます。

プログラム動作中にプラグインをインストールとアンインストールする場合、Liveは変更を検知せず、プログラムを再起動するまで、ブラウザー内にプラグインが表示されません。[File/Folder]環境設定の再スキャンボタンを使えば、Liveが動作中にプラグインを再スキャンし、インストールされたデバイスを即時にブラウザーから選択することができます。

プラグインデーターベース表示の更新にも、再スキャンを行うと便利です。ALT(PC)/ALT(Mac)キーを押したまま[再スキャン]をクリックすると、古いプラグインデーターベースが削除され、新たにプラグインデーターベースが構築されます。

17.2.1 デバイスビューのプラグイン

VstPlugInTrackView.png

デバイスビューのVSTプラグイン

プラグインをブラウザーからトラックへドラッグすると、プラグインがデバイスビューに表示されます。調節可能なパラメーターが32未満のプラグインでは、Liveパネルに水平スライダーとしてすべてのパラメーターが表示されます。調節可能なパラメーターが32以上のプラグインでは、空のパネルが開きます。アクセスしたいパラメーターが表示されるよう、パネルを設定することができます。プラグイン独自のインターフェースは、別ウィンドウで開く(“プラグインパネルを別ウィンドウで表示する”)ことができます。

VstPlugHideButton.png

プラグイン展開ボタン

プラグインのタイトルバーにある27181.pngボタンをクリックし、プラグインのパラメーターの表示と非表示を切り換えることができます。

X-Yコントロールフィールドは、2つのプラグインパラメーターを一度にコントロールすることができ、ライブ演奏でのコントロールに特に便利です。2つのプラグインパラメーターをLiveパネルのX-Yフィールドにアサインするには、フィールド下のドロップダウンメニューを使用します。

プラグインパネルを別ウィンドウで表示する
VstPlugInEditButton.png

プラグイン編集ボタン

プラグイン編集ボタンを押すと、VSTまたはAudio Unitsプラグインパネルを別ウィンドウに開きます。別ウィンドウ内でのパラメーターの変更も、Liveパネルでの変更と同様に機能します。

プラグイン設定で、プラグイン編集ウィンドウに関する設定を行います。

  • 有効の場合、[プラグインカスタムエディターを自動で開く]をオンにすると、プラグインがブラウザーからトラック上に起動された際、プラグインカスタムエディターウィンドウが自動的に開きます。
  • [マルチプラグインウィンドウ]オプションがプラグイン設定で選択されている場合、プラグインウィンドウを一度に好きな数だけ開くことができます。このオプションが選択されていなくても、CTRL(PC)/CMD(Mac)キーを押したまま新しいプラグインウィンドウを開くと、すでに開いているウィンドウを閉じずに新しいウィンドウを開くことができます。
  • [プラグインウィンドウを自動で隠す]では、現在使用中のトラックに置かれているプラグインのウィンドウだけがLiveディスプレイに表示されるよう設定することができます。

[表示]メニューの[プラグインウィンドウ]コマンド、またはCTRL+ALT+P(PC)/CMD+ALT+P(Mac)のショートカットを使用して、開いているプラグインウィンドウの表示と非表示を切り換えることができます。プラグイン編集ウィンドウ内のタイトルバーには、プラグインが置かれているトラック名が表示されます。

プラグイン設定モード

VstPlugInConfigureMode.png

設定ボタン

設定モードでは、アクセスする必要のあるプラグインのパラメーターだけを表示するようLiveのパネルをカスタマイズすることができます。手順は以下のとおりです。

  • デバイスのヘッダーの[設定]ボタンを押して、設定モードに切り替えます。
  • プラグイン編集ウィンドウのパラメーターをクリックして、Liveのパネルに加えます。(プラグインによっては、パラメーターの値を実際に変更しなければならない場合もあります。また、プラグインによっては、すべてのパラメーターをLiveに「公開」しないものもあります。これらのパラメーターは、Liveのパネルに追加されません。)

設定モードがオンの場合、Liveのパネルのパラメーターを新しいロケーションへドラッグ&ドロップして記録または移動することができます。パラメーターは削除キーを押して削除することができます。既存のオートメーションデータ、クリップエンベロープ、MIDI、キーまたはマクロ・マッピングのあるパラメーターを削除しようとすると、Liveに警告メッセージが表示されます。

割り当てたパラメーターはご使用のセットのプラグインの各インスタンスに対して固有となり、セットと共に保存されます。特定のパラメーターを使った設定を保存したい場合、設定したプラグインを含むラックを作成(チャプター 18)することができます。ラックは、ユーザーライブラリに保存し、他のセットにロードすることができます。デフォルトプリセット(“デフォルトプリセット”)として特定のパラメーター設定も保存できます。

プラグインによっては独自のウィンドウがないものもあり、その場合はパラメーターのみLiveのパネルに表示されます。これらのプラグインでは、設定モードでパラメーターを削除することはできません(パラメーターの移動と記録は可能です)。

設定モードに切り替えないでプラグインのパラメーターをLive パネルに加えるには、いくつかの方法があります。

  • プラグインの別ウィンドウのパラメーターを調整すると、クリップエンベロープとオートメーションセレクターとパネルのX-Yフィールドのセレクターにそのパラメーターの仮エントリが作成されます。これらのエントリは、別のパラメーターを調整すると削除されます。エントリを常設させる(Live のパネルに加える)には、パラメーターのオートメーションまたはクリップエンベロープを編集するか、オートメーションまたはクリップエンベロープのセレクターで別のパラメーターを選択するか、X-Yフィールドのいずれかのセレクターで借りのパラメーターを選択します。
  • 録音中にプラグインの編集ウィンドウでパラメーターを変更すると、オートメーションデータが自動的に記録されます。録音が停止すると、調整されたプラグインのLiveパネルにオートメーション化されたパラメーターが自動的に追加されます。
  • MIDI・キー・マクロマッピングモードがオンの場合にプラグインのウィンドウでパラメーターを調整すると、Liveのパネルにマッピングを作成します。新しいパネルのエントリが自動的に選択され、すぐさまマップすることができます。

プラグインをトラックに置き、Liveのパネルでそのパラメーターを(任意で)設定したら、プラグインをLiveデバイスのように扱うことができます。

  • MIDIコントローラーメッセージをLiveのパネルのパラメーターすべてにマップすることができます。
  • オーディオエフェクトとインストゥルメントのルールに従い、デバイスチェーンやトラックの別ロケーションにデバイスをドラッグまたはコピーすることができます。
  • クリップエンベロープを使って、連続パラメーターを操作できます。
  • トラックルーティング設定のソースやターゲットとしてアサインし、プラグインのマルチ入力/出力機能を使うことができます。詳しくは、ルーティングとI/Oの章(チャプター 14)をご参照ください。
  • プラグインに対し、独自のインフォテキストを作成することができます。

Macintoshのみ:VSTプラグインには、編集ウィンドウがコンピューターのキー操作の影響を受けないものがあります。一般的に、プラグイン自体の実装エラーであることが考えられます。アンロックコードやシリアルナンバーを入力するのに、プラグインウィンドウに直接入力する必要がある場合は、Shiftキーを押したまま、プラグイン編集ボタンをクリックします。編集ウィンドウが「通常の」操作ウィンドウに表示され、直接入力が可能になります。この機能は、このようなプラグインの制限を回避する目的で追加されています。入力が終わったらウィンドウを閉じ、操作前にプラグインパラメーターを使用し再びウィンドウを開くことをお勧めします。

17.3 VSTプラグイン

17.3.1 VSTプラグインフォルダー

Liveを初めて起動する場合、VSTプラグインを使用する前に、VSTプラグインソースを有効にする必要があります。コンピューターのプラットフォームによっては、使用したいデバイスを含むVSTプラグインフォルダーのロケーションを、Liveに伝える必要があります。VSTソースを設定するには、ブラウザー[Plug-In]パネルの有効ボタンを押すか、CTRL+,(PC)/CMD+,(Mac)を押して[File/Folder]環境設定を開き、[有効ソース]セクションから設定します。そこに[プラグインソース]セクションが表示されます。

VstPlugInFolder.png

VSTプラグインソースをWindowsにセットアップする

Windowsでは、以下のようにしてセットアップを行います。

  1. VSTプラグインカスタムフォルダーエントリを使って、LiveにVSTプラグインのロケーションを知らせます。ブラウズボタンをクリックしてフォルダー検索ダイアログを開き、適切なフォルダーをロケートし選択します。
  2. VSTカスタムフォルダーを選択し、Liveのスキャンが終了するとパスが表示されます。Windowsでは、ブラウズしなくてもLiveがパスのレジストリを見つけることがあります。
  3. VSTプラグインカスタムフォルダーオプションがオンに設定されていることを確認します。オンに設定されていれば、選択されたフォルダーはLiveにおけるVSTプラグインの有効ソースとなります。VSTプラグインカスタムフォルダーオプションをオフにして、VSTプラグインを使わないように設定することもできます。
VstPlugInFolder2.png

Mac OS XにVSTプラグインソースをセットアップする

Mac OS Xでは、以下のようにVSTプラグインのセットアップを行います。

  1. VSTプラグインは、通常、ホームフォルダーの/Library/Audio/Plug-Ins/VSTディレクトリにインストールされています。[システムフォルダー]オプションの[VSTプラグイン使用]から、Liveプラグインのオンとオフを切り換えることができます。
  2. VSTプラグインを保存するフォルダーが別に存在する場合があります(プラグインがLiveでのみ使用されている場合に多く起こる現象です)。この場合、システムフォルダーに加えて(あるいはシステムフォルダーの代わりに)、このVSTプラグインフォルダーを使うことができます。Liveにこのフォルダーのロケーションを伝えるには、VSTプラグインカスタムフォルダーエントリ横のブラウズボタンをクリックしてフォルダー検索ダイアログを開き、このフォルダーをロケートして選択します。
  3. [VSTプラグインカスタムフォルダー]オプションから[VSTプラグインの使用]を選択し、このフォルダーのVSTプラグインをオフにすることができます。

プラグイン設定を完了すると、VSTプラグインフォルダーとサブフォルダー内に検出されたすべてのプラグインがブラウザーに表示されます。

コンピューター上の別のフォルダーに保存されているVSTプラグインを使用することもできます。これを行うには、VSTプラグインが保存されているフォルダーのMac OSまたは Windowsのエイリアスを作成してから、Liveの[File/Folder]環境設定で選択されているVSTプラグインカスタムフォルダー(Mac OS XではVSTプラグインシステムフォルダー)内にエイリアスを置きます。エイリアスは、コンピューター上の別パーティションまたはハードディスクを参照できます。Liveは、設定されているVSTプラグインフォルダーと、そこに含まれるエイリアスフォルダーをスキャンします。

VSTプラグインには、エラーが含まれているものやLiveに対応していないものもあります。こういったプラグインは、スキャン処理中のクラッシュの原因となります。クラッシュすると、Liveを再起動する際にダイアログが表示され、問題を引き起こしているプラグインが表示されます。Liveによるプラグインの検出結果に応じ、プラグインを再スキャンするか、プラグインを無効にするかを選択するダイアログが表示されます。再スキャンを選択した場合、プログラムが再びクラッシュすると、Liveはこのプラグインを無効に切り換えます。このプラグインは、再インストールされるまでブラウザーには表示されなくなります。

17.3.2 VSTプログラムとバンク

VSTプラグインはそれぞれ、プログラムのバンクを「所有」しています。プログラムには、プラグインのコントロール設定値が含まれています。

プラグインのバンクからプログラムを選択するには、タイトルバー下のセレクターを使用します。バンクごとのプログラム数は決まっています。操作は、現在選択されているプログラム内で行われます。つまり、プラグインのコントロールに加えられた変更は、すべてプログラムの一部になります。

VstProgramChooser.png

VSTプラグインプログラムセレクター

VSTプラグインプログラムセレクターと、Liveデバイスプリセットセレクターを混同しないようにしましょう。Liveデバイスのプリセットは、Liveセットとインスタンスすべてが共有しているのに対し、VSTプログラムは、VSTプラグインの特定インスタンスが「専有」しています。

現在のプログラムの名称を変更するには、VSTのデバイスタイトルバーを選択し、[編集]メニューから[プラグインプログラムの名称を変更]コマンドを実行します。新しいプログラム名をタイプ入力したら、Enterキーを押して確定します。

RenamingAVstProgram.png

VSTプラグインプログラムの名前を変更する

VSTプログラムとバンクは、ファイルからインポートできます。VSTプログラムの[ロード]ボタンをクリックすると、通常のファイルを開くダイアログが表示され、希望のファイルをロケートすることができます。

VstProgramBankLoadAndSave.png

VSTのプログラムまたはバンクのロードボタン(左)とプログラムまたはバンクの保存ボタン(右)

Windowsのみ:VSTデバイスプログラムファイル、または VSTデバイスバンクファイルのどちらをロケートするか、ファイルタイプメニューから選択します。

現在選択されているプログラムをファイルとして保存するには、VSTプログラムまたはバンクの[保存]ボタンをクリックし、ファイル保存ダイアログを表示させます。フォーマットメニュー(Macの場合)またはファイルタイプメニュー(Windowsの場合)から[VSTデバイスプログラム]を選択し、フォルダーと名称を選択します。バンク全体をファイルとして保存するには、同じように操作し、ファイルタイプ/フォーマットに[VSTバンク]を選択します。

17.4 Audio Unitsプラグイン

Audio Unitsプラグインは、Mac OS Xでのみ使用可能です。VSTプラグインとほぼ同様に機能します。

AudioUnitsPlugIn.png

Audio Unitsプラグイン

Liveを初めて起動する場合、Audio Unitsプラグインはブラウザーに表示されません。Audio Unitsをプラグインソースとして有効にするには、ブラウザーの[Plug-In]ラベルの[有効]ボタンを押すか、CTRL+,(PC)/CTRL+,(Mac)を押して[File/Folder]設定を開き、[有効ソース]セクションから設定します。そこに[プラグインソース]セクションが表示されます。[Audio Unitsを使用する]をオンにすると、Audio Unitsプラグインが有効になり、プラグインがLiveのブラウザーに表示されます。

Audio Unitsを使用しない場合には、このオプションをオフに切り替えることができます。

AudioUnitsPlugInActivation.png

Audio Unitsプラグインを有効にする

Audio Unitsプラグインには、デバイスモード選択機能を持つものがあります。例えば、リバーブのレンダリングクオリティレベルを選択することのできるプラグインが存在します。こういったセレクターへは、オリジナルのプラグインパネルからしかアクセスできません。プラグインパネルは、プラグイン編集ボタンを使って開くことができます。

AudioUnitsPlugInEditButton.png

Audio Unitsプラグインウィンドウを開く

Audio Unitsには、Liveエフェクトのプリセットと同様に機能するプリセットが付属しています。しかし、このプリセットは読み取り専用となっているため、ブラウザー内をドラッグしてロケーションを変更することはできません。

Audio Unitsプリセットは、.aupresetという拡張子が付いており、以下のディレクトリに保存されます。

ホーム/ライブラリ/Audio/Presets/<メーカー名>/<プラグイン名>

17.5 デバイスの遅延補正

Liveは、Liveとプラグインインストゥルメントとエフェクト(リターントラックのデバイスを含む)によって生じるディレイを自動補正します。ディレイは、デバイスが入力信号と出力結果を処理するのにかかる時間により生じます。補正アルゴリズムは、Liveのトラックをすべて同期に保ち、再生動作と音の再生の間のディレイをできるだけ少なくします。

通常、デバイスディレイ補正を調節する必要はありません。しかし、Live 4以前で作成されたLiveセットは、デバイスディレイ補正なしで開きます。レーテンシー補正のオンとオフを手動で切り換えるには、[オプション]メニューから[ディレイ補正]を選択します。

ディレイ補正がオンの場合、[オプション]メニューで[モニターリング時に低レーテンシー]オプションが選択可能になります。入力モニターリングがオンのトラックのレーテンシー補正のオンとオフを切り替えます。オンの場合、入力モニターリングがオンのトラックのレーテンシーが可能なかぎり低くなりますが、セット内の他のトラックの一部がずれる場合があります(リターントラックなど。それでもディレイ補正は実行されます)。オフの場合、すべてのトラックが同期しますが、入力モニタリングがオンのトラックのレーテンシーが他より高くなる場合があります。

Liveの内部クロックからタイミング情報を得ている、テンポに同期するエフェクトや他のデバイスは、デバイスチェーン内で遅延の原因となるデバイスの後に置かれている場合、ずれて聞こえることがあります。

トラックディレイ(15.7)が異常に大きい場合や、プラグインからレーテンシーがリポートされた場合は、ソフトウェア動作速度が大幅に低下します。インストゥルメントの録音または再生中にレーテンシー関連の問題が生じた場合、デバイスディレイ補正をオフにしてみて下さい(通常にオンにしておくことをおすすめします)。トラックディレイを個別に調節するのも効果的ですが、トラックディレイコントロールは、デバイスのディレイ補正が無効の場合は使用できません。

デバイスディレイ補正は、使用されているトラックとデバイスの数に比例して、CPUに負荷を与えます。

Live 9マニュアル(PDF)をダウンロード

English, Deutsch, 日本語, Español, Français, Italiano