Certains contenus de ce site ne sont pas encore disponibles en français.

15. Routage et entrées/sorties

Dans le contexte de Live, le « routage » est l'agencement des sources et destinations du signal des pistes (c'est-à-dire leurs entrées et sorties). La majeure partie du routage se fait dans la section Entrées/Sorties (I-O) de piste du mélangeur qui offre, pour chaque piste, des sélecteurs pour la source et la destination du signal. La section Entrées/Sorties, accessible par l'option « Entrées/Sorties » du menu Affichage, est la « baie de connexion » de Live.

La section Entrées/Sorties peut être indépendamment affichée ou masquée dans les écrans Session et Arrangement. Faites alterner sa visibilité à l'aide du sélecteur de section E/S (I-O) du mélangeur, ou via l'option Entrées/Sorties du menu Affichage.

La section Entrées/Sorties du mélangeur et les sélecteurs de section mélangeur.

Pour chaque piste pouvant reproduire des clips, la section In/Out a la même disposition :

  • La paire de sélecteurs du haut (« Audio/MIDI From ») détermine l'entrée de la piste. Les pistes audio ont une entrée audio, et les pistes MIDI une entrée MIDI. Les pistes de retour reçoivent en entrée les départs correspondants (16.4).
  • Les boutons de sélection Monitor sélectionnent le mode d'écoute de contrôle : les conditions sous lesquelles l'entrée de la piste est entendue à travers la piste.
  • La paire de sélecteurs du bas (« Audio/MIDI To ») détermine la sortie de la piste. Toutes les pistes ont des sorties audio, exceptées les pistes MIDI sans instruments. Rappelez-vous que les instruments convertissent le MIDI en audio (4.8).

Dans une paire de sélecteurs, celui du haut détermine la catégorie du signal (« Ext. », par exemple, pour des connexions externes via une interface audio ou MIDI), et se nomme sélecteur du type d'entrée/sortie. Si ce type de signal offre des sous-sélections ou canaux, le sélecteur du bas, ou sélecteur de canal d'entrée/sortie, permet de les choisir. Avec notre exemple « Ext. », il s'agirait des entrées et sorties audio/MIDI individuelles.

15.1 Monitoring

Le « Monitoring », dans le contexte de Live, consiste à envoyer le signal d'entrée d'une piste en sortie de cette piste. Supposons que vous ayez configuré une piste audio pour recevoir en entrée le signal d'une guitare. Le monitoring permet que le signal de votre jeu à la guitare atteigne la sortie de la piste, via la chaîne de périphériques de la piste. Si la sortie de la piste est envoyée au « Master », vous pouvez entendre le signal de la guitare, traité par les effets utilisés quels qu'ils soient (et retardé de la latence induite par l'interface audio matérielle), au travers de vos enceintes.

La section Entrées/Sorties offre, pour chaque piste audio et MIDI, des boutons de sélection Monitor ayant les trois options suivantes :

  • Le réglage Auto de monitoring par défaut est adapté aux applications d'enregistrement les plus simples : le monitoring est activé quand la piste est armée (prête à l'enregistrement) (17), mais désactivé tant que la piste reproduit des clips.
Boutons d'armement de piste audio et MIDI.
  • Pour écouter en permanence l'entrée de la piste, sans tenir compte du fait qu'elle soit armée ou qu'elle reproduise des clips, choisissez In. Ce réglage transforme en réalité la piste en ce que l'on appelle un auxiliaire ou « Aux » dans certains systèmes : la piste ne sert pas à l'enregistrement mais à recevoir un signal d'ailleurs. Avec ce réglage, la sortie des clips est coupée. Un réglage de monitoring « In » se voit facilement, même quand la section Entrées/Sorties est masquée, grâce à la coloration en bleu du commutateur d'activation de piste.
  • Le monitoring peut être entièrement désactivé en choisissant l'option Off. C'est utile pour enregistrer des instruments acoustiques avec « retour par écoutes de contrôle » en cas d'emploi d'une console de mixage externe pour les retours, ou d'une interface audio matérielle avec option « monitoring direct » qui court-circuite l'ordinateur pour éviter la latence. Généralement, il est préférable de travailler avec une interface audio donnant des latences négligeables (quelques millisecondes). Si vous enregistrez dans Live avec le monitoring désactivé (« Off »), vous pouvez avoir à régler la Latence générale dans les Préférences Audio, décrites dans le didacticiel sur le réglage des Préférences Audio intégré au programme.

Si plusieurs pistes sont sélectionnées, presser un de leurs boutons Monitor applique cette sélection à toutes les pistes sélectionnées.

Les boutons Monitor peuvent également être ramenés à leur état par défaut. Lorsque la section I/O est déployée, vous pouvez presser la touche Supprimer pour ramener les boutons Monitor à leur valeur par défaut (« Off » pour les pistes audio et « Auto » pour les pistes MIDI), ou vous pouvez sélectionner l'option « Retour aux réglages par défaut » du menu Édition.

15.2 Entrées/Sorties audio externes

Les entrées d'une interface audio se sélectionnent en choisissant « Ext. In » dans le sélecteur de type d'entrée d'une piste audio. Le sélecteur de canal d'entrée propose alors le choix entre les canaux d'entrée individuels. Les choix de ce sélecteur ont chacun des indicateurs de niveau à côté de leur nom pour vous aider à détecter la présence d'un signal et son éventuelle saturation (quand l'indicateur de niveau clignote en rouge). Le réglage des sorties de l'interface audio se fait de la même façon via la paire de sélecteurs de sortie. Si plusieurs pistes sont sélectionnées, tout changement apporté à un de ces sélecteurs s'appliquera à toutes les pistes sélectionnées.

La liste des entrées et sorties disponibles dépend des Préférences Audio, qui peuvent être obtenues via l'option « Configure... » des sélecteurs de canal d'entrée et de sortie. Notez que les Préférences Audio donnent aussi accès aux dialogues de configuration de canal qui déterminent quelles entrées et sorties sont utilisées, et si elles sont disponibles pour Live en mono ou en paires stéréo. Essentiellement, le dialogue Configuration de canal indique à Live ce qu'il est nécessaire de savoir quant à la façon dont l'ordinateur est connecté aux autres composants audio de votre studio.

Vous pouvez renommer tous les canaux d'entrée et de sortie qui apparaissent dans les boîtes de dialogues de configuration de canal. En cas de modification, le ou les nouveaux noms s’afficheront dans le sélecteur déroulant de canal d'entrée/sortie correspondant. Vous pouvez renommer les canaux plus rapidement en utilisant la touche Tab pour vous déplacer de l’un à l’autre. Notez que les noms modifiés sont toujours associés à leurs périphériques audio respectifs.

15.2.1 Conversions Mono/Stéréo

Quand un signal mono est choisi comme entrée de piste audio, la piste enregistre des échantillons mono ; sinon elle enregistre des échantillons stéréo. Les signaux sont toujours stéréo dans la chaîne de périphériques de la piste, même si l'entrée de piste est mono ou si la piste fait jouer des échantillons mono.

Le mono est simplement transformé en stéréo par emploi du même signal sur les canaux gauche et droit. Quand une piste est dirigée vers une entrée mono, les signaux gauche et droit sont ajoutés l'un à l'autre et atténués de 6 dB pour éviter l'écrêtage.

15.3 Entrées/Sorties MIDI externes

Le MIDI venant de l'extérieur est routé vers Live comme de l'audio. Avec le sélecteur de type d'entrée d'une piste MIDI, vous pouvez soit choisir un port d'entrée MIDI spécifique, soit toutes les entrées (« All Ins »), ce qui correspond à l'entrée fusionnant tous les ports MIDI externes. Le sélecteur de canal d'entrée propose les canaux d'entrée individuels du port MIDI sélectionné et le signal issu de la fusion de tous les canaux, « All ». Comme pour les entrées audio, le sélecteur de canal d'entrée a aussi des indicateurs de niveau à côté de chaque choix pour représenter l'activité sur le canal d'entrée correspondant. Si plusieurs pistes MIDI sont sélectionnées, tout changement apporté à un de ces sélecteurs s'appliquera à toutes les pistes sélectionnées.

15.3.1 La liste des ports MIDI dans les Préférences

La liste des ports MIDI dans les Préférences.

Vous pouvez choisir quels ports MIDI seront rendus disponibles pour Live en utilisant la section MIDI Ports des Préférences Link/Tempo/MIDI. Tous les ports d'entrée et de sortie disponibles y sont listés. Pour que les pistes de Live reçoivent/envoient du MIDI depuis/vers un port MIDI spécifique, le commutateur correspondant dans la colonne Piste doit être réglé sur On. Vous pouvez utiliser n'importe quel nombre de ports MIDI pour l'entrée et la sortie de piste ; les sélecteurs d'entrée/sortie du mélangeur leur permettent d'être affectés individuellement.

15.3.2 Jeu en MIDI avec le clavier de l'ordinateur

Le clavier de l'ordinateur peut être employé pour générer des notes MIDI en frappant sur ses touches. Pour activer le clavier MIDI d'ordinateur, utilisez le bouton Clavier MIDI d'ordinateur de la barre de contrôle, ou le raccourci M pour ce choix dans le menu Options.

Activation du clavier MIDI d'ordinateur.

La rangée centrale des touches de lettres du clavier fera jouer les notes correspondant aux touches blanches d'un piano, en partant sur la gauche de la note C3 (do3). Les touches noires d'un piano correspondent à la rangée supérieure des touches de l'ordinateur. Les quatre lettres les plus à gauche dans la rangée inférieure du clavier (W, X, C, et V sur un clavier français) servent à transposer la tessiture et à régler la dynamique, comme suit :

  • Les touches les plus à gauche (W et X) règlent la tessiture du clavier par octave.
  • Les deux touches suivantes (C et V) règlent la dynamique des notes jouées sur ce clavier par intervalles de vingt (20, 40, 60 et ainsi de suite).

Dans ce cas, quand le clavier de l'ordinateur est réglé pour envoyer des notes entre C3 et C4, les touches sont associées aux notes MIDI de façon à ce que la rangée centrale du clavier (QSDF...) se charge des slots d'échantillons de l'échantillonneur de percussions Impulse (26.5). Cela signifie que vous pouvez jouer et enregistrer des patterns de batterie directement depuis le clavier de l'ordinateur.

Notez que quand le clavier MIDI d'ordinateur est activé, il « vole » des touches qui seraient sinon assignées à la télécommande (29.2.5) d'éléments de l'interface de Live. Pour empêcher cela, vous pouvez désactiver le clavier MIDI d'ordinateur quand il n'est pas nécessaire.

15.3.3 Connexion de synthétiseurs externes

Le routage du MIDI vers un synthétiseur externe est simple : le sélecteur de type de sortie est réglé sur le port MIDI auquel est connecté le synthétiseur, quel qu'il soit ; le sélecteur de canal de sortie sert à choisir le canal MIDI d'émission.

En plus du routage via la section Entrée/Sortie d'une piste, il est aussi possible de router depuis l'intérieur d'une chaîne de périphériques d'une piste en utilisant le périphérique External Instrument (instrument externe) (26.4). Dans ce cas, vous pouvez envoyer du MIDI au synthétiseur externe et récupérer son audio — tout cela dans une même piste. (Note : le périphérique External Instrument n'est pas disponible dans les éditions Intro et Lite.)

Important : si vous employez un synthétiseur à clavier à la fois comme clavier maître pour jouer dans Live et comme générateur de sons, alors veuillez bien vérifier la fonction « Local Off » du synthétiseur. Tout synthétiseur a cette fonction, qui isole le clavier du générateur de sons, vous permettant de traiter ces deux composants comme des appareils différents. Cela vous autorise à employer Live comme cœur de votre studio MIDI, recevant le MIDI du clavier et répartissant le MIDI entrant, ainsi que celui des clips, de façon appropriée.

15.3.4 Témoins d'activité MIDI In/Out

La barre de contrôle de Live contient trois paires de « diodes » témoins de l'activité MIDI en entrée et en sortie. Ces témoins vous indiquent non seulement la présence de signaux, mais aussi leur emploi. Dans chaque paire, le témoin du haut clignote quand un message MIDI est reçu, et celui du bas quand un message MIDI est transmis.

Les témoins MIDI de la barre de contrôle.

Les trois paires de témoins représentent, de gauche à droite :

  1. Les signaux d'horloge et de Timecode MIDI utilisés pour synchroniser Live avec d'autres séquenceurs (32). Notez que ce jeu de témoins n'est visible que quand une source de synchro externe a été activée dans la liste des ports MIDI dans les Préférences ;
  2. Les messages MIDI utilisés pour télécommander les éléments d'interface utilisateur de Live (29)  ;
  3. Les messages MIDI entrants et sortants pour les pistes MIDI de Live.

Les messages MIDI qui sont affectés à la télécommande des éléments d'interface utilisateur de Live sont « absorbés » par cette affectation et ne sont pas transmis aux pistes MIDI. C'est une cause fréquente de confusion qui peut aisément se résoudre en regardant les indicateurs.

15.4 Ré-échantillonnage ou Resampling

La sortie Master de Live peut être dirigée vers une piste audio individuelle et y être enregistrée, ou ré-échantillonnée. Le ré-échantillonnage peut être un outil amusant et utile, car il vous permet, à partir de ce qui se passe actuellement dans un Set Live, de créer des échantillons pouvant ensuite être immédiatement intégrés. Il peut servir à enregistrer des pistes incluant des périphériques sollicitant beaucoup le processeur, afin de les supprimer ensuite, ou à une pré-écoute rapide avant conversion sur disque (5.2.3).

L'option de ré-échantillonnage « Resampling » du sélecteur de type d'entrée de toute piste audio dirigera la sortie Master vers cette piste. Vous pouvez alors décider exactement comment vous ré-échantillonnerez et couperez, mettrez en solo ou réglerez autrement les pistes envoyées à la sortie Master. Vous pourrez employer l'indicateur de volume Master pour vous assurer que le niveau est aussi haut que possible sans écrêtage (signalé en rouge dans l'indicateur). Vous pouvez alors armer la piste et enregistrer dans n'importe lequel de ses slots de clip vides (17.3.2). Notez que la propre sortie de la piste d'enregistrement sera coupée durant le ré-échantillonnage, et ne sera donc pas incluse dans l'enregistrement.

Les échantillons créés par ré-échantillonnage seront conservés dans le dossier Projet du Set actuel (5.6), dans Samples/Recorded. Jusqu'à ce que le Set soit sauvegardé, ils demeurent à l'emplacement spécifié pour le dossier temporaire (17.8).

15.5 Routages internes

Le mélangeur et les périphériques de routage externe de Live permettent des routages entre pistes. Ces routages, bien que potentiellement sources d'une certaine confusion, offrent de nombreuses et appréciables options créatives et techniques. Via le mélangeur, le routage entre pistes peut fonctionner de deux façons :

  1. La piste A est configurée pour envoyer son signal de sortie à la piste B. C'est possible car chaque piste qui peut recevoir un signal de sortie du type approprié de la piste A apparaît dans son sélecteur de type de sortie.
  2. La piste B est configurée pour recevoir son signal d'entrée de la piste A. Cela fonctionne car chaque piste qui produit un signal d'entrée de type approprié apparaît dans le sélecteur de type d'entrée de la piste B.
Deux façons de router la piste A dans la piste B.

Les deux approches adressent la sortie de la piste A à la piste B. L'approche 1 laisse intacts les réglages d'entrée/sortie de la piste B, et nous pouvons à tout moment ajouter d'autres pistes devant envoyer leur sortie à la piste B. C'est la méthode de choix pour les routages « plusieurs-en-un » comme les pré-mixages ou quand plusieurs pistes MIDI font jouer le même instrument. Dans ce scénario, mettre en solo la piste B vous permettra toujours d'entendre la sortie des pistes qui y entrent. Vous pouvez aussi mettre en solo la piste A et entendre son signal de sortie. Dans ce cas, toutes les autres pistes sont coupées, y compris celles qui entrent aussi dans la piste B. Techniquement, ce que vous entendez est la sortie de la piste B dont tout a été retiré sauf le signal de la piste A.

L'approche 2, à l'opposé, laisse la piste A sans changement excepté le fait que la piste B se branche à sa sortie. Nous pouvons facilement ajouter d'autres pistes comme la piste B qui se branchent toutes en sortie de la piste A. L'empilage d'instruments est un bon exemple d'une telle configuration de routage « une-vers-plusieurs ».

15.5.1 Points de routage interne

Les signaux voyagent depuis les pistes de Live dans leurs chaînes de périphériques respectives puis dans le mélangeur de pistes, où elles peuvent subir un réglage de panoramique ou avoir leur niveau modifié par les faders de piste.

Lorsque le sélecteur d'entrée Audio From d'une piste est réglé sur une autre piste (comme décrit dans l'approche 2 de la section précédente), le signal reçu peut être pris depuis un des trois points proposés par le sélecteur de canal d'entrée : Pre FX, Post FX ou Post Mixer.

Points de branchement pour le routage de piste.
  • Pre FX prend le signal venant directement d'une piste, avant qu'il ne soit passé par les chaînes de périphériques de la piste (FX) ou par le mélangeur. Par conséquent, les changements apportés aux périphériques de cette piste ou au mélangeur n'ont pas d'effet sur le signal ainsi pris. Mettre en solo une piste qui reçoit une autre piste prise avant effets (Pre FX) vous permettra d'entendre la piste ainsi prise.
  • Post FX prend le signal en sortie des chaînes de périphériques de la piste (FX), mais avant qu'il ne soit passé par le mélangeur de pistes. Les changements apportés aux périphériques de cette piste se feront donc entendre dans le signal ainsi pris, mais pas ceux apportés aux réglages du mélangeur. Mettre en solo une piste qui reçoit une autre piste prise après effets (Post FX) vous permettra d'entendre la piste ainsi prise.
  • Post Mixer prend la sortie finale d'une piste, après passage dans les chaînes de périphériques de la piste et dans le mélangeur. Mettre en solo une piste qui reçoit une autre piste prise Post Mixer ne vous permettra pas d'entendre la piste ainsi prise.

Points de routage dans les Racks

Points de branchement pour chaque chaîne dans une piste.

Si une piste a un ou plusieurs Racks d'instruments ou d'effets (20) dans sa chaîne de périphériques, les points de routage internes (Pre FX, Post FX et Post Mixer) seront disponibles pour chaque chaîne appartenant au Rack. Si une piste contient un ou plusieurs Racks de batterie (20.6), les points de routage internes seront disponibles pour chaque chaîne de retour du Rack. Chaque Rack sera aussi listé dans le sélecteur de canal d'entrée :

  • (Nom du Rack) | (Nom de la chaîne) | Pre FX — Le signal sera pris au point d'entrée dans le Rack, avant qu'il n'atteigne la chaîne de périphériques.
  • (Nom du Rack) | (Nom de la chaîne) | Post FX — Le signal sera pris à la fin de la chaîne, mais avant son passage dans le mélangeur de chaînes.
  • (Nom du Rack) | (Nom de la chaîne) | Post Mixer — Le signal sera pris en sortie du mélangeur de chaînes, juste avant le point où toutes les chaînes du Rack sont réunies pour créer le signal de sortie du Rack.

Mettre en solo une piste qui reçoit une chaîne prise en n'importe lequel de ces points vous permettra toujours d'entendre la sortie en ce point.

15.5.2 Emploi du routage interne

Cette section présente plus en détail plusieurs exemples de routage interne.

Enregistrement après effets

Considérons que vous branchez une guitare dans Live, construisez un morceau piste par piste et superposez prise sur prise. Il est assurément très performant d'avoir une chaîne d'effets indépendante par piste pour appliquer différents effets à différentes prises — après coup. Vous pouvez toutefois vouloir faire passer le signal de la guitare au travers des effets (un noise gate ou une modélisation d'ampli, par exemple) avant l'étage d'enregistrement, et ainsi enregistrer le signal après effets.

Un exemple de configuration pour l'enregistrement après effets.

Cela s'accomplit facilement en dédiant une piste audio spéciale au traitement et à l'écoute de contrôle ou « monitoring » du signal de guitare entrant. Nous appelons cette piste « Guitar » et faisons glisser les effets désirés dans sa chaîne de périphériques. Nous n'enregistrons pas directement dans la piste Guitar ; à la place, nous créons d'autres pistes pour servir à l'enregistrement. Ces pistes sont toutes configurées pour recevoir leur entrée Post FX de la piste Guitar. Notez que nous pourrions aussi prendre la piste Guitar après le mélangeur (Post Mixer) si nous voulions enregistrer ses réglages de niveau ou de panoramique.

En ce qui concerne le monitoring, nous réglons le bouton de sélection Monitor de la piste Guitar sur In, car nous voulons toujours entendre notre guitare au travers de cette piste, quoi qu'il se passe dans Live. Les boutons de sélection Monitor des autres pistes sont réglés sur Off.

Enregistrer le MIDI en audio

Quand on travaille avec le MIDI et de complexes instruments audio, il est parfois préférable d'enregistrer l'audio résultant plutôt que le MIDI entrant. Une seule note MIDI peut par exemple demander à Absynth de Native Instruments de produire quelque chose qui sonne plus comme un morceau de musique que comme un simple son. Cette sortie se prête plus à une représentation comme une forme d'onde audio que comme une seule note dans un clip MIDI, particulièrement si l'on compare les options d'édition.

Enregistrer la sortie d'un instrument complexe dans des pistes audio.

Une configuration similaire à celle décrite ci-dessus (15.5.2) fait l'affaire. Nous avons une piste MIDI accueillant l'instrument virtuel, et nous utilisons des pistes audio supplémentaires pour enregistrer le résultat audio du jeu avec l'instrument.

Créer des pré-mixages

Pré-mixer les éléments individuels d'un kit de batterie.

Supposons que les éléments individuels d'un kit de batterie arrivent sur des pistes séparées pour un enregistrement multipiste. Au mixage, nous pouvons facilement changer les volumes de chaque percussion, mais le réglage du volume de la totalité du kit de batterie par rapport au reste de la musique est chose moins pratique. Par conséquent, nous ajoutons une nouvelle piste audio pour pré-mixer les éléments de batterie. Les pistes individuelles de batterie sont toutes réglées pour arriver à la piste de pré-mixage, qui est elle envoyée au Master. La piste de pré-mixage nous donne un contrôle pratique sur le volume de la totalité du kit de batterie.

Sinon, vous pouvez réunir les pistes de batterie distinctes en une piste de groupe (16.3) pour encore plus de flexibilité. Cela crée automatiquement les routages de sortie nécessaires et vous permet aussi de masquer ou d'afficher les pistes qui la compose.

Pré-mixage par réglage du type de sortie d'une piste sur Sends Only (départs uniquement)

Une troisième possibilité est l'emploi des pistes de retour de Live pour le pré-mixage. Cela se fait en sélectionnant l'option Sends Only (départs uniquement) comme type de sortie d'une piste, puis en montant la commande de départ Send comme désiré. La piste de retour correspondante servira alors de canal de pré-mixage.

Plusieurs pistes MIDI pour faire jouer le même instrument

Considérez une piste MIDI contenant un instrument virtuel — un Simpler faisant par exemple jouer un son de « nappe ». Nous avons déjà enregistré des clips MIDI dans cette piste quand nous réalisons que nous aimerions ajouter une prise du même instrument, mais de façon indépendante et parallèle. Nous ajoutons donc une autre piste MIDI. Nous pouvons à présent faire glisser un autre Simpler dans la nouvelle piste, mais nous aimerions vraiment ré-utiliser le Simpler de la piste de nappe, afin que le changement du son de nappe affecte les notes des deux pistes.

Diriger une piste MIDI supplémentaire vers une piste MIDI existante pour ré-utiliser son instrument.

Cela s'obtient en réglant le sélecteur de type de sortie de la nouvelle piste sur « Pad » (son de nappe en anglais). Notez que le sélecteur de canal de sortie offre maintenant une sélection de destinations : nous pouvons adresser la sortie de la nouvelle piste soit à l'entrée de la piste contenant la nappe, soit directement au Simpler. L'option « Track In » du canal de sortie représente le signal entrant dans la piste de nappe (le signal à enregistrer), ce qui n'est pas ce que nous voulons. Nous sélectionnons à la place « Simpler Ch. 1 » pour directement envoyer le MIDI de la nouvelle piste au Simpler, court-circuitant les étages d'enregistrement et de monitoring. Avec cette configuration, nous pouvons choisir d'enregistrer de nouvelles prises sur l'une ou l'autre des pistes et ces prises feront toutes jouer le même son de nappe.

L'instrument a été isolé sur une piste dédiée.

Nous pouvons nous inquiéter du fait que neutraliser (couper) la piste de nappe (en réglant sur off son commutateur d'activation) coupe aussi l'autre piste MIDI. Pour être précis, l'autre piste continue de jouer, mais son MIDI est joué par un instrument qui est sorti du mixage. Cela peut facilement se solutionner en coupant les clips de la piste de nappe et en les collant dans une troisième piste qui peut être indépendamment coupée (et qui peut contenir ses propres effets MIDI). La piste de nappe d'origine agit maintenant comme un simple conteneur d'instrument. Comme nous n'allons pas enregistrer de nouveaux clips dans cette piste, nous pouvons régler son sélecteur de type d'entrée sur « No Input », ce qui fait disparaître son bouton d'armement et aide à éviter toute confusion quand la section Entrées/Sorties du mélangeur est masquée.

Branchement de sorties individuelles à partir d'un instrument

Certains instruments logiciels, comme l'échantillonneur de percussion Impulse de Live, offrent de multiples sorties audio pour les signaux qu'ils produisent. Par défaut, Impulse mixe la sortie de ses huit slots d'échantillons en interne et produit le mixage en sortie audio de l'instrument. Tous les effets audio à la suite d'Impulse dans la même piste traitent le signal composite. Quelquefois, il est souhaitable de sortir un élément de batterie du mixage en vue d'un traitement individuel par effets et mixage. C'est possible car Impulse offre ses emplacements d'échantillons comme sources audio aux autres pistes.

Utiliser les sorties individuelles d'Impulse pour traiter séparément les échantillons.

Nous créons simplement une piste audio et choisissons la piste où se trouve Impulse dans son sélecteur de type d'entrée Audio From. Le sélecteur de canal d'entrée offre maintenant, en plus des options Pre FX, Post FX et Post Mixer, les huit sorties individuelles d'Impulse, libellées selon l'échantillon utilisé dans chaque slot. Notez que diriger une sortie individuelle d'Impulse vers une autre piste fait automatiquement sortir ce signal du mixage interne d'Impulse. Cette commodité n'est toutefois pas un comportement standard de la plupart des plug-ins d'instruments. Mettre en solo une piste qui reprend un des slots d'échantillon d'Impulse vous permettra toujours d'entendre la sortie de ce slot.

Emploi de plug-ins d'instruments multitimbraux

De nombreux plug-ins d'instruments acceptent le fonctionnement multitimbral. Un instrument multitimbral, c'est comme plusieurs instruments en un seul, chaque « partie » (ou quel que soit le terme employé par le fabricant) recevant le MIDI sur un canal MIDI à part. Habituellement, l'instrument multitimbral offre des sorties individuelles pour que les parties puissent être séparément dirigées vers le mélangeur ou « mixer ». Ou bien, l'instrument peut avoir son propre pré-mixer.

Pistes fournissant le MIDI aux parties d'un instrument multitimbral et en recevant l'audio.

Envoyer du MIDI à un instrument multitimbral depuis le mélangeur est une variation d'un cas décrit ci-dessus (15.5.2). Une piste MIDI accueille l'instrument multitimbral et des pistes MIDI supplémentaires servent à piloter ses parties individuellement. Chaque piste MIDI supplémentaire a son sélecteur de type de sortie pointé sur la piste qui contient l'instrument, et son sélecteur de canal de sortie sur le canal MIDI visé. Des pistes audio supplémentaires peuvent alors être employées pour recevoir les sorties individuelles de l'instrument, comme décrit précédemment (15.5.2).

Il est aussi possible d'utiliser le périphérique External Instrument pour router du MIDI vers (et de l'audio depuis) les sorties secondaires de plug-ins multitimbraux. Ce scénario élimine le besoin de créer une piste audio supplémentaire pour chaque sortie connectée :

  1. Insérez l'instrument multitimbral dans une piste MIDI.
  2. Insérez un périphérique External Instrument dans une autre piste MIDI.
  3. Sélectionnez la piste qui contient l'instrument dans le premier sélecteur MIDI To du périphérique External Instrument.
  4. Sélectionnez le canal MIDI vers lequel router avec le second sélecteur du périphérique External Instrument.
  5. Avec le sélecteur Audio From d'External Instrument, sélectionnez une sortie secondaire sur l'instrument auquel vous envoyez du MIDI.

Répétez les étapes 2-5 pour gérer les sources et retours d'autres composants de votre instrument multitimbral. Vous pouvez aussi mettre tout le système des périphériques External Instrument sur une seule piste, en plaçant chacun dans une chaîne de périphériques de Rack.

Notez que les sorties principales de l'instrument multitimbral continueront d'arriver sur la piste qui contient l'instrument — seules les sorties auxiliaires sont disponibles pour le périphérique External Instrument.

Source des entrées de Sidechain

Certains effets ont ce que l'on appelle des « entrées de sidechain », c'est-à-dire des entrées pour une chaîne de traitement ou détection parallèle. Un Vocoder, par exemple, impose des caractéristiques spectrales prises sur un signal (disons un mot parlé) à un autre signal, par exemple une nappe de cordes. Le Vocoder est inséré comme un effet audio dans la piste des cordes. Il a une entrée sidechain pour le signal vocal, qui doit être fourni par une autre piste. Donc, nous créons une piste audio supplémentaire nommée « Speech » (paroles) et réglons son sélecteur de type de sortie sur la piste « Strings » (cordes). Avec le sélecteur de canal de sortie, nous choisissons l'entrée sidechain du Vocoder.

Envoi d'un signal de paroles vers l'entrée Sidechain d'un Vocoder.

Certains plug-ins de Vocoder intègrent un synthétiseur pour générer le signal « porteur ». Dans ce cas, la seule différence avec la procédure ci-dessus est que l'instrument Vocoder est déposé dans une piste MIDI. L'entrée audio de sidechain est alimentée comme décrit ci-dessus.

Un certain nombre de périphériques Ableton ont leurs propres commandes de sidechain avec des sélecteurs de routage intégrés correspondant à ceux trouvés dans les pistes. Donc quand vous utilisez ces périphériques, il n'est pas nécessaire de suivre la procédure ci-dessus — vous pouvez simplement sélectionner la source de sidechain depuis le périphérique lui-même.

Superposition d'instruments

Supposons que nous ayons une piste MIDI contenant un instrument produisant un son de cordes, que nous aimerions grossir en ajoutant un son de cuivres jouant les mêmes notes. Cela peut facilement se faire en ajoutant une piste MIDI qui contient un instrument jouant le son de cuivres et en réglant son sélecteur de type d'entrée de façon à récupérer le signal après effet (Post FX) de la piste de cordes.

Emploi d'une piste MIDI auxiliaire pour superposer des instruments.

Vous vous demandez sans doute comment cela fonctionne, étant donné que la sortie de la piste de cordes est de l'audio et non du MIDI. Quand on dirige du MIDI vers une autre piste, le MIDI est pris au dernier étage possible, c'est-à-dire après tout effet MIDI et juste avant l'instrument.

Download Live 11 manual (PDF)

English, Deutsch, 日本語, Español, Français, Italiano, 简体中文