Contact support or Ask other Live users

17. Working with Instruments and Effects

Every track in Live can host a number of devices. These devices can be of three different sorts:

  • MIDI effects act upon MIDI signals and can only be placed in MIDI tracks.
  • Audio effects act upon audio signals and can be placed in audio tracks. They can also be placed in MIDI tracks as long as they are “downstream“ from an instrument.
  • Instruments are devices that reside in MIDI tracks, receive MIDI and output audio.

The Device View is where you insert, view and adjust the devices for the selected track. To select a track and open the Device View to access its devices, double-click the track’s name. The Device View appears in the bottom area of the Live screen.

DevicesInDeviceView.png
Devices in the Device View.

To save space in the Device View, a device can be collapsed by double-clicking on its title bar or by choosing Fold from its right-click (PC) / CTRL - click (Mac) context menu.

FoldedDevices.png
Devices Can Be Folded.

To learn about a particular device and how to operate it, consult the Live Audio Effect Reference (see Chapter 22), Live MIDI Effect Reference (see Chapter 23) or the Live Instrument Reference (see Chapter 24).

To learn about creating and using custom groupings of instruments and effects, check out the Instrument, Drum and Effect Racks chapter (see Chapter 18).

Get “hands-on“ with devices by assigning their parameters to MIDI or key remote control (see Chapter 26).

17.1 Using the Live Devices

LiveDevicesInBrowser.png
Devices in Live’s Browser.

Live’s built-in devices can be accessed in the browser. You will notice that Live’s Synths, Audio Effects, and MIDI Effects each have their own labels in the browser’s sidebar.

The easiest way to place a device in a track is to double-click on it in the browser, which creates a new track to hold the device. Alternatively, select a destination track by clicking within it, then select a device or preset in the browser and press Enter to add it to the selected track.

You can also drag devices into tracks or drop areas in the Session and Arrangement Views, or into the Device View. Dragging a sample to the Device View of a MIDI track creates a Simpler instrument with this sample loaded.

Note : If you are using an external input signal to feed your Live track using the default settings, the track’s Arm button in the mixer must be activated in order to hear the input through the devices in your track’s device chain. On MIDI tracks, this is normally activated automatically when inserting an instrument.

ArmButtons.png
MIDI and Audio Track Arm Buttons.

This is how you would play live instruments through effects on a track, for example, or use a MIDI keyboard’s input to play a track’s instrument. Note that you can easily move from this setup into recording new clips for further use in Live (see Chapter 16). If you have alternative monitoring preferences, please see the Monitoring section (see 14.1) to learn how to make these settings.

To add another device to the track, simply drag it there or double-click its name to append it to the device chain. Signals in a device chain always travel from left to right.

You can drop audio effects in at any point in an audio track’s device chain, keeping in mind that the order of effects determines the resulting sound. The same is true for a MIDI track’s device chain.

If you drop an instrument into a MIDI track’s device chain, be aware that signals following (to the right of) the instrument are audio signals, available only to audio effects. Signals preceding (to the left of) the instrument are MIDI signals, available only to MIDI effects. This means that it’s possible for a MIDI track’s device chain to hold all three types of devices: first MIDI effects, then an instrument, and finally audio effects.

DevicesInDeviceView.png
A MIDI Track’s Device Chain Can Contain All Three Device Types.

To remove a device from the chain, click on its title bar and press your computer’s Backspace or Delete key, or select Delete from the Edit menu. To change the order of devices, drag a device by its title bar and drop it next to any of the other devices in the Device View. Devices can be moved to other tracks entirely by dragging them from the Device View into the Session or Arrangement Views.

Edit menu commands such as cut, copy, paste and duplicate can be used on devices. Pasted devices are inserted in front of the selected device. You can paste at the end of a device chain by clicking in the space after the last device, or by using the right arrow key to move the selection there. Generally, devices can be placed, reordered and deleted without interrupting the audio stream.

DeviceActiveSwitch.png
Device Activator Switches.

Devices are turned on and off using their Activator switches. Turning a device off is like temporarily deleting it: The signal remains unprocessed, and the device does not consume CPU cycles. Live devices generally do not load down the CPU unless they are active. For more information, please refer to the CPU load section (see 31.1). The Freeze Track command discussed there is especially helpful when working with CPU-intensive devices.

Devices in Live’s tracks have input and output level meters. These meters are helpful in finding problematic devices in the device chain: Low or absent signals will be revealed by the level meters, and relevant device settings can then be adjusted, or the device can be turned off or removed.

MetersBetweenDevices.png
The Level Meters Between Devices in a Chain.

Note that no clipping can occur between devices because there is practically unlimited headroom. Clipping can occur when an overly strong signal is sent to a physical output or written to a sample file.

Further information about track types in Live can be found in the Routing and I/O chapter (see Chapter 14), including information on using return tracks to distribute the effect of a single device amongst several tracks. After reading about using devices in Live, it might also be interesting to look into clip envelopes (see Chapter 20), which can automate or modulate individual device parameters on a per-clip basis.

17.1.1 Live Device Presets

Every Live device can store and retrieve their parameter settings as presets . Each device appears in the content pane of the browser as a folder that can be opened to reveal its presets.

PresetsInBrowser.png
Presets in the Browser.

You can browse and load presets quickly with the computer keyboard:

  • Scroll up and down using the up and down arrow keys.
  • Close and open device folders using the left and right arrow keys.
  • Press Enter to load a device or preset.

Pressing Q or clicking a device’s Hot-Swap Presets button will temporarily link the browser to a device and reveal its presets. With the device and browser linked in this manner, you can quickly browse and audition different presets. In Hot-Swap Mode, devices and presets are loaded automatically upon selection in the browser. To load a device’s default factory settings, select the parent folder of its presets (i.e., the one with the device’s name) from the browser.

Note that pressing Q to enter Hot-Swap mode will swap from the last selected device on a given track. If no device was selected, swap will be enabled from the first audio effect (on audio tracks) or the instrument (on MIDI tracks).

BrowsePresetsButton.png
The Hot-Swap Presets Button.

The link between the browser and the device will be broken if a different view is selected, or if the Q key or the Hot-Swap button is pressed again. Preset hot-swapping can also be cancelled with a press of the Esc key or by pressing the close button in the Hot-Swap bar at the top of the browser.

Note that although importing via the browser is the recommended method, presets can also be dropped directly into Live from the Explorer (Windows)/Finder (Mac).

Saving Presets

You can create and save any number of your own presets in the browser’s User Library .

SavePresetsButton.png
The Save Preset Button.

Click the Save Preset button to save a device’s current settings (including any custom info text) as a new preset. You will be redirected to the browser, where you can press Enter to use Live’s suggested name, or you can type one of your own. To cancel preset saving, press the Esc key. You can also save presets to specific folders in the Places section of the browser (such as your Current Project folder) by dragging from the title bar of the device and dropping into the browser location of your choice.

For detailed information on what can be done with the browser, please see the Managing Files and Sets chapter (see Chapter 5). For more on how to store project-specific presets, see the appropriate section (see 5.6.2).

Default Presets

Presets saved to the Defaults folders in your User Library will load in place of Live’s generic device settings. There are also Defaults folders that allow you to customize how Live responds to various user actions, such as sample dropping, slicing, and converting audio to MIDI. You can even create default presets for newly-created MIDI and audio tracks, so that they will load with devices already in place.

DefaultsFolder.png
The Default Presets folders in the User Library.

To save the current settings of a device as a default preset, open the right-click (PC) / CTRL - click (Mac) context menu on the device’s header and select “Save as Default Preset.“ This works for all of Live’s instruments, MIDI effects and audio effects (including the various types of Racks (see Chapter 18)). If you have already saved a default preset for a particular device, Live will ask you before overwriting it.

To create default presets for MIDI and audio tracks:

  • Load the device(s) you would like as default onto a track (or no devices, if you would like your default track to be empty)
  • Adjust the device parameters as you like
  • Open the right-click (PC) / CTRL - click (Mac) context menu on the track header and select “Save as Default [Audio/MIDI] Track”

To specify how Live behaves when dragging a sample to a Drum Rack or the Device View of a MIDI track:

  • Create an empty Simpler or Sampler
  • Adjust the parameters as you like
  • Drag the edited device to the “On Drum Rack“ or “On Device View“ folder, which can be found in the Defaults/Dropping Samples folders in your User Library. Drum Rack pad defaults can also be saved via a right-click (PC) / CTRL - click (Mac) context menu option on a Drum Rack’s pad

To adjust how Live behaves when slicing an audio file:

  • Create an empty Drum Rack
  • Add an empty Simpler or Sampler to the Drum Rack to create a single chain
  • Add any additional MIDI or Audio Effects to this chain
  • Adjust parameters in any of the devices
  • Assign Macro Controls (see 18.7) to any of the controls in the chain’s devices
  • Drag the entire Drum Rack to the Defaults/Slicing folder in your User Library

You can create multiple slicing presets and choose between them in the Slicing Preset chooser in the slicing dialog.

Note that slicing is not available in the Intro and Lite Editions.

To create default presets for converting Drums, Harmony, or Melody to MIDI (see 11.2):

  • Create a MIDI track containing the instrument you would like to use as your default for a particular conversion type. (Note that default presets for converting drums must contain a Drum Rack)
  • Add any additional MIDI or Audio Effects to the track
  • Adjust parameters in any of the devices
  • If you’re using multiple devices, group them to a Rack
  • Drag the entire Rack to the appropriate folder in Defaults/Audio to MIDI in your User Library

17.2 Using Plug-Ins

The collection of devices that you can use in Live can be extended with plug-ins . Live supports Steinberg Media’s VST Plug-ins format, as well as the Audio Units (AU) Plug-ins format (Mac OS X only).

Working with VST and Audio Units Plug-ins is very much like working with Live devices. VST and AU instruments can only be placed in Live MIDI tracks and, like Live instruments, they will receive MIDI and output audio signals. Plug-in audio effects can only be placed in audio tracks or following instruments. Please see the previous section, Using the Live Devices (see 17.1), for details.

PlugInBrowser.png
Plug-Ins in the Browser.

Audio Units and VST Plug-ins are browsed and imported using the browser’s Plug-In label. Plug-in instruments can be differentiated from plug-in effects in the browser, as they appear with a keyboard icon.

Note that plug-in presets are only available in the browser for Audio Units Plug-ins. In some instances, factory presets for Audio Units will only appear in the browser once the device has been placed in a track and its Hot-Swap button activated.

Note : The first time you start Live, no plug-ins will appear in the Plug-In label as you must first “activate“ your plug-in sources. Activating your plug-in sources tells Live which plug-ins you want to use and where they are located on your computer. Information on activating (and deactivating) plug-in sources can be found later in this chapter, in the sections on the VST Plug-in folder (see 17.3.1) and Audio Units Plug-ins (see 17.4).

Note for “Intel® Mac“ users : Intel® Mac computers cannot natively run VST or AU plug-ins that have been written for the PowerPC platform. Only plug-ins of type Universal or Intel® can be used in Live.

If you install/de-install a plug-in while the program is running, Live will not detect your changes or implement them in the browser until the next time you start the program. Use the Rescan button in the File/Folder Preferences to rescan your plug-ins while Live is running, so that newly installed devices become immediately available in the browser.

You can also rescan if you believe that your plug-in database has somehow become corrupted. Holding down the ALT (PC) / ALT (Mac) modifier while pressing Rescan will delete your plug-in database altogether and run a clean scan of your plug-ins.

17.2.1 Plug-Ins in the Device View

VstPlugInTrackView.png
A VST Plug-In in the Device View.

Once a plug-in is dragged from the browser into a track, it will show up in the Device View. For plug-ins with fewer than 32 modifiable parameters, a Live panel will represent all of the parameters as horizontal sliders. Plug-ins that contain more than 32 parameters will open with an empty panel, which you can then configure to show the parameters you want to access. The plug-in’s original interface can be opened in a separate window (see “Showing Plug-In Panels in Separate Windows”).

VstPlugHideButton.png
The Plug-In Unfold Button.

You can view or hide the plug-in’s parameters by toggling the 24385.png button in the plug-in’s title bar.

The X-Y control field can be used to control two plug-in parameters at once and is therefore especially well-suited for live control. To assign any two plug-in parameters to the Live panel X-Y field, use the drop-down menus directly beneath it.

Showing Plug-In Panels in Separate Windows

VstPlugInEditButton.png
The Plug-In Edit Button.

The Plug-In Edit button opens a floating window that shows the original VST or Audio Units Plug-in panel. Changing parameters on the floating window has the same effect as changing them in the Live panel, and vice versa.

There are a few important Plug-In Preference settings for working with plug-in edit windows:

  • If activated, the Auto-Open Plug-In Custom Editor Preference assures that plug-in custom editor windows open automatically when plug-ins are loaded into tracks from the browser.
  • If the Multiple Plug-In Windows option in the Plug-In Preferences is activated, you can open any number of plug-in windows at once. Even with this option off, you can hold down the CTRL (PC) / CMD (Mac) modifier when opening a new plug-in window to keep the previous window(s) from closing.
  • Using the Auto-Hide Plug-In Windows preference, you can choose to have Live display only those plug-in windows belonging to the track that is currently selected.

You can use the View menu’s Show/Hide Plug-In Windows command or the CTRL - ALT - P (PC) / CMD - ALT - P (Mac) shortcut to hide and show your open plug-in windows. Notice that the name of the track to which the plug-in belongs is displayed in the title bar of the plug-in editor window.

Plug-In Configure Mode

VstPlugInConfigureMode.png
The Configure Button.

Configure Mode allows you to customize Live’s panel to show only the plug-in parameters that you need to access. To do this:

  • Enter Configure Mode by pressing the “Configure“ button in the device’s header.
  • Click on a parameter in the plug-in edit window to add it to Live’s panel. (For some plug-ins, it may be necessary to actually change the parameter’s value. Additionally, certain plug-ins do not “publish“ all of their parameters to Live. These parameters cannot be added to Live’s panel.)

While in Configure Mode, parameters in Live’s panel can be reordered or moved by dragging and dropping them to new locations. Parameters can be deleted by pressing the Delete key. If you try to delete a parameter that has existing automation data, clip envelopes, or MIDI, key or Macro mappings, Live will warn you before proceeding.

The parameters that you assign are unique for each instance of a given plug-in in your Set, and are saved with the Set. If you would like to save a setup using a particular collection of parameters, you can create a Rack (see Chapter 18) containing the configured plug-in. Racks can then be saved to your User Library and loaded into other Sets.

Certain plug-ins do not have their own windows, and instead only show their parameters in Live’s panel. For these plug-ins, it is not possible to delete parameters when in Configure Mode (although they can still be moved and reordered).

There are several ways to add plug-in parameters to Live’s panel without entering Configure Mode:

  • Adjusting a parameter in the plug-in’s floating window creates temporary entries for that parameter in the clip envelope and automation choosers, as well as the choosers in the panel’s X-Y field. These entries are removed when you adjust another parameter. To make the entry permanent (thus adding it to Live’s panel), either edit the parameter’s automation or clip envelope, select another parameter in the automation or clip envelope choosers or select the temporary parameter in one of the X-Y field’s choosers.
  • When a parameter is changed on a plug-in’s edit window during recording, automation data is recorded automatically. When recording is stopped, the automated parameters are automatically added to Live’s panels for any plug-ins that were adjusted.
  • When in MIDI, key or Macro mapping mode, adjusting any parameter in the plug-in’s window will create it in Live’s panel. The new panel entry will be automatically selected, allowing you to map it immediately.

Once a plug-in is placed in a track and you have (optionally) configured its parameters in Live’s panel, you can use it just like a Live device:

  • You can map MIDI controller messages to all of the parameters in Live’s panel.
  • You can drag or copy the device to different locations in the device chain or to other tracks, according to the rules of audio effects and instruments.
  • You can automate or modulate its continuous parameters with clip envelopes.
  • You can use the multiple I/O features of some plug-ins by assigning them as sources or targets in the routing setup of tracks. See the Routing and I/O chapter (see Chapter 14) for details.
  • You can create custom info text for the plug-in.

Macintosh only: The floating editor windows of some VST Plug-ins do not receive computer key strokes. This is generally an implementation error in the plug-in itself. If it is necessary to type into a plug-in window, for instance for entering a serial number or unlock code, hold down Shift while clicking the Plug-In Edit button. The editor window will then appear as a “normal“ application window, rather than as a floating window, and receive your typing. Note that this functionality is intended only as a workaround for the limitations of such plug-ins. We recommend closing the window after you have finished typing, then reopening it normally before working with the plug-in parameters.

17.3 VST Plug-Ins

17.3.1 The VST Plug-In Folder

When you start Live for the first time, you will need to activate your VST Plug-in sources before working with VST Plug-ins. Depending on your computer platform, you may also have to tell Live about the location of the VST Plug-in folder containing the devices you want to use. In order to set up your VST sources, press the Activate button in the browser’s Plug-In panel, or open the File/Folder Preferences by pressing CTRL - , (PC) / CMD - , (Mac). There you will find the Plug-In Sources section.

VstPlugInFolder.png
Setting up VST Plug-In Sources for Windows.

For Windows, proceed as follows:

  1. Use the VST Plug-In Custom Folder entry to tell Live about the location of your VST Plug-ins: Click the Browse button to open a folder-search dialog for locating and selecting the appropriate folder.
  2. Once you have selected a VST Custom Folder and Live has scanned it, the path will be displayed. Note that, on Windows, Live may have found a path in the registry without the need for browsing.
  3. Make sure that the Use VST Plug-In Custom Folder option is set to “On,“ so that your selected folder is an active source for VST Plug-ins in Live. Note that you can choose not to use your VST Plug-ins in Live by turning off the Use VST Plug-In Custom Folder option.
VstPlugInFolder2.png
Setting up VST Plug-In Sources for Mac OS X.

Set up your VST Plug-ins under Mac OS X by doing the following:

  1. Your VST Plug-ins will normally be installed in the following folder in your home and local directories: /Library/Audio/Plug-Ins/VST. You can turn Live’s use of these plug-ins on or off with the Use VST Plug-ins in System Folders option.
  2. You may have an alternative folder in which you store your VST Plug-ins (perhaps those that you use only with Live). You can use VST Plug-ins in this folder in addition to, or instead of, those in the System folders. To tell Live about the location of this folder, click the Browse button next to the VST Plug-In Custom Folder entry to open a folder-search dialog for locating and selecting the appropriate folder.
  3. Note that you can turn off your VST Plug-ins in this folder using the Use VST Plug-In Custom folder option.

Once you have configured your Plug-In Preferences, the browser will display all plug-ins it finds in the selected VST Plug-in folder(s) as well as any sub-folders.

It is also possible to use VST Plug-ins stored in different folders on your computer. To do this, create a Mac OS or Windows alias of the folder where additional VST Plug-ins are stored, and then place the alias in the VST Plug-In Custom folder (or in the VST Plug-In System folder on Mac OS X) selected in Live’s File/Folder Preferences. The alias can point to a different partition or hard drive on your computer. Live will scan the set VST Plug-in folder as well as any alias folders contained therein.

Some VST Plug-ins contain errors or are incompatible with Live. During the scanning process, these may cause the program to crash. When you re-launching Live, a dialog will appear to inform you about which plug-in caused the problem. Depending on what Live detects about the plug-in, you may be given the choice between performing another scan or making the problematic plug-in unavailable. If you choose to rescan and they crash the program a second time, Live will automatically make them unavailable, meaning that they will not appear in the browser and will not be rescanned again until they are reinstalled.

17.3.2 VST Programs and Banks

Every VST Plug-in instance “owns“ a bank of programs . A program is meant to contain one complete set of values for the plug-in’s controls.

VstProgramChooser.png
The VST Plug-In Program Chooser.

To select a program from the plug-in’s bank, use the chooser below the title bar. The number of programs per bank is fixed. You are always working “in“ the currently selected program, that is, all changes to the plug-in’s controls become part of the selected program.

Note that VST programs are different from Live device presets: Whereas the presets for a Live device are shared among all instances and Live Sets, the VST programs “belong“ to this specific instance of the VST Plug-in.

RenamingAVstProgram.png
Renaming a VST Plug-In Program.

To rename the current program, select the VST’s Device Title Bar and execute the Edit menu’s Rename Plug-In Program command. Then type in a new program name and confirm by pressing Enter .

VstProgramBankLoadAndSave.png
The VST Load Program or Bank Button (Left) and Save Program or Bank Button (Right).

VST programs and banks can be imported from files. Clicking a VST’s Load Program or Bank button brings up a standard file-open dialog for locating the desired file.

Windows only : Please select from the File Type menu whether you want to locate VST Device Program files or VST Device Bank files.

To save the currently selected program as a file, click the VST Save Program or Bank button to bring up a standard file-save dialog; select “VST Program“ from the Format menu (Macintosh)/from the File Type menu (Windows); select a folder and name. For saving the entire bank as a file, proceed likewise but choose “VST Bank“ as a file type/format.

17.4 Audio Units Plug-Ins

Audio Units Plug-ins are only available in Mac OS X. In most respects, they operate just like VST Plug-ins.

AudioUnitsPlugIn.png
An Audio Units Plug-In.

The first time you open Live, Audio Units Plug-ins will not appear in the browser. In order to activate your Audio Units as a plug-in source, please press the Activate button in the browser’s Plug-In label, or go to the File/Folder Preferences by pressing CTRL - , (PC) / CMD - , (Mac). There you will find the Plug-In Sources section. Turning on the Use Audio Units option activates Audio Units Plug-ins so that they appear in Live’s browser.

Note that you can always turn this option off later if you decide not to use Audio Units.

AudioUnitsPlugInActivation.png
Activating Audio Units Plug-Ins.

Audio Units Plug-ins sometimes have a feature that allows choosing between different modes for the device. You might be able to choose, for example, between different levels of quality in the rendering of a reverb. Choosers for these device modes can only be accessed through the original plug-in panel, which is opened using the Plug-In Edit button.

AudioUnitsPlugInEditButton.png
Opening an Audio Units Plug-In Window.

Audio Units have presets that function just like those for the Live effects. However, some AU presets cannot be dragged to different locations in the browser, as they are read-only.

Audio Units presets have an .aup reset extension and are stored in the following directory according to their manufacturer’s name:

Home

17.5 Device Delay Compensation

Live automatically compensates for delays caused by Live and plug-in instruments and effects, including those on the return tracks. These delays can arise from the time taken by devices to process an input signal and output a result. The compensation algorithm keeps Live’s tracks in sync while minimizing delay between the player’s actions and the audible result.

Note: there are a few situations in which Live cannot compensate for plug-in delay:

  • Automation (see Chapter 19) is not delay compensated. As a result, when using automation on tracks that contain devices that cause delays, the automation may sound early.
  • Tempo-synced effects and other devices that get timing information from Live’s internal clock may sound out of sync if they are placed in a device chain after devices which cause delay.

Device delay compensation is on by default and does not normally have to be adjusted in any way. However, Live Sets that were created with Live 4 or earlier will open without device delay compensation. To manually turn latency compensation on (or off), use the Delay Compensation option in the Options menu.

When Delay Compensation is on, the Reduced Latency When Monitoring option is available in the Options menu. This option toggles latency compensation on and off for tracks which have input monitoring on. When enabled, input-monitored tracks will have the lowest possible latency, but may be out of sync with some other tracks in your Set (such as Return tracks, which are still delay compensated.) When disabled, all tracks will be in sync, but input-monitored tracks may have higher latency.

Unusually high individual track delays (see 15.7) or reported latencies from plug-ins may cause noticeable sluggishness in the software. If you are having latency-related difficulties while recording and playing back instruments, you may want to try turning off device delay compensation, however this is not normally recommended. You may also find that adjusting the individual track delays is useful in these cases, but please note that the Track Delay controls are unavailable when device delay compensation is deactivated.

Note that device delay compensation can, depending on the number of tracks and devices in use, increase the CPU load.

Download Live 9 manual (PDF)

English, Deutsch, 日本語, Español, Français, Italiano