1. Welcome to Live

1.1 The Ableton Team Says: Thank You

Live is the result of musicians wanting a better way to create, produce and perform music using a computer. A great deal of effort has been put into making Live easy and fun to use, yet at the same time capable of helping you create music with unlimited depth and sophistication. This effort continues even as you read these lines... in fact, a new, improved Live version might already be available for download! Please check your ableton.com account now*https://www.ableton.com/account, or choose the Check for Updates command from the Help menu.

We hope you enjoy using Live and that it enhances your creative process.

Your Ableton Team.

1.2 What’s New in Live 11

1.2.1 Arrangement View Improvements

A new Create Crossfades On Clip Edges command creates four-millisecond crossfades on clip edges. The command is available in the Create menu, and the context menu of Arrangement clips, or via the CTRL-ALT-F(Win) / CMD-ALT-F(Mac) keyboard shortcut.

It is possible to change the selection of automation and take lane headers using the up and down arrow keys. The lane header selection can also be extended using Shift and the up and down arrow keys.

You can move automation lanes and take lanes using CTRL(Win) / CMD(Mac) and the up and down arrow keys.

Selected automation lanes or take lanes can be resized vertically by pressing ALT-+ or ALT--, or by pressing ALT while using the mousewheel/pinch gesture.

When using the Zoom to Time Selection command in the Arrangement, Live now only zooms horizontally at first. When using the command a second time (without changing the time selection), Live then zooms vertically as well. Upon using the command a third time, the Arrangement returns to the first vertical zoom state.

You can use the left arrow key to navigate from an automation lane or take lane to the main track, this will fold the lanes as well. You can also use the left arrow key to navigate from tracks in a group to the main Group Track.

Selected tracks and automation lanes can be folded/unfolded using the left and right arrow keys.

You can solo tracks with the S key and arm tracks with the C key when take lane headers or automation lane headers are selected.

Pressing Tab/Shift-Tab while renaming an Arrangement clip selects the next/previous clip on the same track or take lane.

1.2.2 Browser Improvements

A Templates label (see 5.5.4) has been added to the browser’s Categories. It shows template Live Sets from factory packs (including the Core Library), the User Library, and other Project folders.

A Grooves label (see Chapter 13) has also been added. It shows a flat list of all Grooves from the Core Library as well as the User Library.

Devices in the Audio Effects label are now grouped into folders. You can unfold more than one folder at once by holding CTRL(Win) / CMD(Mac).

Ableton’s official Max for Live devices are now listed within the Audio Effects, MIDI Effects, and Instruments labels.

The browser receives focus when opened via the CTRL-ALT-B(Win) / CMD-ALT-B (Mac) keyboard shortcut.

When viewing and expanding Live Sets in the browser, you will see a new Devices icon for device chains on a track that contain at least one device.

1.2.3 Capture MIDI Updates

Added MPE to Capture MIDI.

In the first captured MIDI clip (in an empty set with the transport stopped), if the detected loop is eight bars or less, the first played note is considered the start of the loop.

When only one note is played in the first captured MIDI clip (in an empty set with the transport stopped), the loop boundaries are set to the note start and end, and the tempo is accordingly calculated, resulting in a one, two, four, or eight bar loop. This is particularly useful when playing a rhythmical sample with a single MIDI note.

In Session View, new captured clips now use the Adaptive Grid: Narrow setting instead of Fixed Grid: 1/16.

1.2.4 Clip View Updates

Live now makes better use of screen space when editing clips.

Clip View properties (see 8.1) can be arranged vertically by moving the mouse cursor to the left from the Clip View panel edge next to the Sample Editor/MIDI Note Editor.

Clip View properties can also be arranged automatically, which switches between the horizontal and vertical views depending on the height of the Clip View area. Select “Arrange Clip View Panels Automatically” from the View menu to enable this option.

Pressing ALT-1 switches to the Audio/Notes tab, pressing ALT-2 switches to the Envelopes tab, and, when a MIDI clip is selected, pressing ALT3 switches to the Note Expression tab.

The Pitch control now has a dial control for transposing in semitones, and a text slider control for fine-tune in cents (previously named Transpose/Detune).

Clip Volume is now called Clip Gain in the Envelope tab’s Device/Control choosers, and in the undo history.

The Audio tab’s Clip Gain control has been changed back to a vertical slider, and it has been repositioned above the Transpose controls.

The Audio tab’s Reverse button now shows an icon instead of text. The Reverse and Edit buttons are now positioned next to each other.

When multiple audio clips with different Clip Gain values are selected, the value range is shown with split triangle handles on the Clip Gain slider.

1.2.5 Comping

Introduced comping (see Chapter 18) in the Arrangement View.

Comping makes it possible to pick the best moments of each recorded performance, and combine them into a composite track.

You can record multiple takes of a musical performance without stopping recording. Live will then create and organize individual takes from this recorded material, allowing you to piece your favorite parts together.

You can also drag samples from your library and use comping as a creative sample-chopping tool.

1.2.6 CPU Meter Updates

The CPU meter (see 33.1.1) drop-down menu now can be customized to display both the Average or Current CPU usage levels, only the Average level or only the Current level. Alternatively, the CPU meter can also be switched off entirely.

By default, Live will not display the Current level; it must be enabled from the drop-down menu of the meter.

The Overload Indicator (previously named the “Disk Overload” indicator) in the Control Bar has been redesigned, and will light up if a CPU overload has occurred.

The Overload Indicator is disabled by default for new Live 11 installations.

CPU overload notifications can be disabled in the Control Bar via the CPU Overload Indication entry in the Overload indicator’s context menu.

Clicking on the new Show/Hide CPU Meter Section selector in the Session View’s Mixer Section will open a per-track CPU metering section. Each track shows a CPU meter with six rectangles that light up to indicate the relative impact of that track on the CPU level of the current Live Set.

1.2.7 Device Additions and Improvements

Hybrid Reverb (see 24.25) is a new audio effect which allows blending a convolution reverb with a number of reverb algorithms.

Spectral Time (see 24.40) is a new audio effect that combines time freezing and spectral delay effects in a single inspiring device.

Spectral Resonator (see 24.39) is a new audio effect based on spectral processing that uses spectral resonances and pitched overtones to add tonal character to any audio source.

Chorus-Ensemble (see 24.8) is a new audio effect featuring two different chorus modes and a vibrato mode for creating pitch variation.

Phaser-Flanger (see 24.32) is a new audio effect that combines the functionalities of the Phaser and Flanger devices into one, as separate effect modes.

Shifter (see 24.38) is a new audio effect designed for pitch shifting, frequency shifting, and ring modulation.

Redux (see 24.33) now has new parameters that can be used to create a wider range of sounds, from harsh distortion to digital and aliasing artifacts, through to warm and fat 8-bit sounds.

Wavetable has a new Hi-Quality right-click(Win) / CTRL-click(Mac) context menu option (see 26.10.9). Using Wavetable with Hi-Quality mode off can save up to 25% CPU compared to having it enabled.

Wavetable can now be fully controlled using MPE controllers.

MPE Control is a new Max for Live MIDI effect that can be used to shape and transform incoming MPE modulation for Pressure (polyphonic aftertouch, Slide (per-note Y-Axis) and Pitch (per-note pitch bend).

Align Delay (see 28.2.1) is a new Max for Live audio effect that delays incoming signals by samples, milliseconds, or meters/feet.

Shaper MIDI (see 28.3.4) is a new Max for Live MIDI effect that uses multi-breakpoint envelopes to generate mappable modulation data.

Updated the appearance of the UI in the Tension (see 26.9), Electric (see 26.3), Corpus (see 24.10), and Collision (see 26.2) devices.

Sampler and Simpler now support MPE. It is now also possible to use MPE/Push 2’s Pressure mode to modulate individual notes in Sampler and Simpler.

The number of visible Macro Controls in Instrument Racks can now be controlled from a Max for Live device or a control surface.

The Cytomic Filters, which are used in the Wavetable, Echo, Simpler, Sampler, Operator, and Auto Filter devices, have been updated and improved in stability, sound and performance. As of 11.1, the Cytomic filters (particularly the MS2 and SMP options) might deviate in sound compared to previous Live versions, especially when driven hard.

An update to the Softtube libraries may cause subtle sound changes in the Amp and Cabinet audio effects.

1.2.8 Follow Actions

Follow Actions can now be assigned to scenes via the new Scene View. Clip Follow Actions will continue to run when a scene Follow Action is created or scheduled, however scene Follow Actions take precedence when triggered.

Follow Actions can be activated or deactivated using the selected clip/scene’s Follow Action button. This button is disabled by default, and can be toggled using the Shift-Enter keyboard shortcut.

An Enable Follow Actions Globally button has been added next to the Back to Arrangement button in the Session View. When disabled, no Follow Actions will occur in the Live Set.

Follow Action Chance A and Chance B values are now represented as percentages that sum to 100%. These values can be modified using a new slider control.

The Follow Action Chance slider now displays a split triangle instead of just a black bar when it is showing multiple different values.

1.2.9 Interface Improvements

Live’s Themes have been redesigned to provide much greater contrast.

Added a Reduced Automatic Colors toggle to the Look/Feel Preferences, which uses a reduced color palette when assigning colors to clips and tracks. This palette makes clips and tracks easier to tell apart with a deuteranopia, protanopia or tritanopia color vision deficiency.

Added a Grid Line Intensity slider to the Look/Feel Preferences, allowing for more pronounced or dimmed appearance of grid lines in the Arrangement and Detail Views.

Added an Arm Track command to the Edit menu. If multiple tracks are selected, the command appears as Arm Tracks. If the selected track is armed, the command is replaced with Disarm Track. It is now possible to arm selected tracks using the C shortcut key.

Reorganized the Edit menu for improved usability and accessibility, and added a new Solo/Unsolo Track entry.

The Groove Pool now opens automatically when loading a groove file from the browser by double-clicking or pressing the Enter key, adding a groove to the Groove Pool, or extracting grooves.

You can use the left and right arrow keys to navigate radio buttons anywhere in Live. If you are navigating radio buttons on a device that is inside of a Rack with the left and right arrow keys, you can get back to moving between devices in the Rack using the left and right arrow keys by hitting the ESC key.

In Session and Arrangement View, the Monitor radio buttons now have a default state that can be restored. When the In/Out section is expanded, you can press the Delete key to reset the Monitor radio buttons to the default (Off for audio tracks and Auto for MIDI tracks). This option is also accessible via the Edit menu option Return to Default.

An error message will be displayed in the status bar if an auto-update cannot be downloaded.

Added a new MIDI Envelope Auto-Reset entry to the Options menu. When enabled, certain MIDI control message types that are not automated for a given clip will automatically reset at the start of a new clip.

Added support for keyboard shortcuts on French keyboard layouts for macOS versions 10.14 and older. Keyboard shortcuts that have numbers can be accessed without having to press Shift to access the number keys.

The audio engine can now be turned on or off via a new Audio Engine On entry in the Options menu, or using the CTRL-ALT-Shift-E(Win) / {CMD]ALT-Shift-E(Mac) keyboard shortcut.

When Sets are saved with the File menu’s Save Live Set as Template... or Save Live Set as Default Set... command, they are automatically self-contained in the same way as Sets that use the File Manager’s Collect and Save function.

1.2.10 Linked Track Editing

Introduced linked-track editing (see 6.13) in the Arrangement View.

Linked-track editing makes it possible to use comping workflows and other phase-locked editing operations on multiple tracks at once.

Any tracks in the Arrangement View can now be linked so that their content can be edited simultaneously. There can be multiple instances of linked tracks in a Set, however each track can only belong to one of these instances.

1.2.11 Max for Live Updates

Updated the bundled Max build to version 8.2.1.

Added support for MPE input to/output from Max for Live devices.

The Expression Control device now allows assigning an additional parameter as a mapping target.

All Max for Live devices have been moved inside the application bundle (previously, they lived in the Core Library), to ensure that using Collect All and Save will not create redundant copies of the devices.

Link functions have been added to the Max for Live API.

When Max fails to load, an error message will be displayed that contains a link to a Knowledge Base article that explains potential causes for the issue and steps to take to resolve it.

Error reporting in the Max Window is more consistent.

Four new theme colors are available in Max for Live.

1.2.12 MIDI Clip Scales

A new Scale Mode (see 8.1.9) can be enabled/disabled via the Scale button in the Clip tab of MIDI clips.

By default, key tracks belonging to the selected scale are highlighted in the MIDI Note Editor, and the root note is indicated by a prominent highlight in the piano roll.

Newly-created MIDI clips inherit the previously edited or viewed clip scale, even if they have Scale Mode disabled. When editing multiple clips with different key and scale settings, any foreground clip with Scale Mode enabled now updates the global settings that are used to initialize the next created clips, as well as Push’s key and scale.

1.2.13 MIDI Note Editing

A new Chance Editor (see 10.4.9) allows setting the probability of a MIDI note occurring in a playing clip. Dragging a note’s probability marker up and down changes the probability value between 0-100%.

It is now possible to see and edit a velocity range, from which a velocity value is selected when a note is played. In the Notes tab, a Velocity Range slider (see 10.4.8) allows assigning velocity ranges to selected notes (or all notes in a single clip, if none are selected).

The Randomize button allows randomizing velocity/probability values for selected notes (or notes with selected markers), depending on the focused lane. If no markers are selected, values for all notes will be randomized.

The Velocity and Chance Editor lanes can be shown or hidden via the lane selector toggle buttons at the left. Underneath the lane selector toggle buttons, a triangular toggle button allows showing/hiding all enabled lanes at once.

The Velocity and Chance Editor lanes can be resized at once by dragging the split line between the lanes and the MIDI Note Editor.

In the Record/Warp/Launch tab of Live’s Preferences, a new MIDI Note Drawing section contains a Draw Mode with Pitch Lock option. When enabled, drawing MIDI notes is constrained to one single key track (or pitch) at a time, while holding the ALT key allows freehand melodic drawing.

It is now possible to change the note selection in the MIDI Note Editor using CTRL(Win) or ALT(Mac) and the up and down arrow keys.

1.2.14 MPE Support and Editing

Added support for MIDI Polyphonic Expression, also known as MPE (see Chapter 11).

The Slide, Pressure, Velocity, and Release Velocity dimensions are displayed inside new expression lanes below the MIDI Note Editor.

When a note is moved, its expression envelopes will move along with it.

MIDI track meters now indicate MPE per-note controller changes. The lowest dot in a meter lights up in a blue color if per-note controller changes pass that meter.

Plug-in devices that have MIDI outs and that have MPE enabled can now output MPE.

Added an MPE Settings dialog box to the I/O section of Live’s mixer (see 11.6).

1.2.15 Multi-clip Editing

The new Focus button enables Focus Mode (see 10.5.1), which allows editing the current foreground clip only. Focus Mode can be toggled via the N keyboard shortcut.

Loops are now visible and editable via mouse interactions.

The Invert button is now enabled in the Notes tab when at least one note is selected, and it is possible to invert selected notes from multiple clips at the same time.

Time selection interactions, note selection interactions, and new note editing options have been added to multi-clip editing.

1.2.16 Push Device Visualizations

On Push 2, the Hybrid Reverb parameter banks Algorithm 1 and Algorithm 2 have been renamed. Also some parameters for Hybrid Reverb have been rearranged for easier navigation.

Updated some parameter names for the Chorus-Ensemble device on Push 2.

The Saw Up and Saw Down icons for Sampler’s LFO waveforms on Push 2 now appear as expected.

1.2.17 Push MIDI Clip Mode

When Push’s In Key/Chromatic is set to In Key Mode, and the selected MIDI clip has Scale Mode enabled, selecting a scale on Push will update that clip’s scale in Live.

If Focus Mode is enabled in multi-clip editing, only the foreground clip’s key and scale will be updated in Live.

When Push’s In Key/Chromatic is set to In Key Mode, and the selected MIDI clip has Scale Mode enabled, selecting a scale in Live will change the pad layout on Push.

1.2.18 Additional Push Improvements

Added a Pressure switch to Push 2’s Setup Menu that allows toggling between monophonic and polyphonic aftertouch when playing melodic instruments.

Push 2 and MIDI controllers sending polyphonic aftertouch can be used with plug-in devices that support polyphonic aftertouch.

When Push 2’s Pressure mode is set to Poly, the Repeat button now produces notes at full velocity when Accent is enabled.

When a Rack contains a parameter mapped to one of the new Macro Controls (e.g., Macro 9-16), the additional Macro Control parameters will appear in a new device within the Rack. Degree symbol icons (Push 1) or bullet point icons (Push 2) are used to differentiate the Rack from the device.

When editing multiple MIDI clips at once, a connected Push device now follows all highlight changes of tracks/scenes, and the focus on the corresponding track.

Updated the notification style for scenes, and updated the scene name visualization to include the absolute position, tempo and time signature on Push.

1.2.19 Rack and Macro Control Improvements

The maximum number of available Macro Controls (see 20.1.2) in Live has been doubled to 16. New + and - view selector buttons in Racks allow setting how many Macro Controls are shown or hidden.

A new Show/Hide Macro Variations view selector button in Racks opens a view that allows storing the state of the Macro Controls as a variation preset via the “New” button.

Pressing the Rand button in the title bar of a Rack randomizes the values of mapped Macro Controls.

1.2.20 Session View Improvements

Selecting a scene (or multiple scenes) opens the new Scene View (see 7.2.2), which allows editing the selected scene’s tempo, time signature and Follow Actions.

Scene numbers are now displayed in a new column in the Master track.

Dragging the left edge of the Master track’s title header reveals two new controls, which allow assigning a tempo or time signature to a scene.

It is now possible to rename multiple selected clips at once, via the Rename command in the right-click(Win) / CTRL-click(Mac) context menu, Edit menu, or by using the CTRL-R (Win) / CMD-R (Mac) keyboard shortcut.

Added a Cancel Scene Launch entry to the Master track’s right-click(Win) / CTRL-click(Mac) context menu. Clicking this entry cancels the launch of any previously triggered scene.

1.2.21 Setup Improvements

As of version 11.1, Live is natively supported on Apple silicon computers.

Live’s Status Bar will now indicate when an update for Live is being downloaded. Once it is downloaded, the Status Bar will state that Live must be restarted in order to apply the update.

ReWire support has been removed.

To avoid incompatibilities, you will be asked to save Live Sets created with an older version of Live as a new file in Live 11.1.

1.2.22 Tempo Follower

Introduced Tempo Follower (see 32.2), which adapts Live’s tempo to stay in time with a drummer or another rhythmic audio source.

A Tempo Follower section has been added to Live’s Preferences in the Link, Tempo, MIDI tab. The Show Tempo Follower Toggle switch shows/hides the Follow button in the Control Bar.

An Input Channel (Ext. In) chooser allows choosing the channel from which the tempo will be tracked, and displays a level meter for each channel.

Download Live 11 manual (PDF)

English, Deutsch, 日本語, Español, Français, Italiano, 简体中文