8. Clip View

The Clip View is where clip properties can be set and adjusted.

The Clip View with Clip Tabs Arranged Horizontally.

Clip View properties can be arranged horizontally in tabs, vertically in panels, or automatically (switching between the horizontal and vertical views depending on the height of the Clip View area).

To arrange Clip View vertically, drag the right edge of the Clip View panel (next to the Sample Editor/MIDI Note Editor) to the left; drag it to the right to switch back to horizontal arrangement. To change views automatically, you can select “Arrange Clip View Panels Automatically” from the View menu or from the title bar’s right-click(Win) / CTRL-click(Mac) context menu. Live will remember the Clip View arrangement when you open it again in the future.

Clicking on the Clip Overview or double-clicking a clip in the Session or Arrangement View opens the Clip View.

Clicking the Clip Overview Opens the Clip View.

If you’re using dual monitors, the Clip View will open in the same window you just clicked. To switch the Clip View to the other window, press Shift-Tab.

Tip: single-clicking a clip will show that clip in the Clip View, but will not move the Clip View from its current window. This allows you to, for example, dedicate one window to detailed clip editing while using the other window for your work in the Session or Arrangement.

In the Session View, clicking on a Track Status Field opens the Clip View for editing the clip that is currently running in the track.

Clicking a Session View Track Status Field Opens the Clip View.

The properties of more than one clip can be edited collectively in the Clip View as a multi-selection. To create a multi-selection, click and drag from an empty clip slot to highlight the clips, or select one clip and use the CTRL(Win) / CMD(Mac) or Shift modifiers to add to your selection. The properties available in the Clip View for a multi-selection depend on the contents of the clips; generally only properties which the clips have in common are shown.

Creating a Clip Multi-Selection.

Controls such as sliders and knobs behave slightly differently when they are part of a multi-selection. If the clips in a multi-selection have differing values for any particular knob or slider parameter (clip transposition, for example), the range of these values will be displayed and can be adjusted with the control. Dragging the knob or slider to its absolute maximum or minimum value will make the clips’ settings thereafter identical, adjustable as a single value.

MIDI clips and audio clips in Live have different sets of properties and, consequently, do not share the same set of Clip View controls. The two types of clips do have the following in common:

  • The clip tabs/panels contain basic clip settings.
  • You can access the clip launch properties by clicking on the relevant clip tab when Clip View is arranged horizontally. When Clip View is arranged vertically, you can expand the corresponding clip panel to view the clip launch properties. The Session View clip launch properties are covered in detail in a separate manual chapter (see Chapter 14).
  • The Envelopes tab/panel and the Envelope Editor manage the clip’s envelopes, which are used to automate or modulate the effects, mixer, and clip or MIDI controls. Clip envelopes and their associated Clip View components are covered in detail in a separate manual chapter (see Chapter 22).

Audio clips have these additional Clip View controls:

  • The Sample Editor toggles with the Envelope Editor on the right-hand side of the Clip View, and controls Live’s sample-warping capabilities and clip playback settings (see 8.2.5).
  • The Audio tab/panel contains settings pertaining to how the clip plays its sample and displays it in the Sample Editor.
The Clip View for an Audio Clip.

MIDI clips have these additional Clip View controls:

  • The MIDI Note Editor toggles with the Envelope Editor on the right-hand side of the Clip View, and allows editing and creating MIDI notes and velocities (see Chapter 10).
  • The Notes tab/panel contains settings pertaining to how Live plays a MIDI clip, as well as a collection of tools for transforming the notes within the clip.
  • The Note Expression tab/panel toggles Expression Editors underneath the MIDI Note Editor on the right-hand side of the Clip View, to allow editing different dimensions of MIDI Polyphonic Expression (MPE) for each note in a clip. You can find more information about working with MPE and the Expression Editors in the Editing MPE chapter (see Chapter 11).
The Clip View for a MIDI Clip.

To make best use of the screen real estate, you can minimize the Clip View tabs/panels by double-clicking the Clip View title bar. You can toggle between the Sample Editor/MIDI Note Editor, the Envelope Editor, and the Expression Editors by clicking on the relevant clip tabs/panels. You can also switch between tabs/panels using the following key combinations:

ALT-1 switches to the Audio or Notes tab/panel

ALT-2 switches to the Envelopes tab/panel

ALT-3 switches to the Note Expression tab/panel

Clip View Tabs Arranged Horizontally.
Clip View Panels Arranged Vertically.

8.1 The Clip Tabs/Panels

8.1.1 Clip Activator Switch

Using this switch, you can deactivate a clip so that it does not play when launched in the Session View or during Arrangement playback. Clips can also be activated/deactivated directly from the Session or Arrangement View with the right-click(Win) / CTRL-click(Mac) context menu entries.

The Clip Activator Switch.

8.1.2 Clip View Sample Details

The sample rate, bit depth, and channel count of a sample can be viewed in the Clip View title bar or underneath the title bar, depending on whether Clip View is arranged horizontally or vertically.

The Sample Properties in the Clip View Title Bar.

When multiple audio clips are selected, the sample properties for all samples will be displayed. If a value is not the same for all samples, the character “*” will be displayed. You will also see the total number of samples selected.

Clicking on the sample properties from Clip View will open the sample file in the browser.

8.1.3 Clip Tabs/Clip Panels

When Clip View properties are arranged horizontally, you will see clip tabs for various clip settings and the clip launch properties.

Clip Tabs.

In vertical Clip View arrangement, these settings are displayed in clip panels.

Clip Panels.

Clip tabs and panels can be accessed using keyboard shortcuts.

In MIDI clips:

ALT-1 switches to the Notes tab/panel

ALT-2 switches to the Envelopes tab/panel

ALT-3 switches to the Note Expression tab/panel

In audio clips:

ALT-1 switches to the Audio tab/panel

ALT-2 switches to the Envelopes tab/panel

8.1.4 Clip Name and Color

By default, a clip’s name matches the name of the file it references but, in general, the clip name is independent from the file name. To change the name of a clip, right-click(Win) / CTRL-click(Mac) on the title bar of the Clip View, and choose “Rename” from the context menu.

You can also rename a clip by selecting it in the Session grid or Arrangement View and using the Rename command in the Edit menu or the clip’s right-click(Win) / CTRL-click(Mac) context menu. From the Edit menu you can also create your own info text for the clip via the Edit Info Text command.

Renaming an audio clip does not rename the referenced sample file. To rename a file, select it in Live’s browser, and then choose the Edit menu’s Rename command.

Newly created clips take the same color as the track on which they’re created, but you can also choose a clip color from the color palette in the clip’s right-click(Win) / CTRL-click(Mac) context menu manually.

You can quickly apply the track’s color to each of its clips by using the Assign Track Color to Clips command in the track header’s right-click(Win) / CTRL-click(Mac) context menu.

To apply a Group Track’s (see 16.3) color to all of its contained tracks and clips, you can use the Assign Track Color to Grouped Tracks and Clips command in the respective Group Track header’s right-click(Win) / CTRL-click(Mac) context menu.

Note that when using the Assign Track Color to Clips or Assign Track Color to Grouped Tracks and Clips command in Session View, the color change will only affect Session clips. Likewise, using either command in Arrangement View will only change the color of Arrangement clips.

8.1.5 Clip Region/Loop and Display

Zooming and Scrolling

The Clip Zoom/Scroll Area.

Zooming and scrolling in the Sample Editor/MIDI Note Editor work much like they do in the Arrangement View (see 6.1). For audio clips, when Warp (see 8.2.1) is disabled, zooming and scrolling can be done anywhere in the upper half of the Sample Editor. When Warp is enabled, however, scrolling only happens in the beat-time ruler.

Click and drag vertically in these areas to smoothly change the zoom level, and horizontally to scroll the display.

To zoom in on the current time selection completely, press Z or use the View menu’s Zoom to Clip Selection command. You can revert back to the previous zoom state by pressing the X key. Note that when zooming in multiple times using the Z key, the X key can be pressed multiple times to go back one step each time the key is pressed.

The Clip Overview.

The Clip Overview provides additional zoom/scrolling functionality. It always shows the complete clip, from start to end. The black rectangular outline represents the part of the clip that is currently displayed. You can click within the outline and drag horizontally or vertically to scroll or zoom.

To have the Sample Editor/MIDI Note Editor follow the play position and scroll automatically, turn on the Follow switch, or use the Follow command from the Options menu. Follow will pause if you make an edit in the Sample Editor/MIDI Note Editor. Follow will start again once you stop or restart playback, or click in the Arrangement or clip scrub area.

The Follow Switch.

Playing and Scrubbing Clips

The section of the clip that plays when a clip is launched is set with the clip’s region and loop controls (see 8.1.5). An unlooped clip will play from its start marker to its end marker or until it is stopped.

The Clip Start and End Markers.

These markers can be clicked and dragged to new positions in the Sample Editor/MIDI Note Editor, or they can be moved with the left and right arrow keys. To move the entire clip region (i.e., both the start and end markers), select either marker, hold down ALT, and use the arrow keys.

Use the Clip Start and End Controls to Change Clip Length.

You can also adjust the clip start and end numerically using the respective value fields. For warped audio clips, these fields display values as bars-beats-sixteenths; for unwarped audio clips, the display is in minutes-seconds-milliseconds. Notice that you can use the Set buttons here to place the markers during playback. Setting markers this way is quantized according to global quantization.

When Permanent Scrub Areas is enabled in Live’s Look/Feel Preferences, clicking in the lower half of the waveform or in the beat-time ruler will make clip playback jump to that point.

The Clip Scrub Area.

The size of this jump is quantized by the global quantization setting, which can be quickly changed using the CTRL-6(Win) / CMD-6(Mac), 7, 8, 9, and 0 shortcuts. While the mouse is held down over the scrub area, a portion of the clip the size of the chosen quantization setting will be repeatedly played. With small quantization settings, or a setting of “None,“ this allows you to scrub through the music. Activating the Options menu’s Chase MIDI Notes command allows MIDI notes to play back even if playback begins after the MIDI note’s start time.

When the Permanent Scrub Areas preference is off, you can still scrub by Shift-clicking anywhere in the scrub area or in the beat-time ruler.

Looping Clips

To have the clip play as a (potentially infinite) loop, turn on the Loop switch. Note that for audio clips, the Warp switch must be activated before the Loop switch is accessible, as unwarped audio clips cannot be looped.

You can click and drag to change the position and length of the loop brace in the Sample Editor/MIDI Note Editor, or you can type exact values into the Loop Length and Position fields.

The Loop Controls.

The loop brace can be selected with the mouse and its position changed with commands from the computer keyboard:

  • The left and right arrow keys nudge the loop brace to the left/right by the current grid setting (see 6.9).
  • The up and down arrow keys shift the loop brace left/right in steps the size of its length.
  • CTRL(Win) / CMD(Mac) plus the left or right arrow shortens or lengthens the loop brace by the current grid setting.
  • CTRL(Win) / CMD(Mac) plus the up or down arrow doubles or halves the loop length.
  • The loop’s length and its contents can be duplicated at once via the Edit menu’s Duplicate Loop command. Any notes to the right of the loop will be moved, so that they maintain their position relative to the end of the loop. (MIDI clips only)

Regardless of the position of the loop brace, clip play will begin at the position marked by the start marker, which means you can set up the clip to run into a loop.

Setting the Clip to Run Into a Loop.

The Loop Length and Position fields are equipped with Set buttons, which can be used to create loops spontaneously during playback.

Playing the clip and then clicking the Set Loop Position button moves the beginning of the loop to the current playback position (rounded to the global quantization setting) and engages the loop. Then, clicking the Set Loop Length button moves the end of the loop to the current playback position. This lets you capture the music in a loop on the fly.

While the loop is still off, you can click the Set Loop Length button to set the loop to end at the current playback position without changing its preset length. This simultaneously activates looping.

The Set buttons, the Loop switch, the loop brace and the start/end markers can all be mapped to MIDI controls (see Chapter 29). You could, for example, use a rotary encoder to move the loop through a sample in increments the size of the chosen quantization interval.

8.1.6 Clip Signature

Using the Clip Signature fields, you can specify the time signature of a MIDI or audio clip. This setting is relevant only for display; it does not affect playback. Please note that Clip Signature is completely separate from the project’s time signature, and can be set independently for each clip. This makes it easy to see which clips can be used to create complex polymetric textures when simultaneously triggering clips with different meters and/or loop lengths.

The Clip Time Signature Fields.

8.1.7 Clip Groove Chooser

The Clip Groove chooser selects the groove used for the clip from the grooves available in the Groove Pool (see 13.1).

The Clip Groove Chooser.

You can use the Hot-Swap Groove button to preview available grooves in Live’s browser while the clip plays. Hit the Enter key to add a selected groove to the Groove Pool.

The Commit button under the chooser “writes“ the current groove settings to the clip and disables the assigned groove. If the groove uses the Velocity parameter, committing on an audio clip will create a volume Clip Envelope (see Chapter 22) in order to convert the groove’s velocity information into audio volume changes. Note that this will overwrite any volume Clip Envelope that was already in the clip.

8.1.8 Saving Default Audio Clip Settings with the Sample

The Save Default Clip Button.

In audio clips, the Save Default Clip button is shown in the Clip View title bar. The Save Default Clip button saves the current clip’s settings with the sample. With multiple clips selected, this button will save them all simultaneously. Once saved, Live will restore the current clip settings whenever you drop the sample into a Live Set. This is especially useful with regards to Warp Markers (see 9.2.2) that have to be set correctly for Live to play long files in sync. Note that you can use the Save button without affecting any existing clips; Save just saves default settings for future clips using this sample.

The clip data becomes part of the analysis file that accompanies the sample (see 5.2.2).

Note that storing default clip settings with the sample is different from saving the clip as a Live Clip (see 5.4), which also saves devices and device settings.

8.1.9 MIDI Clip Scales

In MIDI clips, Clip View offers some additional controls. The Scale button enables or disables Scale Mode, which, thanks to its helpful highlighting of notes, is useful for writing melodies within a certain scale. You can set a clip’s scale using the Root Note and Scale Name choosers. These controls are described in further detail in the “Scales, Folding and Looping” section (see 10.4.2).

The Scale Controls.

8.1.10 MIDI Clip Bank and Program Change

In MIDI clips, the settings that allow Live to send MIDI bank/program change messages to external devices and plug-ins that support MIDI program change messages are found in the relevant clip tab/panel.

The Bank and Program Controls.

According to the settings in these controls, launching a clip also sends its bank/program change message. If you are using Live to send MIDI to your synth, this means that each MIDI clip in your Live Set can play a different sound on your synth. Live offers messages for 128 banks with 128 sub-banks, each of which has 128 programs. Please see the documentation that came with your synthesizer to determine how many of these messages it can use. If you do not want your clip to send program or bank change messages, simply set the bank/program choosers to “---.“

8.2 The Audio Tab/Panel

8.2.1 Warp Controls

The Warp Controls.

When the Warp switch is off, Live plays the sample at its original, “normal“ tempo, irrespective of the current Live Set tempo. This is useful for samples that have no inherent rhythmic structure: percussion hits, atmospheres, sound effects, spoken word and the like. Turn the Warp switch on to play rhythmically structured samples (such as sample loops, music recordings, complete music pieces, etc.) in sync with the current song tempo.

To verify this, note that a warped sample’s speed follows the tempo as you change the Control Bar’s Tempo control.

The Control Bar’s Tempo Field.

Live offers a number of controls to adjust the time-warping engine for optimal stretching quality (see 9.3). For accurate warping, Live needs to know the sample’s metrical structure. For properly prepared loops, tempo and duration are calculated automatically; most of the time this is accurate enough that the sample is immediately ready for use in Live. For other samples, you may have to provide some hints. We will examine these topics thoroughly in the Audio Clips, Tempo, and Warping chapter (see Chapter 9).

8.2.2 Clip Start and End Fades

The Clip Fade Switch.

The Clip Fade switch, when enabled, applies a short fade to the clip start and end to avoid clicks at the clip edges. The length of the fade is signal-dependent and ranges from 0-4 milliseconds.

This switch is only available for clips in Session View. In Arrangement View, clip fades are adjusted via envelopes (see 6.7).

The Clip Fade switch is on by default for all new clips when the Create Fades on Clip Edges option is enabled in the Record/Warp/Launch Preferences.

Automatically Create Short Fades At Clip Edges.

8.2.3 Clip RAM Mode

The RAM Mode Switch.

If the RAM Mode switch is on, Live loads the audio referenced by the clip into the computer’s memory rather than reading it from disk in real time. RAM Mode can help with these problems:

  • Your computer’s hard disk is too slow to deliver audio for as many tracks as desired in real time. For more information on disk-related problems, please refer to Managing the Disk Load (see 33.2).
  • You are experiencing audio dropouts when playing clips in Legato Mode (see 14.3).

Use RAM Mode with care, as RAM is usually a scarce resource. Your computer is using the hard disk for swapping out RAM contents that have not been used in a while. The more clips you are running in RAM Mode, the higher the likelihood for them to be swapped out. Live can handle disk overloads more gracefully than swapped-out audio arriving late: Disk overloads result in unwanted mutes, whereas RAM overload results in both mutes and rhythmical “hiccups.“

8.2.4 High Quality Interpolation

The High Quality Switch.

If the High Quality switch is on, Live uses an advanced sample-rate conversion algorithm that provides better sound quality at the expense of a higher CPU load. Samples processed with the Hi-Q algorithm generate less distortion, particularly at high frequencies, when transposing a sample and/or matching an imported sample’s sampling rate to the system’s sampling rate. With this mode enabled, samples can be transposed roughly 19 semitones in either direction before aliasing is likely to be audible.

From Live 7 on, the Hi-Q mode uses an algorithm that produces even smaller audible artifacts than in previous versions. Although we think this has greatly improved sound quality, any Sets made in older versions that used Hi-Q mode may now sound different. For this reason, we have provided a Legacy Hi-Q Mode option, which is enabled by default in the Options menu whenever you load an old Set that has Hi-Q enabled for any clips. Simply disable this option if you wish to use the new mode.

8.2.5 Clip Gain and Pitch

The Clip Gain and Pitch Controls.

The Gain slider, calibrated in dB, changes the clip gain.

When multiple audio clips with different Gain values are selected, the value range is shown with split triangle handles on the Gain slider.

The Pitch knob control shifts the clip pitch in semitones. This amount can also be adjusted using the value field on the left underneath the knob. To the right of the semitone value field is another value field for fine-tine transpoing in cents (100 cents = one semitone).

8.2.6 Destructive Sample Editing

The Launch Sample Editor Button.

The Edit button opens the sample in an external sample editing application, which you can specify in the File/Folder Preferences. To process a sample in an external program, you have to stop Live’s playback. When you return to Live, the edited version of the sample will be played back. The current set of Warp Markers is retained only if the sample length remains the same as it did prior to editing. Remember that changes made to one sample may affect other clips that play the same sample.

8.2.7 Reversing Samples

The Reverse Button.

This function creates a new sample by reversing the sample referenced by the current clip. It then reapplies the old clip’s settings (according to some rules that we will explain in a moment), and replaces the original sample with the reversal in the Clip View. The new sample can be found, after saving the Live Set, in the Set’s Project folder, under Samples/Processed/Reverse. Until the Set is saved, new samples remain at the location specified by the Temporary Folder.

There are a few rules for the reversing process. First, any Warp Markers will remain fixed to their positions in the sample. This means that a Warp Marker on the downbeat of the second bar of a clip will end up on the downbeat of the second-to-last bar after reversal. Clip loop/region settings are similarly flipped. Second, clip envelopes remain fixed to their position in time. Therefore, a mixer volume envelope that lowers the volume of the first half of a clip will continue to do exactly that after reversal.

The reversal process is quite fast (about as fast as copying), but for very long samples it might take a little time. When this is the case, the Status Bar in the lower portion of the Live screen will give you a progress display, and further actions in the program will be temporarily locked (though running clips will continue to play). You can play the reversed clip and perform other actions in the program as soon as Live begins to draw the new waveform into the Sample Editor. Once a sample is reversed, a link to the reversed sample will be maintained until you quit the program, and reversing the same clip again (or a copy) will be instantaneous.

In the Arrangement View, it is possible to reverse a selection of material, even if it contains multiple clips. To do this, select the range of time you want to reverse, and choose the Reverse Clip(s) command from the clip’s right-click(Win) / CTRL-click(Mac) context menu, or press the R shortcut key.

It is not recommended that you reverse clips in a live performance situation, as a slight audio glitch can sometimes occur while Live reapplies the warp and loop settings.

8.2.8 Cropping Audio Clips

The Sample Editor’s right-click(Win) / CTRL-click(Mac) context menu includes the Crop Sample command. This function creates, similarly to the Reverse function, a new sample by copying the currently selected portion of a longer sample. The new sample can be found, after saving the Live Set, in the Set’s Project folder, under Samples/Processed/Crop. Until the Set is saved, the new sample remains at the location specified by the Temporary Folder.

8.2.9 Replacing and Editing the Sample

To replace the sample referenced by the clip with a different one, drop the new sample directly from the browser into the Clip View. Clip settings like pitch and volume will be retained. The Warp Markers will be retained only if the new sample has the exact same length as the old sample.

The Sample Editor’s right-click(Win) / CTRL-click(Mac) context menu includes the Manage Sample File command. This opens the File Manager for the current Set with the sample referenced by the clip selected. From there, you can replace and destructively edit the sample (see 5.5.5), in such a way that all clips and instruments referencing the sample will be affected. You can also use the Show in Browser command in the right-click(Win) / CTRL-click(Mac) context menu to reveal the file in the browser.

8.3 The Notes Tab/Panel

The Notes Tab.

The Notes tab/panel’s transform tools allow for fast manipulation of a MIDI clip’s contents. These controls affect the selected notes or time range. If nothing is selected, they affect the whole clip.

  • The Transpose slider transposes the selection. Type a number to transpose by semitones. Type a note name to set the lowest note. Adding a “-” before the note name sets the highest note.
  • The ÷2 and ×2 buttons double or halve the playback speed of the selection, respectively.
  • Reverse reverses the selection so that the last note swaps places with the first note.
  • Invert flips the selection “upside-down” so that the highest note is swapped with the lowest note.
  • Legato lengthens (or shortens) each selected note so that it is just long enough to reach the beginning of the next note.
  • Duplicate doubles the material within the loop brace (as well as the length of the loop brace itself), zooming as necessary to show the entire loop. Any notes to the right of the loop will be moved, so that they maintain their position relative to the end of the loop.
  • Randomize adjusts note velocity (see 10.4.8) or probability (see 10.4.9) values at random, depending on which lane is in focus.
  • Randomize Range specifies a randomization range that can be applied to velocity or probability values.
  • Velocity Range assigns a range from which a velocity value is selected when a note is played.

For a more detailed discussion of MIDI editing, see the chapter on this topic (see Chapter 10).

8.4 Clip Defaults and Update Rate

You can change the rate at which Live applies your Clip View settings to a running clip. Clip View changes will be quantized by the rate selected from the Clip Update Rate chooser in the Record/Warp/Launch Preferences. Certain clip settings, such as Launch Mode and Warp Mode, can be set up as defaults for all new clips. This is also done in the Record/Warp/Launch Preferences.

The Record Warp Launch Options in Live’s Preferences.

Download Live 11 manual (PDF)

English, Deutsch, 日本語, Español, Français, Italiano, 简体中文