Contact support or Ask other Live users

6. Arrangement View

The Arrangement View displays the Arrangement, which contains music laid out along a song timeline, like a multitrack tape.

DemoArrangement.png
A Piece of Music in the Arrangement View.

The Arrangement View is a powerful editing tool that easily lets you combine and arrange MIDI, loops, sound effects, video and complete pieces of music.

Live offers several fast methods for zooming and scrolling the Arrangement display:

20441.png
Navigating the Arrangement View.
  1. To smoothly change the zoom level, click and drag vertically in the beat-time ruler at the top of the Arrangement View (you can also drag horizontally to scroll the display).
  2. To zoom in and out around the current selection, use the computer keyboard’s + and - keys. To “pan“ the display, click and drag while holding the CTRL - ALT (PC) / CMD - ALT (Mac) modifier. Double-clicking in the beat-time ruler also zooms to the current selection. If nothing is selected, double-clicking the beat-time ruler zooms out to show the entire Arrangement.
  3. The Arrangement Overview is like a “bird’s-eye view“ of your music. It always shows the complete piece, from start to end. The black rectangular outline represents the part of the Arrangement that is currently displayed in the Arrangement display below. To scroll the display, click within the outline and drag left or right; to zoom out and in, drag up and down.
  4. To change the displayed part of the Arrangement, drag the outline’s left and right edges.
  5. To see a specific part of the Arrangement in more detail, click on it in the Overview and drag downwards to zoom in around that part. Note that you can also drag horizontally to scroll the display. Using this method, you can zoom and scroll to focus around any part of the Arrangement with just one mouse motion.
  6. To have the Arrangement display follow the song position and scroll automatically, turn on the Follow switch, or use the Follow command from the Options menu.

6.2 Transport

There are a number of ways to control Live’s transport with the computer keyboard and mouse:

  1. You can start Arrangement playback by clicking the Control Bar’s Play button, and stop playback by clicking the Stop button. Arrangement playback can also be toggled on and off by pressing the keyboard’s space bar.
PlayAndStop.png
The Play and Stop Buttons in the Control Bar.
  1. You can set the Arrangement playback position by clicking anywhere along the Arrangement to place the flashing insert marker. You can return the Arrangement play position to 1.1.1 by double-clicking the Stop button or by pressing the Home key (PC) / Function + left arrow key (Mac).
FlashingInsertMarker.png
Arrangement Playback Begins from the Insert Marker.
  1. To continue playback from the position where it last stopped, rather than from the insert marker, hold down the Shift modifier while pressing the space bar.
  2. When Permanent Scrub Areas is enabled in Live’s Look/Feel Preferences, clicking in the scrub area above the tracks will make playback jump to that point. The size of these jumps is quantized according to the Control Bar’s Quantization menu setting. While the mouse is held down over the scrub area, a portion of the Arrangement the size of the chosen quantization setting will be repeatedly played. With small quantization settings, or a setting of “None,“ this allows you to scrub through the music.
  3. When the Permanent Scrub Areas preference is off, you can still scrub by Shift -clicking anywhere in the scrub area or in the beat time ruler.
ArrangementScrubArea.png
Scrubbing Arrangement Playback.
  1. The song position can be adjusted numerically using the Control Bar’s Arrangement Position fields.
ArrangementPositionFields.png
Setting the Play Position in the Arrangement Position Fields.
  1. The Arrangement Position fields show the song position in bars-beats-sixteenths. To change the values:
  • Click and drag up or down in any of these fields.
  • Click and type a number, then hit Enter .
  • Click and decrement or increment the value with the up and down arrow keys .
  1. Arrangement playback can be started at a particular point in one of your clips using the scrub area in the Clip View (see Chapter 8).
  2. Several Arrangement playback positions can be set using launchable locators (see 6.3).

Note that any computer keyboard key or MIDI message can be mapped to the transport controls, as described in the respective chapter (see Chapter 26).

6.3 Launching the Arrangement with Locators

LocatorsInArrangement.png
Using Locators to Launch Play in the Arrangement.

Locators can be set at any point in the Arrangement. This can be done in real time during playback or recording with the Set Locator button, and will be quantized according to the global quantization value set in the Control Bar. Clicking the Set Locator button when the Arrangement is not playing will create a locator at the insert marker or selection start. You can also create a locator using the context menu in the scrub area above the tracks or via the Create menu. Note that the position of a new locator is quantized according to the Control Bar’s Quantization menu setting.

LocatorControls.png
The Locator Controls.

You can recall (jump to) locators by clicking on them, or with the Previous and Next Locator buttons on either side of the Set button. Locators can also be recalled using MIDI/key mapping (see Chapter 26). Note that locator recall is subject to quantization. Double-clicking a locator will select it and start Arrangement playback from that point.

After jumping to the first or last locator in the Arrangement, the Previous and Next Locator buttons will jump to the Arrangement start or end, respectively.

Locators can be moved by clicking and dragging, or with the arrow keys on your computer keyboard.

To name a locator, select it by clicking its triangular marker, and choose the Rename Edit menu command (or use the CTRL - R (PC) / CMD - R (Mac) shortcut). You can also enter your own info text (see 2.1.1) for a locator via the Edit Info Text command in the Edit menu or in the locator’s right-click (PC) / CTRL - click (Mac) context menu. Locators can be removed with your computer’s Backspace or Delete key , the Create menu, or the Delete Locator button.

Note that the locator right-click (PC) / CTRL - click (Mac) context menu offers a quick way of looping playback (see 6.5) between two locators with its Loop To Next Locator command.

The locator right-click (PC) / CTRL - click (Mac) context menu’s Set Song Start Time Here command can be used to overrule the default “play starts at selection“ rule: when this command is checked, play starts at the locator.

6.4 Time Signature Changes

TimeSignatureMarkers.png
Time Signature Changes.

Live’s time signature can be changed at any point in the Arrangement by using time signature markers. These can be added at the insert marker position via the Create menu, or anywhere below the beat-time ruler using the right-click (PC) / CTRL - click (Mac) context menu. Time signature markers appear just below the beat time ruler, but this marker area is hidden if a Set contains no meter changes, freeing up additional space at the top of the Arrangement.

In many ways, time signature markers look and function like locators; they can be moved with the mouse or with your computer keyboard’s arrow keys, and their value can be changed using the Edit menu’s Edit Value command (or with the CTRL - R (PC) / CMD - R (Mac) shortcut). They can be also be deleted using the Backspace or Delete key, or via delete commands in the Edit and Create menus.

The time signature marker right-click (PC) / CTRL - click (Mac) context menu offers a number of features, including a Delete All Time Signature Changes command and options to loop or select the area up to the next time signature marker.

Any time signature with a one- or two-digit numerator and a denominator of 1, 2, 4, 8 or 16 can be used as a time signature marker value. The numbers must be separated by a delimiter such as a slash, comma, period, or any number of spaces. These marker values can also be set by adjusting the time signature fields in the Control Bar, either by typing in values or dragging the numerator and denominator sliders. This will change the time signature marker value at the current play location, and works either with the transport stopped or during playback. When the Arrangement contains time signature changes, the time signature editor displays an automation LED in the upper left corner.

TimeSignatureTransport.png
The Time Signature Editor Can Change Time Signature Marker Values, and Shows an Automation LED.

Time signature markers are not quantized; they may be placed anywhere in the timeline, and their positioning is only constrained by the editing grid (see 6.9). This means that it is possible to place meter changes in “impossible“ places — such as before the end of the previous measure. This creates a fragmentary bar , which is represented in the scrub area by a crosshatched region. Live is happy to leave these incomplete measures as they are, but if you’d like your Set to conform to the rules of music theory, you can use the two right-click (PC) / CTRL - click (Mac) context menu options to “correct“ incomplete bars.

FragmentaryBar.png
A Fragmentary Bar and its Resolution Options.

Delete Fragmentary Bar Time deletes the duration of the fragmentary bar from the Arrangement, thereby moving any audio or MIDI on either side of the deleted area closer together in the timeline. The next time signature marker will now fall on a “legal“ barline.

Complete Fragmentary Bar inserts time at the beginning of the fragmentary bar, so that it becomes complete. The next time signature marker will now fall on a “legal“ barline.

Please note that these resolution options affect all tracks — deleting and inserting time changes the length of the entire Arrangement.

If you import a MIDI file (see 5.3) into the Arrangement, you’ll be given an option to import any time signature information that was saved with the file. If you choose to do this, Live will automatically create time signature markers in the correct places. This makes it very easy to work with complex music created in other sequencer or notation software.

6.5 The Arrangement Loop

ControlBarLoopSwitch.png
The Control Bar’s Loop Switch.

For Live to repeatedly play a section of the Arrangement, activate the Arrangement loop by clicking on the Control Bar’s Loop switch.

ControlBarLoopControls.png
The Loop Start Fields (Left) and the Loop Length Fields (Right).

You can set loop length numerically using the Control Bar fields: The left-hand set of fields determines the loop start position, while the right-hand set determines loop length.

The Edit menu’s Loop Selection command accomplishes all of the above at once: It turns the Arrangement loop on and sets the Arrangement loop brace to whatever timespan is selected in the Arrangement.

ArrangementLoopMarker.png
The Arrangement’s Loop Brace.

The loop brace can be selected with the mouse and manipulated with commands from the computer keyboard:

  • the right and left arrow keys nudge the loop brace to the left/right by the current grid setting (see 6.9).
  • the up and down arrow keys shift the loop brace left/right in steps the size of its length.
  • The CTRL (PC) / CMD (Mac) modifier used with the arrow left and right keys shortens or lengthens the loop by the current grid setting.
  • The CTRL (PC) / CMD (Mac) modifier with the arrow up and down keys doubles or halves the loop length.

You can also drag the Arrangement’s loop brace: Dragging the left and right ends sets the loop start and end points; dragging between the ends moves the loop without changing its length.

The loop’s right-click (PC) / CTRL - click (Mac) context menu’s Set Song Start Time Here command can be used to overrule the default “play starts at selection“ rule: when this command is checked, play starts at the loop start.

6.6 Moving and Resizing Clips

A piece of audio or MIDI is represented in the Arrangement View by a clip sitting at some song position in one of Live’s tracks.

DraggingClipInTheArranger.png
Moving a Clip.

Dragging a clip moves it to another song position or track.

DraggingClipEdge.png
Changing a Clip’s Length.

Dragging a clip’s left or right edge changes the clip’s length.

Clips snap to the editing grid, as well as various objects in the Arrangement including the edges of other clips, locators and time signature changes.

6.7 Audio Clip Fades and Crossfades

The beginning and end of audio clips in the Arrangement View have adjustable volume fades. Additionally, adjacent clips on the same audio track can be crossfaded .

To access the fades for an audio track’s clips:

  1. “Unfold“ the track by clicking the 20748.png button next to the track name.
  2. Select “Fades“ in the Fades/Device chooser.
  3. Click and drag the fade handle to change the length of the fade.
  4. Click and drag the slope handle to change the shape of the fade’s curve.
20764.png
Fades in the Arrangement View.

You can also set the length of a fade by selecting a range of time within the clip (see 6.8) that includes the clip’s beginning or end and executing the Create Fade command in the clip’s right-click (PC) / CTRL - click (Mac) context menu.

Adjacent audio clips can be crossfaded. Creating and editing crossfades is similar to creating and editing start and end fades:

  • click and drag a fade handle over the opposite clip’s edge to create a crossfade
  • click and drag the slope handle to adjust the shape of the crossfade’s curve
  • select a range of time that includes the boundary between the adjacent clips and execute the Create Crossfade command from the right-click (PC) / CTRL - click (Mac) context menu.
CrossfadedClips.png
Crossfaded Clips.

Selecting a fade handle and pressing the Delete key deletes the fade, unless the Create Fades on Clip Edges option is enabled in the Record/Warp/Launch Preferences. In this case, pressing Delete returns the fade handle to a default length of 4 ms. With this option enabled, new clips in the Arrangement View will have these short “declicking“ fades by default.

CreateFadesOnClipEdges.png
Automatically Create Short Fades At Clip Edges.

Another result of enabling the Create Fades on Clip Edges option is that adjacent audio clips will get automatic 4 ms crossfades. These can then be edited just like manually-created crossfades.

There are some limits to the length of fades and crossfades:

  • Fades cannot cross a clip’s loop boundaries.
  • A clip’s start and end fades cannot overlap each other.

When a fade handle is selected, a dotted red line will appear on the relevant clip to indicate the limit for that fade handle. This is especially helpful when editing crossfades, because one clip’s loop boundary may be “hidden“ under the other clip.

Note that fades are a property of clips rather than the tracks that contain them, and are independent of automation envelopes (see Chapter 19).

6.8 Selecting Clips and Time

With the exception of moving and resizing clips, Arrangement editing in Live is selection-based: You select something using the mouse, then execute a menu command (e.g., Cut, Copy, Paste, Duplicate) on the selection. This editing method lends itself to an efficient division of labor between the two hands: One hand operates the mouse or trackpad, while the other hand issues the keyboard shortcuts for the menu commands. The menu eventually is only used as a reference for looking up the keyboard shortcuts.

Here is how selection works:

  • Clicking a clip selects the clip.
  • Clicking into the Arrangement background selects a point in time, represented by a flashing insert marker. The insert marker can then be moved in time with the left and right arrow keys, or between tracks via the up and down arrow keys. Holding CTRL (PC) / ALT (Mac) while pressing the left and right arrow keys snaps the insert marker to locators and the edges of clips in the selected track or tracks.
  • Clicking and dragging selects a timespan.
  • To access the time within a clip for editing, “unfold“ its track by clicking the 20818.png button next to the track name.
AdjustingTrackHeight.png
Adjusting an Unfolded Track’s Height.
  1. Clicking and dragging in the waveform display below the clip’s horizontal strip allows you to select time within the clip. Notice that you can adjust the height of the unfolded track by dragging the split line below the Unfold Track button. Note that you can actually unfold all of your tracks at once by holding down the ALT (PC) / ALT (Mac) modifier when clicking the 20850.png button.
  • Clicking on the loop brace is a shortcut for executing the Edit menu’s Select Loop command, which selects all material included within the loop.
  • Holding Shift while clicking extends an existing selection in the same track or across tracks. You can also hold Shift and use the arrow keys to manipulate the selection.
ArrangerSelectLoop.png
Clicking the Loop Brace to Select the Loop for Editing.

6.9 Using the Editing Grid

To ease editing, the cursor will snap to grid lines that represent the meter subdivisions of the song tempo. The grid can be set to be either zoom-adaptive or fixed.

You can set the width of both zoom-adaptive and fixed grid lines using the right-click (PC) / CTRL - click (Mac) context menu available in either the Arrangement View track area or the Clip View display.

The following shortcuts to Options menu commands allow quickly working with the grid:

  • Use CTRL - 1 (PC) / CMD - 1 (Mac) to narrow the grid, doubling the density of the grid lines (e.g., from eighth notes to sixteenth notes).
  • Use CTRL - 2 (PC) / CMD - 2 (Mac) to widen the grid, halving the density of the grid lines (e.g., from eighth notes to quarter notes).
  • Use CTRL - 3 (PC) / CMD - 3 (Mac) to toggle triplets mode; this would, for instance, change the grid from eighth notes to eighth note triplets.
  • Use CTRL - 4 (PC) / CMD - 4 (Mac) to turn grid snapping on or off. When the grid is off, the cursor does not snap to meter subdivisions.
  • Use CTRL - 5 (PC) / CMD - 5 (Mac) to toggle fixed and adaptive grid modes.

The current spacing between adjacent grid lines is displayed in the lower right corner of the Arrangement View or Clip View.

You can hold down the ALT (PC) / CMD (Mac) modifier while performing an action to bypass grid snapping. If the grid is already disabled, this modifier will temporarily enable it.

6.10 Using the ...Time Commands

Whereas the standard commands like Cut, Copy and Paste only affect the current selection, their “... Time“ counterparts act upon all tracks by inserting and deleting time. Any time signature markers within the selected region will also be affected.

  • Cut Time cuts a selection of time from the Arrangement, thereby moving any audio or MIDI on either side of the cut area closer together in the timeline. This command reduces the length of your Arrangement by whatever amount of time you have cut. Note that the Cut Time command affects all tracks, not only the selected ones.
CutTime.png
A Gap Between Clips Has Been Cut by First Selecting It, Then Executing the Cut Time Command.
  • Paste Time places copied time into the Arrangement, thereby increasing its overall duration by the length of time you have copied.
  • Duplicate Time places a copy of the selected timespan into the Arrangement, thereby increasing its overall duration by the length of the selection.
  • Delete Time deletes a selection of time from the Arrangement, thereby moving any audio or MIDI on either side of the deleted area closer together in the timeline. This command reduces the length of your Arrangement by the amount of time you have deleted. Note that the Delete Time command affects all tracks, not only the selected ones.
  • Insert Silence inserts as much empty time as is currently selected into the Arrangement, before the selection.

6.11 Splitting Clips

The Split command can divide a clip or isolate part of it.

To split a clip in two halves, do the following:

  1. Unfold the track;
  2. In the waveform or MIDI display, click at the position where you want the clip to be split;
  3. Execute the Split command.

To isolate a part of a clip, do the following:

  1. Unfold the track;
  2. In the waveform or MIDI display, drag a selection over the part of the clip you want to isolate;
  3. Execute the Split command to divide the original clip into three pieces.
Split.png
The Result of Splitting a Clip.

6.12 Consolidating Clips

The Consolidate command replaces the material in the Arrangement View selection with one new clip per track. This is very useful for creating structure.

CreatingANewLoopWithConsolidate.png
Consolidating Several Clips Into a New Clip.

Suppose you have, by editing or improvising, come up with a layout of clips that sound good in Arrangement Loop mode. Selecting that part of the Arrangement, for instance by using the Edit menu’s Select Loop command, and then executing the Consolidate command creates a new clip that can be treated as a loop. You can now, for instance, drag the clip edges to create more repetitions. You might also want to drag the new loop via the Session View selector into a Session View slot for real-time arrangement purposes.

When operating on audio clips, Consolidate actually creates a new sample for every track in the selection. The new samples are essentially recordings of the time-warping engine’s audio output, prior to processing in the track’s effects chain and mixer. Hence, the new sample incorporates the effects of in-clip attenuation, time-warping and pitch shifting, and of the respective clip envelopes (see Chapter 20); however, it does not incorporate the effects. To create a new sample from the post-effects signal, please use the Export Audio/Video command (see 5.2.3).

The new samples can be found in the current Set’s Project folder, under Samples/Processed/Consolidate. Until the Set is saved, they remain at the location specified by the Temporary Folder (see 16.8).

Download Live 9 manual (PDF)

English, Deutsch, 日本語, Español, Français, Italiano