Certains contenus de ce site ne sont pas encore disponibles en français.

10. Éditer les notes MIDI et leur dynamique

Un clip MIDI dans Live contient des notes et des données de contrôleurs pour faire jouer un instrument MIDI. Cet instrument peut être un instrument virtuel dans la chaîne de périphériques d'une piste MIDI (19) ou un synthé externe piloté par le routage de sortie de la piste (15). Le clip MIDI (4.7) apporte au périphérique une partition musicale à jouer, spécifiant la hauteur, la longueur, la position et la dynamique (parfois nommée vélocité dans le jargon MIDI) de chaque note. Le MIDI est composé et édité dans l'éditeur de notes MIDI de Live.

10.1 Création d'un clip MIDI vide

Les clips MIDI sont créés :

  • en enregistrant sur une piste MIDI (17)  ;
  • ou par capture MIDI (17.10)  ;
  • ou en double-cliquant sur un emplacement ou « slot » vide dans une piste MIDI ;
  • ou en sélectionnant un slot de Session vide dans une piste MIDI et en choisissant la commande Insérer Clip(s) MIDI du menu Créer ;
  • ou en double-cliquant sur l'affichage de piste d’une piste MIDI en écran Arrangement ;
  • ou, en écran Arrangement, en sélectionnant une plage temporelle dans une piste MIDI et en choisissant la commande Insérer Clip(s) MIDI du Menu Créer.

10.2 L’éditeur de notes MIDI

Pour ouvrir l'éditeur de notes MIDI, double-cliquez sur un clip MIDI afin d'afficher la fenêtre Clip. Vous pouvez ensuite choisir l’un des trois onglets de visualisation des clips en cliquant sur leur en-tête, ou en utilisant les combinaisons de touches suivantes :

  • ALT-1 fait passer à l'onglet/panneau Notes
  • ALT-2 fait passer à l’onglet/panneau Enveloppes (Envelopes)
  • ALT-3 fait passer à l'onglet/panneau Expression

Selon l’onglet/panneau de fenêtre Clip choisi, la fenêtre Clip affichera différentes informations. Vous pouvez en savoir plus sur ces onglets/panneaux dans le chapitre Fenêtre Clip (8).

L’éditeur de notes MIDI.

Lorsque l’onglet/panneau Notes est visible, l’éditeur de notes MIDI est divisé en deux fenêtres d’édition : l’éditeur de notes MIDI en haut et les lignes de l’éditeur d’expression en bas (comprenant les lignes d’édition de la dynamique ou « vélocité » (Velocity) MIDI et de la probabilité (Chance) MIDI).

La ligne Velocity de l’éditeur est affichée par défaut, mais elle peut être affichée ou masquée, tout comme la ligne Chance (décrite en détail ci-dessous), grâce aux boutons de sélection de ligne situés sur leur gauche. Sous les boutons de sélection d’affichage/masquage des lignes, un bouton commutateur contenant un triangle permet d’afficher ou de masquer d’un coup toutes les lignes. Lorsque les deux sélecteurs de ligne sont masqués, appuyer sur le bouton contenant un triangle permet d’afficher les deux lignes à la fois.

Ces boutons activent et désactivent la visibilité des lignes Velocity et Chance de l'éditeur.

Les lignes Velocity et Chance de l’éditeur peuvent être redimensionnées individuellement au moyen de leurs lignes de séparation, ou simultanément en faisant glisser la ligne de séparation entre ces lignes et l’éditeur de notes MIDI.

Il est également possible de redimensionner les lignes Velocity, Chance et Expression par note en utilisant la molette de la souris/ le pincement des doigts tout en maintenant la touche ALT enfoncée.

Le commutateur de mode Dessin de la barre de contrôle.

Passez en mode Dessin en activant le sélecteur de mode Dessin en barre de contrôle ou en pressant la touche B. Vous pouvez maintenant dessiner des notes MIDI à la souris dans l'éditeur de notes MIDI. Désactiver le mode Dessin permet de sélectionner des notes et de les déplacer via des opérations impliquant le presse-papiers ou en cliquant dessus et en les tirant, soit verticalement pour changer leur hauteur, soit horizontalement pour changer leur position dans le temps. Des notes MIDI peuvent aussi être ajoutées et supprimées par double-clic quand le Mode Dessin est désactivé.

Le commutateur « Mode Dessin à hauteur fixe » des préférences Record/Warp/Launch vous permet de choisir entre deux façons différentes d’utiliser le mode Dessin. En cas d’activation, le dessin de notes MIDI est limité à une seule ligne (ou hauteur) de note à la fois, tandis que maintenir la touche ALT permet de librement dessiner des mélodies à main levée. Sinon, le mode Dessin est par défaut le dessin de mélodies à main levée, tandis que maintenir la touche ALT active le dessin à hauteur fixe. Le mode de dessin mélodique peut être utilisé pour effacer des notes, lorsque le dessin commence sur une note existante. Lorsque l’éditeur de notes MIDI est ciblé, l’option « Mode Dessin » dans les menus Options et contextuel indique le réglage actuelle de la préférence « Mode Dessin à hauteur fixe », sous la forme « Hauteur fixe activée/désactivée ».

Pré-écoute des notes MIDI.

À condition que la chaîne de périphériques de votre piste MIDI contienne un instrument (19), activer le commutateur Pré-écoute de l'éditeur MIDI vous permet d'entendre les notes quand vous les sélectionnez et les déplacez. Si la piste MIDI est armée, activer la pré-écoute permet aussi un enregistrement pas à pas (17.3.4) de nouvelles notes dans le clip. Notez que l'état on/off du commutateur Pré-écoute s'applique à toutes les pistes MIDI du Set Live.

Après avoir dessiné quelques notes et les avoir déplacées, vous désirerez sans doute savoir comment vous mouvoir dans l'éditeur de notes MIDI. Aussi, avant d'entrer dans les détails de l'édition, nous allons d'abord expliquer la navigation dans l'éditeur MIDI.

10.3 Navigation et transport dans l'éditeur MIDI

La hauteur de la note dans la gamme est donnée verticalement et sa position dans le temps horizontalement.

L'éditeur MIDI permet la navigation verticale et horizontale. Sur l'axe horizontal se trouve une règle temporelle, qui affiche la position de la note le long d'une ligne musicale chronologique. L'axe vertical contient la règle de notes, qui affiche les octaves C0 - C10 (C = do), et une représentation d'un clavier de piano (« piano roll »). Notez que si le commutateur Pré-écoute est activé en haut du clavier de piano, vous pouvez entendre les résultats de votre jeu sur ce clavier.

Navigation dans l'éditeur MIDI.
  1. Pour progressivement changer le niveau de zoom temporel, cliquez sur la règle temporelle et tirez verticalement. Tirez horizontalement dans la règle temporelle pour obtenir un défilement latéral gauche-droite. Tout en faisant défiler vers le haut et vers le bas à l’aide de la molette de la souris, vous pouvez maintenir le modificateur CTRL(Win) / CMD(Mac) pour zoomer horizontalement, ou le modificateur ALT pour zoomer verticalement.
  2. Cliquez et tirez verticalement sur la règle de notes pour afficher d'autres octaves, ou tirez horizontalement pour changer le zoom sur l'axe vertical des notes MIDI et du clavier.
  3. Cliquez et tirez en encadrant une ou plusieurs notes pour les sélectionner, ou sur une portion du fond de l'éditeur pour sélectionner une zone temporelle. Puis, double-cliquez sur la règle des notes ou sur la règle temporelle pour automatiquement zoomer sur votre sélection. Si rien n'est sélectionné, double-cliquer sur la règle des notes entraînera un zoom sur la zone allant de la note la plus basse à la note la plus haute dans le clip, tandis que double-cliquer sur la règle temporelle entraînera un zoom arrière pour afficher le temps compris entre la première et la dernière note. Vous pouvez changer la sélection des notes en utilisant le modificateur CTRL(Win) / ALT(Mac) en combinaison avec la touche flèche haut ou bas.
  4. Pour zoomer en avant et en arrière sur la sélection actuelle, utilisez les touches + et [–] du clavier de l'ordinateur.
  5. La vue générale (vignette) du Clip située juste sous l'éditeur MIDI peut aussi servir à la navigation. Elle affiche toujours la totalité du contenu du clip MIDI sélectionné. L'encadré rectangulaire noir représente la partie du clip actuellement affichée au dessus dans l'éditeur. Pour faire défiler, cliquez dans l'encadré et tirez à gauche ou à droite ; pour zoomer en avant et en arrière, tirez en haut et en bas.
  6. Changez la longueur de ce qui est affiché dans l'éditeur en tirant sur les côtés gauche ou droit de l'encadré dans la vignette du clip.
  7. Pour rapidement changer ce qui est vu dans l'éditeur, cliquez dans la vignette du clip sur une section que vous voulez examiner, puis tirez vers le bas pour un zoom avant, ou faites défiler en tirant à gauche et à droite.
Le commutateur Suivi de lecture de la barre de contrôle.

Dans la barre de contrôle, le commutateur Suivi de lecture peut forcer la zone affichée dans l'éditeur de notes MIDI à défiler en suivant la lecture. Le suivi fera une pause si vous apportez une modification dans l'éditeur de notes MIDI, et recommencera après l’arrêt ou le redémarrage de la lecture, ou un clic dans l'Arrangement ou la zone de scrub du clip.

Quand Zones de scrub permanentes est activé (On) dans les Préférences Look/Feel de Live, cliquer dans la zone de scrub sous la règle mesures/temps lance la lecture depuis ce point, après arrondissement par le réglage de quantification globale. (Astuce : activer la commande Reprendre notes MIDI en cours du menu Options permet aux notes MIDI d’être jouées même si la lecture démarre après l'endroit où elles commencent.)

Quand la préférence Zones de scrub permanentes est désactivée (Off), vous pouvez toujours balayer l'audio en mode scrub par Shift-clic n'importe où dans la zone de scrub ou dans la règle mesures/temps. Étudier les commandes de boucle/région (8.4) et les raccourcis associés peut également être utile pour naviguer dans l'éditeur MIDI et lire des sélections vite et facilement.

Quand vous travaillez avec le MIDI, vous pouvez avoir besoin d'espace supplémentaire à l'écran. Vous pouvez cliquer sur la séparation de fenêtre et la tirer verticalement entre la fenêtre Session ou Arrangement et la fenêtre Clip pour agrandir l'éditeur MIDI.

Agrandissez l'éditeur MIDI en faisant glisser le séparateur des fenêtres Session et Clip.

10.4 Édition MIDI

10.4.1 Édition non destructive

Vous pouvez toujours ramener votre clip MIDI à son état antérieur en employant la commande Annuler du menu Édition. Plus encore, si le clip MIDI édité venait d'un fichier MIDI de votre disque dur, aucune édition ne modifiera le fichier MIDI d'origine, car Live incorpore son contenu dans votre Set Live lors de l'importation.

10.4.2 Gammes, repli et bouclage

En surlignant certaines notes dans la représentation de clavier (piano roll) d’un clip MIDI, le mode Scale (limiter à la gamme) vous permet d’écrire facilement des mélodies dans la gamme choisie. Le mode Scale peut être commuté à l’aide du bouton Scale dans l’onglet/panneau Clip. À droite du bouton Scale, les sélecteurs Tonique et Type de gamme permettent de définir la note tonique et la gamme pour le ou les clips sélectionnés.

Les réglages du mode Scale d'un clip MIDI.

Lorsqu’un clip sélectionné a son mode Scale activé et qu’une gamme est sélectionnée, les notes appartenant à cette gamme sont surlignées dans le piano roll. Par défaut, les lignes des notes appartenant à la gamme sélectionnée sont surlignées dans l'éditeur de notes MIDI, et la tonique est surlignée de façon bien visible dans le clavier vertical. Le surlignage de la gamme peut être activé ou désactivé en appuyant sur la touche de raccourci K lorsque l’éditeur de notes MIDI est sélectionné, ou avec l’option Surligner gammes du clip du menu contextuel et du menu Affichage.

Les lignes des notes appartenant à la gamme sélectionnée sont surlignées.

Les clips MIDI nouvellement créés héritent de la gamme du clip précédemment édité ou visualisé, même si le mode Scale est désactivé. Lorsque vous éditez plusieurs clips ayant des paramètres de tonalité et de gamme différents, tout clip de premier plan dont le mode Scale est activé actualise le réglage global utilisé pour créer de nouveaux clips.

Lorsqu’un clip sélectionné a son mode Scale activé et qu’une gamme est sélectionnée, presser le bouton Scale situé à droite du bouton Fold n’affichera que les lignes de notes appartenant à la gamme choisie. Toute ligne de note contenant des notes qui n’appartiennent pas à la gamme actuelle sera également affichée.

Vous pouvez définir dans le menu contextuel du clavier vertical (piano roll) une préférence pour l'écriture enharmonique des notes d'un clip avec des bémols, des dièses, ou les deux. Lorsque le mode Scale n’est pas activé, ce réglage s’applique à toutes les notes, mais lorsque le mode Scale est activé, cette préférence ne s’applique qu’aux notes extérieures à la gamme choisie ; les notes de la gamme conserveront leurs propres altérations. Une option supplémentaire nommée « Auto » sélectionne automatiquement les bémols ou les dièses en fonction de la position de la tonique dans le cercle des quintes.

Définition d’une préférence pour l’écriture enharmonique des notes d'un clip.

Le bouton Fold (« repli »), situé dans le coin supérieur gauche, est une fonction importante de l'éditeur de notes MIDI. Activer ce bouton masque immédiatement dans chaque clip toutes les rangées, ou pistes de touche, qui ne contiennent pas de notes MIDI. Cela signifie que les pistes de touche disponibles différeront dans chaque clip de votre Set en fonction des notes qui y sont présentes.

C'est très utile pour travailler avec des kits de percussion, par exemple, qui sont souvent répartis tout au long du clavier en sections correspondant à des types de percussions (par ex., caisses claires groupées deux octaves sous les cymbales charleston, etc.). Quand vous travaillez avec un fichier MIDI créé par une telle répartition, seuls un ou deux sons de percussion de chaque type sont parfois utilisés, et il devient inutile de voir la totalité du clavier. (Note : le repli de l'éditeur de notes MIDI n'est pas possible lors de l'édition de plusieurs clips (10.5).)

Le bouton de repli Fold ne garde que les pistes de touches contenant des notes.

En édition MIDI, vous pouvez vouloir changer la partie du clip que vous écoutez, ou mettre en boucle le clip afin de l'écouter répétitivement. À cet effet, vous pouvez vous servir des marqueurs de boucle/région (8.2.5).

Emploi des marqueurs de boucle/région pour sélectionner une zone spécifique à reproduire dans le clip.

Si Fold est désactivé sur une piste contenant un Rack de batterie (20.6), l'éditeur de notes MIDI n’affiche que les rangées des notes correspondant à un pad avec des périphériques. Si Fold est activé, seules les rangées contenant des notes sont affichées.

Astuce : sélectionner l'accolade de boucle dans un clip MIDI et presser CTRL-D(Win) / CMD-D(Mac) double la longueur de l'accolade de boucle et change le zoom en conséquence pour afficher la totalité de la boucle. Toute note située à droite de la boucle sera déplacée, de façon à conserver sa position par rapport à la fin de la boucle.

10.4.3 Magnétisme de grille

La plupart des fonctions de l'éditeur de notes MIDI sont sujettes au magnétisme de grille (6.9). Quand vous ajustez des événements avec la souris, la grille semble « aimantée » ; les événements peuvent être librement déplacés en direction de la ligne de grille précédente ou suivante puis s'y collent quand vous vous en approchez. Vous pouvez tenir enfoncé le modificateur ALT(Win) / CMD(Mac) pendant une action pour suspendre le magnétisme de grille.

Les mouvements de notes respecteront aussi un décalage ou « offset », qui dépend du placement d'origine de la note par rapport à la grille. C'est utile pour préserver un groove ou un style de jeu libre que vous ne désirez pas nécessairement « rendre carré ».

10.4.4 Édition des notes

L'édition dans l'éditeur de notes MIDI est similaire à l'édition dans l'Arrangement (6.8). Dans les deux cas, vos actions portent sur la sélection : vous sélectionnez quelque chose avec la souris, puis vous exécutez une commande de menu (par ex. Couper, Copier, Coller, Dupliquer) sur la sélection.

Voici comment fonctionne la sélection :

  • Cliquer sur une note la sélectionne. Plusieurs notes peuvent être sélectionnées en même temps : « encadrez » plusieurs notes d'un mouvement de souris en cliquant dans un espace vide, puis en tirant pour entourer les notes voulues dans le rectangle en pointillés qui apparaît. [Échap] désélectionne toutes les notes sélectionnées.
  • Cliquer sur le fond de l'éditeur de notes MIDI sélectionne un point dans le temps, représenté par un marqueur d'insertion clignotant.
  • Cliquer sur le fond et tirer sélectionne une zone temporelle. Pressez [Entrée] pour faire alterner la sélection entre la zone temporelle et toutes les notes qui commencent à l'intérieur de celle-ci.

Après avoir placé le marqueur d'insertion, vous pouvez le déplacer à l'aide du clavier de votre ordinateur :

  • Pressez les touches flèches gauche ou droite pour déplacer le marqueur d'insertion sur la gauche ou la droite, conformément aux réglages de la grille. CTRL(Win) / ALT(Mac) plus la touche flèche gauche ou droite déplace le marqueur d'insertion jusqu'au bord de la note voisine.
  • Tenez enfoncée Shift pendant que vous pressez les touches flèches pour allonger ou rétracter l'intervalle temporel sélectionné en déplaçant le marqueur d'insertion. ALT(Win) / ALT(Mac) plus Shift pendant que vous pressez les touches flèches allonge ou rétracte à partir du côté opposé de la sélection.
  • Le marqueur d'insertion peut être déplacé jusqu'au début ou jusqu'à la fin d'un clip MIDI en appuyant respectivement sur la touche [Début (Orig)] ou [Fin].

Comme nous l'avons vu, dans l'éditeur de notes MIDI, les notes peuvent être déplacées à la fois horizontalement (ce qui change leur position dans le temps) et verticalement (ce qui change leur hauteur). Elles peuvent être déplacées en cliquant dessus et en les tirant, ou avec les touches flèches du clavier de votre ordinateur. Les notes déplacées avec les touches flèches sont toujours sujettes au magnétisme de grille et d'offset, tandis que les notes tirées avec la souris peuvent être librement déplacées jusqu'à ce que soit atteint le point de grille ou d'offset précédent ou suivant. Si le clip est reproduit pendant que vous éditez des notes, vous pouvez les entendre jouer à leur nouvelle affectation quand vous les faites glisser.

Plusieurs modificateurs de touches s'appliquent aussi à l'édition de note :

  • Pour transposer par octave les notes sélectionnées, maintenez Shift pendant que vous pressez les touches flèches haut et bas.
  • Shift plus les touches flèches gauche ou droite augmentent ou réduisent la durée des notes sélectionnées, conformément aux réglages de la grille. Pour allonger ou rétracter les notes sans magnétisme de grille, tenez aussi ALT(Win) / CMD(Mac).
  • Pour sélectionner la note voisine sur la même ligne de note, maintenez CTRL(Win) / ALT(Mac) pendant que vous pressez la touche flèche gauche ou droite. CTRL(Win) / ALT(Mac) plus la touche flèche haut ou bas déplace la sélection sur la note voisine en termes de temps.
  • Pour décaler des notes sans magnétisme de grille, tenez ALT(Win) / CMD(Mac) et pressez les touches flèches gauche ou droite.
  • Vous pouvez utiliser le modificateur Shift pour cliquer et ajouter individuellement à votre sélection actuelle des notes ou des sélections supplémentaires par « encadrement ». Vous pouvez aussi supprimer une note de votre sélection en maintenant Shift et en cliquant sur cette note. Maintenir Shift et cliquer sur la représentation de clavier ou « piano roll » ajoute toutes les notes de même hauteur (même ligne de note) à la sélection actuelle, ou les supprime si elles étaient déjà sélectionnées.

Sélectionner une ou plusieurs notes les assujettit aux commandes du menu Édition, comme Copier et Coller. Les notes présentes dans le presse-papiers seront collées à partir de l'emplacement du marqueur d'insertion. Vous pouvez aussi utiliser le modificateur CTRL(Win) / ALT(Mac) pour cliquer sur les notes et tirer afin d'en faire des copies à un nouvel endroit. Si vous cliquez sur des notes et tirez pour les déplacer puis décidez que vous préféreriez les copier, vous pouvez presser le modificateur CTRL(Win) / ALT(Mac) même après avoir commencé à tirer.

Quand vous éditez ou dessinez, vous pouvez parfois placer une nouvelle note par dessus une note existante. Si la nouvelle note empiète sur le début de la note existant déjà, cette dernière disparaît. Si la nouvelle note empiète sur la « queue » de celle existant déjà, la longueur de cette dernière est changée pour que la note se termine juste avant que la nouvelle note ne commence.

10.4.5 Changement de la durée de note

Cliquer sur les bords gauche ou droit d'une note et les tirer change la longueur ou durée de note. Comme pour la position des notes, la durée des notes peut être librement ajustée jusqu'à la ligne de grille précédente ou suivante, mais sera quantifiée si on tire plus sauf si on maintient le modificateur ALT(Win) / CMD(Mac).

Changement de la durée de note.

Astuce : pour donner la même longueur à tout un groupe de notes, sélectionnez-les toutes, saisissez la fin de la plus longue, ramenez-les toutes à une longueur nulle puis étendez-les.

10.4.6 Les commandes ...Zone temporelle dans l'éditeur MIDI

Les commandes standard de presse-papiers comme Couper, Copier et Coller n'affectent que les notes actuellement sélectionnées (ou les notes comprises dans la sélection temporelle). Mais, comme en édition d'Arrangement (6.10), il existe des commandes « ... Zone temporelle » qui agissent sur la totalité du clip MIDI en insérant et en supprimant du temps.

Notez que ces opérations ne changent pas la position de début/fin du clip ni les réglages d'accolade de boucle.

  • Dupliquer Zone temporelle place une copie de l'intervalle de temps sélectionné dans le clip, en même temps que toutes les notes contenues.
  • Supprimer Zone temporelle supprime une sélection de temps du clip MIDI, les notes situées de part et d'autre de la zone coupée se rapprochant dans la timeline pour combler le trou créé.
  • Insérer Silence insère avant la sélection un blanc de la durée de la sélection actuelle.

10.4.7 Quantification des notes

Il existe trois options pour quantifier les notes MIDI dans Live. D'abord, vous pouvez quantifier des notes MIDI quand vous les enregistrez (17.5). Ensuite, comme déjà mentionné, vous pouvez déplacer des notes pour qu'elles se calent sur les lignes visibles de la grille. Enfin, vous pouvez sélectionner une ou plusieurs notes et choisir la commande Quantifier du menu Édition, ou utiliser le raccourci clavier CTRL-U(Win) / CMD-U(Mac). La première fois que vous faites cela, vous voyez une boîte de dialogue avec plusieurs options de quantification. La quantification utilisera les réglages par défaut ou ceux que vous aurez déjà appliqués.

Pour régler vos paramètres de quantification, ouvrez la boîte de dialogue Réglages de quantification par le menu Édition.

Quantifier des notes MIDI.

A l'aide de ces options, vous pouvez sélectionner soit l'intervalle de grille actuel soit une valeur musicale spécifique pour la quantification et choisir si la quantification s'appliquera au début ou à la fin de la note (ou aux deux). Quantifier la fin de la note étirera la note pour qu'elle se termine sur la sous-division de mesure choisie. Vous pouvez aussi quantifier les notes sans leur donner cette sensation « mécanique » en utilisant la commande Rigueur, qui détermine le pourcentage de « rigueur » de l'application de la quantification choisie.

10.4.8 Édition des dynamiques

Pour changer la dynamique («  vélocité ») d’une note MIDI, cliquez sur le marqueur associé dans l’éditeur de dynamique (ligne Velocity) et tirez-le Les valeurs de dynamique seront affichées numériquement dans l’en-tête de l’éditeur de dynamique. Pour vous aider à localiser le marqueur de dynamique appartenant à une note MIDI pouvant être empilée verticalement avec d'autres, Live surligne le marqueur de dynamique de toute note survolée par votre souris.

Changement de la dynamique de note.

Comme dans l'éditeur de notes MIDI, vous pouvez sélectionner plusieurs marqueurs de dynamique à modifier en cliquant tout en maintenant enfoncé le modificateur Shift.

Astuce : pour donner la même dynamique à tout un groupe de notes, sélectionnez leurs marqueurs dans l'éditeur de dynamique, tirez-les vers le haut ou le bas jusqu'à la dynamique maximale ou minimale puis ramenez la dynamique à la valeur désirée.

Comme déjà vu, le mode Dessin permet de dessiner des dynamiques identiques pour toutes les notes d'un carreau de grille. En mode Dessin, le dessin de dynamique est limité aux seules notes actuellement sélectionnées. Pour dessiner individuellement des marqueurs (comme pour faire un crescendo, par exemple), désactivez le magnétisme de la grille avec le raccourci CTRL-4(Win) / CMD-4(Mac), ou tenez simplement le modificateur ALT(Win) / CMD(Mac).

Dessin de dynamiques identiques (gauche) et d'un crescendo (droite).

Astuce : pour dessiner une progression dynamique avec des notes appartenant toutes à la même ligne de note, cliquez sur une touche dans la représentation de clavier pour sélectionner toutes les notes de la ligne souhaitée. Assurez-vous que le mode Dessin n'est pas activé et dessinez la ligne dans l'éditeur de dynamique. Cela n'affectera que les notes sélectionnées.

Astuce n°2 : pour dessiner une pente de dynamique linéaire sur une sélection de notes, sélectionnez d'abord les notes qui doivent être affectées (avec le modificateur Shift si nécessaire pour sélectionner des notes non adjacentes). Assurez-vous que le mode Dessin est activé et dessinez la ligne dans l'éditeur de dynamique en maintenant enfoncé le modificateur CTRL(Win) / ALT(Mac).

Chaque note de l'éditeur de notes MIDI indique sa dynamique par l’intensité de sa couleur – les notes claires jouent doucement, et les notes foncées plus fort. Pour changer la dynamique des notes sans ouvrir l'éditeur de dynamique, cliquez sur n'importe quelle note sélectionnée et tirez verticalement en maintenant pressé le modificateur ALT(Win) / CMD(Mac).

Quand on maintient la touche CTRL(Win) / CMD(Mac) pressée en mode Dessin, les mouvements verticaux correspondent à des changements de dynamique. Cela signifie que vous pouvez dessiner plusieurs notes et leur dynamique sans relâcher le bouton de la souris, avec un déplacement horizontal et un vertical. Si vous changez la dynamique avec ce mouvement vertical, Live mémorise le changement et utilise votre nouvelle dynamique pour toutes les notes dessinées ensuite.

Les valeurs de dynamique peuvent également être saisies manuellement en sélectionnant d’abord le marqueur de dynamique, puis en tapant la valeur numérique sur le clavier de l’ordinateur puis en appuyant sur la touche [Entrée]. Maintenir la touche Shift permet de régler avec plus de précision les valeurs des marqueurs de dynamique sélectionnés. Lorsque vous utilisez les touches flèches haut ou bas avec la touche CTRL(Win) / CMD(Mac) enfoncée, les valeurs des marqueurs de dynamique sélectionnés changent par pas de ±10.

Les valeurs de dynamique peuvent être randomisées en cliquant d’abord dans la ligne de l’éditeur de dynamique, ce qui changera le curseur Randomize Range en une valeur entière. Cliquer sur le bouton Randomize donnera des valeurs de dynamique aléatoires aux notes sélectionnées (ou aux notes dont les marqueurs sont sélectionnés). Si aucun marqueur n'est sélectionné, les valeurs de toutes les notes sont randomisées.

Le bouton Randomize.

Le curseur Plage de randomisation, à droite du bouton Randomize, permet de spécifier la plage de randomisation applicable aux valeurs de dynamique. La valeur de randomisation du curseur peut être saisie numériquement au clavier, et déclenche la randomisation lorsqu’elle est validée avec la touche Enter. Les valeurs de dynamique seront augmentées ou diminuées de façon aléatoire d’une valeur comprise entre zéro et le nombre indiqué dans le curseur Plage de randomisation.

Le curseur Plage de randomisation.

Le curseur Velocity Range (plage de dynamique) permet un meilleur contrôle en augmentant la plage de dynamique de chaque note. Les valeurs de dynamique seront choisies au hasard dans la plage spécifiée. Par exemple, une note avec une valeur de dynamique de 60 combinée à une plage de dynamique de +20 sera jouée avec une valeur choisie au hasard entre 60 et 80. Les valeurs positives augmentent la dynamique, tandis que les valeurs négatives la diminuent.

Le curseur Plage de dynamique.

Maintenir CTRL(Win) / CMD(Mac) et tirer verticalement un marqueur de dynamique révèle une poignée horizontale, que l’on peut faire glisser vers le haut ou le bas pour fixer la valeur maximale ou minimale de la plage de dynamique. La plage de dynamique est indiquée par la zone ombrée entre la poignée horizontale et le marqueur de dynamique. Un double-clic sur le marqueur de dynamique ramène la plage à 0.

Dynamique de relâchement (Note Off)

Par défaut, l'éditeur de dynamique vous permet de régler les dynamiques d'enfoncement (Note On). Mais vous pouvez faire basculer l'éditeur en affichage des dynamiques de relâchement (Note Off) avec les options du menu contextuel obtenu par [clic droit](Win) / [CTRL-clic](Mac) sur l'éditeur.

L'éditeur de dynamique affichant les dynamiques de relâchement (Note Off).

La dynamique de Note Off (ou de « relâchement ») est un paramètre quelque peu ésotérique qui n'est pris en charge que par certains appareils. L'instrument Sampler d'Ableton (26.7), par exemple, propose la dynamique de Note Off comme contrôleur pour une variété de paramètres.

10.4.9 Édition des probabilités

L’éditeur de probabilité (Chance, sous l’éditeur de dynamique/Velocity) permet de définir la probabilité qu’une note MIDI se produise lors de la lecture d’un clip. La ligne de l’éditeur de probabilité est masquée par défaut et peut être affichée en cliquant sur son bouton d’affichage/masquage situé à gauche.

L’éditeur de probabilité (Chance).

Pour changer la probabilité d’une note MIDI, cliquez sur le marqueur associé dans l’éditeur de probabilité (ligne Chance) et tirez-le. Vous pouvez faire glisser vers le haut ou le bas le marqueur de probabilité d’une note pour modifier la valeur de la probabilité de 0 à 100 % (pour vous aider à localiser le marqueur de probabilité appartenant à une note MIDI pouvant être empilée verticalement avec d’autres, Live surligne le marqueur de probabilité de toute note survolée par votre souris). Les changements de probabilité seront affichés numériquement dans l’en-tête de ligne Chance (éditeur de probabilité).

Les valeurs de probabilité peuvent également être saisies manuellement en sélectionnant d’abord le marqueur de probabilité, puis en tapant la valeur numérique sur le clavier de l’ordinateur puis en appuyant sur la touche [Entrée]. Maintenir la touche Shift permet de régler avec plus de précision les valeurs des marqueurs de probabilité sélectionnés. Lorsque vous utilisez les touches flèches haut ou bas avec la touche CTRL(Win) / CMD(Mac) enfoncée, les valeurs des marqueurs de probabilité sélectionnés changent par pas de ±10.

Pour randomiser les valeurs de probabilité, cliquez d’abord dans la ligne de l’éditeur de probabilité. Cela changera la valeur du curseur Plage de randomisation en un pourcentage. Cliquer sur le bouton Randomize donnera des valeurs de probabilité aléatoires aux notes sélectionnées (ou aux notes dont les marqueurs sont sélectionnés) en fonction de la ligne ciblée. Si aucun marqueur n'est sélectionné, les valeurs de toutes les notes sont randomisées.

Le bouton Randomize.

Le curseur Plage de randomisation, à droite du bouton Randomize, permet de spécifier la plage de randomisation applicable aux valeurs de probabilité. La valeur de randomisation du curseur peut être saisie numériquement au clavier, et déclenche la randomisation lorsqu’elle est validée avec la touche Enter. Les valeurs de probabilité seront augmentées ou diminuées de façon aléatoire d’une valeur comprise entre zéro et le nombre indiqué dans le curseur Plage de randomisation.

Le curseur Plage de randomisation.

Les notes dont la valeur de probabilité est inférieure à 100 % afficheront un petit triangle dans leur coin supérieur gauche, qui ne sera visible que si la hauteur de la ligne de note est suffisante ; sinon, il sera masqué.

10.4.10 Étirement de note MIDI

Marqueurs d'étirement de note MIDI.

Quand plusieurs notes ou une zone temporelle sont sélectionnées dans l'éditeur de notes MIDI, des marqueurs d'étirement de notes apparaissent, permettant aux notes d'être proportionnées dans le temps. Les marqueurs sont une paire d'indicateurs pointant vers le bas qui se calent sur le début et la fin de la sélection.

En cliquant sur les marqueurs et en les tirant horizontalement, les notes sélectionnées bougent et s'étirent pour conserver la proportion de temps qu'elles occupaient initialement. Comme les notes, les marqueurs d'étirement de notes peuvent être librement déplacés jusqu'à ce que soit atteint le point de grille ou d'offset précédent ou suivant, après quoi ils se calent sur les lignes de grille de l'éditeur de notes MIDI sauf si la grille n'est pas affichée ou si le modificateur ALT(Win) / CMD(Mac) est enfoncé pendant qu'on les tire.

Quand la souris est entre les marqueurs d'étirement de notes, un « pseudo » marqueur d'étirement apparaît. Le tirer allonge ou comprime les données entre les marqueurs fixes sans affecter les données qui leur sont extérieures. Le pseudo marqueur d'étirement a le même comportement de magnétisme de grille que les marqueurs fixes.

Quand des notes (mais pas une zone temporelle) sont sélectionnées, un marqueur peut être tiré au-delà de la limite de l'autre, ce qui « réfléchit » l'ordre des notes étirées par rapport à leur séquence initiale ; on appelle parfois cela un comportement « rétrograde ».

Ajuster les marqueurs d'étirement de notes ajuste aussi le timing de toute enveloppe de clip associée (couplée) au clip. Les enveloppes de clip non couplées ne sont pas affectées.

10.4.11 Recadrage de clips MIDI

Les données MIDI extérieures à l'accolade de boucle peuvent être supprimées au moyen de la commande Recadrer Clip. Il suffit d'un [clic droit](Win) / [CTRL-clic](Mac) sur un clip MIDI en écran Session ou Arrangement pour pouvoir ensuite sélectionner cette option. Contrairement au recadrage des clips audio (8.2.8), le recadrage d'un clip MIDI ne crée pas de nouveau fichier sur le disque.

10.4.12 Désactivation de notes

Pour désactiver, ou couper (Mute), une ou des notes dans l'éditeur MIDI, sélectionnez-les et pressez 0. La commande Désactiver Note(s) coupera le son de la note (Mute), qui apparaîtra grisée dans l'affichage. Pressez à nouveau 0 pour réactiver les notes. Vous pouvez d'un coup désactiver ou réactiver toutes les notes d'une même ligne de note en cliquant sur une touche du clavier vertical ou piano roll et en pressant 0.

10.4.13 Les outils de transformation

En plus des possibilités d’édition de l’éditeur de notes MIDI lui-même, les outils de transformation (8.3) de l’onglet/panneau Notes offrent plusieurs façons de rapidement manipuler les notes d’un clip MIDI.

10.5 Édition de plusieurs clips

Dans l'éditeur de notes MIDI, vous pouvez voir les notes de plusieurs clips MIDI à la fois. Cela vous aide à voir les relations mélodiques et rythmiques entre les différents clips lors de la création et du peaufinage des idées musicales, et vous permet d'éditer plus rapidement les données de pistes et de scènes distinctes. Et outre les notes dans plusieurs clips, vous pouvez également modifier divers paramètres des clips sélectionnés.

Quand plusieurs clips MIDI sont sélectionnés :

  • Les notes de ces clips seront affichées ensemble dans l'éditeur de notes MIDI. Vous pouvez sélectionner et éditer en même temps des notes dans plusieurs clips sélectionnés, ou utiliser le mode Focus (10.5.1) pour éditer les notes d’un seul clip tout en gardant visibles les notes des autres clips.
  • Les barres de bouclage s'affichent au-dessus de l'éditeur de notes MIDI. Chaque barre de bouclage représente un clip différent dans la sélection actuelle, et les couleurs des barres de bouclage correspondent à la couleur des clips. Cliquer sur une note ou sur la barre de bouclage d’un clip rend ce dernier éditable.
Barres de bouclage multi-clips dans l'éditeur de notes MIDI.
  • Vous pouvez individuellement ajuster la longueur de la boucle de n’importe quel clip en cliquant sur son marqueur de barre de bouclage et en le tirant. Vous pouvez également sélectionner et éditer les barres de bouclage de n’importe lesquels des clips sélectionnés simultanément, en cliquant sur leurs marqueurs de bouclage et en les tirant tout en maintenant la touche CTRL(Win) / CMD(Mac). L’utilisation de la touche Shift vous permet de sélectionner des barres de bouclage contiguës. (Note : lorsque le mode Focus est activé, il n’est pas possible de sélectionner plus d’une barre de bouclage à la fois, et toute multi-sélection existante est ignorée.)
  • Vous pouvez dupliquer les barres de bouclage sélectionnées au moyen d’une option de son menu contextuel obtenu par [clic droit](Win) / [CTRL-clic](Mac).
  • La barre de titre affiche le nom du clip sélectionné pour l'édition. Cela peut être particulièrement utile pour distinguer entre eux des clips ayant la même couleur. (Note : si un clip n'a pas de nom, la barre de titre affiche à la place le nom de la piste qui le contient.)
  • Certaines commandes de la fenêtre Clip (8.1) apparaissent lorsque plusieurs clips MIDI sont sélectionnés et qu’elles sont modifiables pour tous les clips sélectionnés. Ces commandes comprennent les réglages de boucle (Loop), la mesure (Signature) du clip, les réglages de groove du clip et les réglages du mode Gamme (Scale).
  • Les réglages de repli (Fold) et de limitation à la gamme (Fold to Scale) peuvent tous être modifiés pour tous les clips sélectionnés.
  • La randomisation des valeurs de dynamique (Velocity) et de probabilité (Chance) n'est jamais appliquée qu'à un seul clip à la fois. Il n'est pas possible de randomiser ces valeurs pour toutes les notes de tous les clips sélectionnés.
  • Vous pouvez redimensionner la région de la barre de bouclage en cliquant directement au-dessus de la zone de scrub de la barre de titre du multi-clip et en tirant.

Notez que l’édition multi-clip fonctionne différemment en écran Session et en écran Arrangement. Ces différences sont expliquées dans les sections dédiées à l'écran Session (10.5.2) et à l'écran Arrangement (10.5.3) plus bas dans ce chapitre.

10.5.1 Mode Focus

Le mode Focus vous permet de sélectionner un clip à éditer seul tout en visualisant plusieurs clips. Le mode Focus s’active/se désactive avec le bouton Focus ou le raccourci clavier N. Maintenir N pendant l'édition avec la souris commute temporairement le mode Focus. L’édition multi-clip fonctionne différemment selon que le mode Focus est activé ou non.

Le bouton Focus active/désactive le mode Focus.

Lorsque le mode Focus est activé :

  • Les notes du clip éditable sont affichées dans la couleur de ce clip, tandis que les notes des clips inactifs sont affichées en gris.
  • La barre de bouclage du clip éditable est affichée en noir, tandis que celles des clips inactifs sont affichées en gris.
  • Le nom du clip éditable s’affiche sous les barres de bouclage.
  • Survoler avec la souris les notes ou la barre de bouclage d’un clip inactif révèle la couleur de ce clip, pour vous aider à choisir dans la sélection actuelle un autre clip à éditer. Cliquer sur une note ou sur la barre de bouclage d’un clip rend ce dernier éditable.
  • Les commandes de longueur de boucle et les outils de l'onglet Notes sont disponibles pour modifier le clip éditable.
  • L’activation du mode Scale affiche la tonique et le nom de la gamme pour le clip actuellement sélectionné.
  • Si l’option Limiter à la gamme (Fold to Scale) est activée, les lignes de note sont limitées aux gammes de tous les clips sélectionnés. L’activation du repli (Fold) désactivera l’option Limiter à la gamme (Fold to Scale) et n’affichera que les lignes de note utilisées par les clips sélectionnés.
  • Les commandes Transposer, Reverse, Invert, Legato et Duplicate de l’onglet Notes ne s’appliquent qu’au clip éditable.

Lorsque le mode Focus est désactivé :

  • Toutes les notes sont affichées avec la couleur de leur clip, car toutes les notes sont éditables.
  • La barre de bouclage d’un clip devient noire quand on clique dessus, ce qui permet alors de randomiser la dynamique (Velocity) ou la probabilité (Chance) des notes de ce clip en cliquant d'abord dessus. L'accolade de boucle non sélectionnée affichera la couleur de son clip.
  • Quand le mode Scale est activé, la tonique et le type de la gamme pour les clips actuellement sélectionnés ne s’affichent que si tous les clips ont les mêmes. Sinon, un astérisque est affiché lorsque des toniques ou des types de gamme différents sont choisis.
  • Les commandes Transposer, Reverse, Invert et Legato de l'onglet Notes s'appliquent à tous les clips sélectionnés. Notez que les commandes Reverse, Invert et Legato ne fonctionnent que si au moins une note est sélectionnée.
  • Les fonctions Duplicate, Lecture à demi-tempo et Lecture à double tempo peuvent être appliquées à plusieurs notes dans les clips sélectionnés.
  • Les notes peuvent être coupées ou copiées à partir de plusieurs clips et insérées dans le même ensemble de clips, tant que la sélection du clip/clip de premier plan n'a pas changé, ou dans un clip différent une fois que ce nouveau clip a été sélectionné.
  • Les fonctions d'édition de notes (par exemple, copier, couper, coller, supprimer) peuvent être utilisées pour travailler avec des sélections de notes au-delà des clips et des limites de boucle.
  • Le temps dans l'éditeur de notes MIDI peut être sélectionné au-delà des limites de la boucle et du clip.

10.5.2 Édition en écran Session

En écran Session, vous pouvez sélectionner et voir à la fois jusqu’à huit clips MIDI bouclés. Dans l'éditeur de notes MIDI, les barres de bouclage sont classées verticalement (d'abord par piste, puis par scène).

Si plusieurs clips de différentes longueurs sont sélectionnés, l'éditeur de notes MIDI affiche autant d'itérations de boucle que nécessaire pour réaligner les clips. Les points de bouclage sont représentées par des lignes verticales noires dans l'éditeur de notes MIDI. Les clips dont le marqueur de début se trouve avant le début de la boucle sont représentés par une barre en haut de l'éditeur de notes MIDI.

Si l'édition multi-clip est utile pour examiner des clips appartenant à des pistes différentes, elle peut également s’avérer pratique lorsque vous devez comparer et éditer plusieurs clips d’une même piste. Par exemple, vous pouvez créer des progressions de patterns par ajout de notes à un clip, puis apporter une variation au clip de la scène suivante et ainsi de suite, tout en gardant une vue d’ensemble des autres clips de la piste.

10.5.3 Édition en écran Arrangement

En écran Arrangement, vous pouvez sélectionner et voir les clips MIDI d’un maximum de huit pistes sur un intervalle de temps sélectionné. Dans l'éditeur de notes MIDI, les barres de bouclage sont classées verticalement par piste et chronologiquement sur l’horizontale.

Les notes peuvent être dessinées continuellement au-delà des limites du clip, sauf en mode Focus.

L'éditeur de notes MIDI n'affiche pas le silence avant ou après la sélection de clips – il ajuste sa plage d'affichage pour aller du début du premier clip à la fin du dernier clip de la sélection. Si la sélection contient des clips bouclés et d’autres qui ne le sont pas, le bouton Loop apparaît à moitié coloré.

Download Live 11 manual (PDF)

English, Deutsch, 日本語, Español, Français, Italiano, 简体中文