Suite 9 Upgrade not installing - anyone else struggling with this?

Hey everyone,

 

I've been struggling with this for a few days. Ableton support is very slow to provide any sort of comprehensive answer.

 

I had Ableton Standard 9.0.6. 

 

I paid to upgrade to Suite 9.1.2 and downloaded the setup file.

 

The setup file, when run, would show a working icon for a bit, and then the icon would go away. That's it. No installation.

 

I tried downloading it again. Same thing - no effect.

 

I tried checking my licenses. I've been upgraded to a Suite license. The support person confirmed this. 

 

I uninstalled Ableton Standard, thinking that would allow Suite to install. Again, no luck.

 

Now I have no copy of Ableton installed on my computer. I could install Standard 9.0.6, but that's an old version and wasn't upgrading before anyway.

 

I can't access the latest version of Standard - my account page only gives me access to the Suite upgrade file now.

 

Thoughts? Similar experiences?

So frustrating!

 

-David

One follower

DavidYates 9 months ago | 0 comments

1 answer

  • DavidYates
    contribution
    1 answer
    1 vote received
    1 vote

    I finally found the answer after a lot of stumbling around:

     

    1) I right-clicked on the setup.msi file.
    2) In the general tab, at the bottom, there was a section labelled "Security" with the message, "This file came from another computer and might be blocked to help protect this computer." Next to that message was a button labelled "Unblock."
    3) I clicked the button, then tried installing, and it worked!
    9 months ago | 0 comments

You need to be logged in, have a Live license, and have a username set in your account to be able to answer questions.

Answers is a new product and we'd like to hear your wishes, problems or ideas.