Push lost communication with live after windows 10 upgrade

Anyone had this issue?

Push is recognized in Windows all seems fine ther.

In live I see the device and can select is as an input. But on Push's display there's only "Please start Live to play"

No matter what I try to configure in Live's midi dialog it doesn't react.

Also my Novation 61SL MkII won't work in automap mode, I can only use it a simple midi keyboard.

Thanks!

5 followers

bjoeri 1 year ago | 0 comments

4 answers

  • mcbpete
    contribution
    185 answers
    205 votes received
    1 vote

    Have you made sure the Push is definitely on *before* loading Ableton - Even if I've only *just* clicked the icon to launch Ableton and then almost instantly turned on the push it won't see it properly. However if I wait till the "Please start Live to play" text appears and then launch Ableton all is fine (am also a recent upgrader to Windows 10)

    1 year ago | 2 comments
  • Professor Alfredsson
    contribution
    1 answer
    1 vote received
    1 vote

    I had the same issue. Windows 10 stopped recognising Push 2 after upgrade from one Windows 10 release to another. I got it working by:

    1. Turn off Push and Live

    2. Open Device Manager and select Actions -> Scan for Hardware Changes

    3. Start Live

    4. Start Push

    5. Perform step 2 again. This made Push light up again and it is now displayed in the Device Manager

     

    11 months ago | 0 comments
  • bjoeri
    contribution
    4 answers
    19 votes received
    1 vote

    I tried all of above suggestions which didn't do any good.

    But This is what fixed it, I had to delete some previous version from C:\ProgramData\Ableton\*version*, I tested which of the previous version worked (9.1.2), deleted all others and then upgraded to 9.5 again.

    Also cleaned up in "C:\Users\*USER*\AppData\Roaming\Ableton\ (all older versions)

    Something in one of those folders was corrupt.

    After that I reinstalled latest version of Ableton. Voala, worked.

     

    11 months ago | 0 comments
  • bigbounce
    contribution
    1 answer
    1 vote received
    1 vote

    uninstall automap. it made ableton lag like crazy i would constantly get a program not responding header. it also made push unusable when ableton would work. novation is complete crap but hey ive got an impulse49 that makes a great paper weight. cant wait to sell it 

    9 months ago | 0 comments

You need to be logged in, have a Live license, and have a username set in your account to be able to answer questions.

Answers is a new product and we'd like to hear your wishes, problems or ideas.