Can't record external instrument

Hi,

I don't seem to be able to record an external MIDI synth using the External Instrument device. Whenever I try to record in any way -ie freeze the track or render the mix, the recording fails after 10 attempts, saying 'waiting for external instruments or effects to become silent' each time. There's no significant audible noise on any of the inputs being recorded, so I think this is either a spurious error message, or the noise threshold is set way too low. This is quite frustrating- I can play my external synths via MIDI, but can't record their audio outputs in Live...

Anyone any thoughts on what might be going on?

I've tried routing the audio out of the track with the External Instrument on it into another track for recording, incidentally, and it's recorded with a delay, which makes that useless. I know latency with external MIDI devices is a minefield, judging my all the posts about it, so I'll leave that to another post, I think.

MacOS X 10.7.7
MOTU 828 Mk.3 (latest drivers)
MOTU MIDI Express 128
Live 8.2.8

a|x

1 answer

  • Near Earth Object
    contribution
    461 answers
    493 votes received
    1 vote

    I have had the same problem with some of my hardware. Nord Lead 2, for instance,does not work with the external instrument plugin somehow.
    What does work however (in my case) is this:
    Insert a new midi track, and route it to the midi channel that controls your external device.then insert a new audio track, and set the input to the channels your external device uses. You can change the latency by changing the track delays.
    In the worst case you have to record the audio real time.

    1 year ago | 0 comments

You need to be logged in, have a Live license, and have a username set in your account to be able to answer questions.

Answers is a new product and we'd like to hear your wishes, problems or ideas.