Ableton wont recognize midi mapping

I'm trying to get my foot controllers to map into Ableton and cannot figure out why it will not work. I have two pedals I have tried. Awhile ago I bought a pedal from someone on here I think it is called Ability Controller? Also have tried my Line 6 HD500. I am having the same problems with both pedals.

First when I am in midi mapping mode and press a button I see the midi not appear at first...something like "1/G-2" but after releasing the button it immediately changes to "1/7"
Also in the midi mapping browser under note control at first the note appears saying "note G-2" but then when I release button it changes to "cc 7"

Also if I try to map my first scene (I am trying to map scenes to play when I press each button) it appears to be mapped ("1/G-2" switching to "1/7") and then when I try to map the next scene to a different button on the controller an alert pops up saying "The selected controller conflicts with the previous mapping to master scene 2. Do you want to replace the previous mapping?"

I'm sure it is something obvious that I am missing. In preferences I have looked for the control surface and don't see anything obvious that would relate to my controllers. Am I supposed to install them somehow? Why would they still map anything even if it isnt what I want? Any help would be greatly appreciated.

One follower

jo9shw 10 months ago | 0 comments

You need to be logged in, have a Live license, and have a username set in your account to be able to answer questions.

Answers is a new product and we'd like to hear your wishes, problems or ideas.