Ableton emptying RAM cache

Hi all,

I'd be grateful for your help with this catastrophic problem!

I use Live for performance. I'm having an issue with Ableton Live 9 where every now and then there seems to be a CPU spike: it displays OFF in red in the CPU meter. This is despite the CPU generally hovering around 30% and nothing significant correlating to the CPU spike.

When this happens, I think the RAM is emptied or something - it seems as if Sample Instrument samples have to be reloaded e.g. Kontakt shows a display loading its samples, and Ableton will stop playing for around 3 to 4 beats. Sound stops and of course, my drummer then has to dry and work out where we are in the track!!! It's a disaster.

I wonder if this is something to do with the buffer size being automatically adjusted. It seems to go through exactly the same processes as when you adjust the Buffer Size setting in Logic Pro preferences - i.e. play stops and all Kontakt and other Sample instrument samples have to be reloaded into the RAM cache.

Has anyone experienced this before? Is there anything that can be done to avoid this? It is disastrous and might spell the end of my time with Live. And I'll have to go back to Mainstage. And I hate Mainstage!

Any help would be so appreciated - thanks so much in advance!!


Late 2013 Macbook Pro 15inch retina, 2.6GHz 16GB RAM, Yosemite, UAD Apollo 16

One follower

Alexthelm 7 months ago | 0 comments

You need to be logged in, have a Live license, and have a username set in your account to be able to answer questions.

Answers is a new product and we'd like to hear your wishes, problems or ideas.