Auto arm selected tracks.

Hello. I thought this was an option but I can't find it. I'm doing some jamming and hitting a frustrating roadblock.

I want to stay in the loop and jam with different instruments. However when I try to select another track it doesn't automatically arm it for recording

Is this possible?

8 followers

elijahlucian 1 year ago | 0 comments

6 answers

  • sporkles
    contribution
    1 answer
    4 votes received
    4 votes

    Hi. With a Push connected, Live automatically acts this way. If you don't have a Push, though, you can still get Live to automatically arm the selected track. First, you need to create an "Options.txt" file - read this article for the specifics: 

    https://www.ableton.com/en/help/article/optionstxt-file-live/

    When you've created the file, all you need to put in there is this short line:

    -EnableArmOnSelection

    When you launch Live, you just need to make sure that a track is armed at first, and from now on, the selected track will automatically be armed.

    6 months ago | 2 comments
  • vbQmcXd9
    contribution
    1 answer
    2 votes received
    2 votes

    Did you find the answer? I am having the same problem.

    10 months ago | 0 comments
  • palewine
    contribution
    2 answers
    3 votes received
    2 votes

    I'd like to know this also. It was possible with a config file tweak in previous versions, but I don't know about any more...

    10 months ago | 0 comments
  • neeve82
    contribution
    5 answers
    6 votes received
    1 vote

    +1

    7 months ago | 0 comments
  • 0x80
    contribution
    4 answers
    5 votes received
    1 vote

    +1

     

    6 months ago | 0 comments
  • antic604
    contribution
    2 answers
    2 votes received
    1 vote

    Is there a reference for options.txt file i.e. a list of all available functions? The link provided above has few of them, but e.g. does not include the "-EnableArmOnSelection" so it's not exhaustive?

    I'm particularly looking for a way to set the "Bin Offset" encoder mode to be the default for when I assign my MIDI controller to Live's parameters, because currently it wrongly assumes the "Absolute" mode which I have to change manually each time.

    14 days ago | 0 comments

You need to be logged in, have a Live license, and have a username set in your account to be able to answer questions.

Answers is a new product and we'd like to hear your wishes, problems or ideas.