Contact support or Ask other Live users

Is Live 1-7 compatible with Mac OS X 10.7 Lion?

  • Live Versions: 1 - 7
  • Operating System: OSX 10.7 and above

We will not update Live 7 or older versions for Lion or above. 

Related tags: system