Contact support or Ask other Live users

Is Max 6 compatible with Max for Live?

  • Live Versions: 8.1 - 8.3.4
  • Operating System: ALL

If you own Max 6, you can use it as your Max for Live editor. If you do not own Max 6, then you will need to either use Max 5 as your editor or purchase Max 6.

Related tags: Max for Live