Contact support or Ask other Live users

What do I need to use the Bridge?

  • Live Versions: 8.2 - 9
  • Operating System: ALL

The Bridge requires Ableton Live / Suite 8.2 or above, Serato Scratch Live 2.1.1 or above and Rane Serato Scratch Live hardware.

The Bridge is not supported by Ableton Live Lite, Ableton Live Intro, Ableton Live Akai Professional APC edition and Ableton Live Launchpad edition.

Related tags: bridge