Routing behavior

Hi there

Today I realized that whenever I drop a clip in the session view (shouldn't be different in the arrangement view) into an empty track without any effects on it, Ableton changes back my routing (audio out and audio in) to master. For example I've routed Audio 1 Track to Audio 2, so the audio out of Audio 1 is set to Audio 2. Now, let's drop a clip into the otherwise empty Audio 1 and Audio To changes back to Master.

Strange enough, when I attach an effect onto the Audio 1 track and replay the game, the audio out setting stays. So in order to have the routing settings stay as I've changed them and be able to delete and drop new tracks in a certain track, I'm forced to have an effect on the said track. This is so wrong when it comes to CPU load and usability. Why on earth does Ableton program it like that?

 

2 followers

manveru0 10 months ago | 0 comments

2 answers

  • Near Earth Object
    contribution
    778 answers
    794 votes received
    1 vote

    Hello,

     

    What you describe would be very strange indeed. And I was curious, because I've never noticed that before.

    So I tried it, both on a Macbook and on a PC, both running Live 9.5.

    Changed some routing in a new project, then loaded some random clips.

    But in both cases nothing happens. Routing stays as it was before, both inputs and outputs.

    So something seems to be going wrong. Have you tried it again after reloading? And did you try updating Live to the latest version? Because on my versions (9.5) this doesn't happen.

    10 months ago | 0 comments
  • manveru0
    contribution
    2 answers
    2 votes received
    1 vote

    Hi Near Earth Object :-D

    Thx for testing. Actually I've deleted everything on my PC from Ableton and deinstalled Ableton Live 9.5 64bit version yesterday. I've even deinstalled the Asio driver for my XONE K2. After that I've reinstalled the driver and Ableton Live 9.5 64bit. Same behavior as before.

    Before I've installed the ASIO driver again I've checked the behavior with MME/Direct X driver and no external controller (2 XONES K2 and one Launchpad Pro). Same error. So I don't think it's related to either the controllers or the ASIO Driver.

     

    I'm on Windows 10 64bit using the latest Ableton Live 9.5 64bit

    I've just done a small video showing what happens on my PC Its on youtube :-D

    watch?v=AwQTm0GJVNQ"

     

    What's your PC OS?

    10 months ago | 0 comments

You need to be logged in, have a Live license, and have a username set in your account to be able to answer questions.

Answers is a new product and we'd like to hear your wishes, problems or ideas.