Nested Drum Rack Layout & Colors on Push 2 Not Updating

Hey everyone, experiencing a super weird issue and I'm not sure if this has always been Push 2's default behavior or what but it's a pretty annoying thing that's happening.

I have an instrument rack that currently has 2 other instrument racks nested inside of it. Each nested Instrument Rack contains a Drum Rack and an Audio Effect Rack. I've mapped a macro on the parent Instrument Rack to the Chain Selector so I can automate which rack to play depending on the song. Pretty basic.

The weird issue that's happening is that regardless of which Instrument Rack is selected and active, Push 2 will only display the Drum Rack layout of the 1st Rack instead of updating the active pad layout/colors for the currently selected rack. I can still play the rack and get pad LED response when I play the pads, but again the colors and layout for that rack don't update when selected.

Is this how it's supposed to work or a bug? Seems like it the pad layout/colors should reflect the current active Instrument Rack when it gets selected/highlighted.

Here's a screenshot of the Parent Instrument Rack:
http://imgur.com/urgswyi

and you can see that there are only 2 Instrument Racks comprised of Drum Racks and Audio Racks nested inside:
http://imgur.com/ZwXbVnP
http://imgur.com/lVFEiXE

and here's what Push 2 shows:
(1st rack in chain selected) http://imgur.com/XiJa0oc
(2nd rack in chain selected, wrong layout/colors) http://imgur.com/GFHzNgz

Some info about my setup:

  • Push 2 (with the latest firmware)
  • Live 9.6.2

8 followers

carlosbeans 11 months ago | 0 comments

9 answers

  • ratox
    contribution
    1 answer
    4 votes received
    4 votes

    I would like to know the answer too....please, any support from Ableton?

    9 months ago | 0 comments
  • carlosbeans
    contribution
    4 answers
    6 votes received
    3 votes

    @ratox I got a reply from Ableton about the color issue, and it sounds like it's just an issue with how colors get rendered on Push, and it didn't sound like they had a fix for that yet.

    Regarding the nested drum racks issue, looking at the future release notes for the upcoming Live 9.7 release, it sounds like it MIGHT get addressed, but don't hold me to that: https://www.ableton.com/en/help/article/live-9-beta-release-notes/

    9 months ago | 0 comments
  • yetax
    contribution
    1 answer
    3 votes received
    3 votes

    I have the same  problem !!!

    no solution ???

    2 months ago | 0 comments
  • willrjmarshall
    contribution
    3 answers
    6 votes received
    3 votes

    I'm having the same issue! It's driving me slightly crazy - hopefully Ableton will get a fix out for this ASAP.

    2 months ago | 0 comments
  • celloincage
    contribution
    4 answers
    5 votes received
    2 votes

    I see you have another problem, maybe it doesn't disturb you, but for me it's disturbing : changing drum rack in the instrument rack, the push doesn't show you the good empty or full pads!

    8 months ago | 0 comments
  • nikkata
    contribution
    1 answer
    2 votes received
    2 votes

    I am also having this issue, with the Push 1. Using the chain selector of an instrument rack to select between contained drum racks will effectively change the notes the Push outputs to the selected drum rack, but the Push display does not update to reflect the selected drum rack's active pads.

    5 months ago | 0 comments
  • Adam Mantium
    contribution
    2 answers
    2 votes received
    1 vote

    So, I am running 9.7.1 and no fix yet for displaying nested kits on push 1. This is really an annoying problem for me.

    2 months ago | 0 comments
  • Adam Mantium
    contribution
    2 answers
    2 votes received
    1 vote

    further to this I would really like to be able to put drum racks and instrument racks in the same instrument rack, separate them by key, and have ableton display note illumination for the instruments and drum illumination for the drums.

    2 months ago | 0 comments
  • carlosbeans
    contribution
    4 answers
    6 votes received
    0 votes

    The newest update seems like it might fix these issues: https://www.ableton.com/en/help/article/live-9-release-notes/

    8 months ago | 0 comments

You need to be logged in, have a Live license, and have a username set in your account to be able to answer questions.

Answers is a new product and we'd like to hear your wishes, problems or ideas.