Live no longer opens .m4a files purchased from iTunes

I recently bought a new computer (PC) and tried to resume my old Live projects on this computer. Most of my old reference tracks were .m4a files purchased on iTunes (not ideal, but it's what I have at this point), and these files required no preparation to import into Live. However, I've tried to import the same files on my new computer with no luck.

I checked the Help article "Why Can't I Import Compressed Audio Files Into Live?" and followed all the instructions there regarding User Account Control, running as administrator, etc. but could not fix the problem. Something worth noting: though I installed the recommended demuxer and codec in the "Missing Codec" section just to be safe, it is possible that I missed a setting to be changed within these.

The problem is probably rooted in the changes between my systems...here are the differences.

Old system:

Toshiba Satellite running Windows 7, Live 9 Standard, version ~9.2, 32-bit

New system:

Alienware R2 running Windows 10, Live 9 Standard, version ~9.6, 64-bit

So it seems I've narrowed it down to a demuxer/codec issue, an OS issue, an issue between Live install versions, and an issue between 32-bit and 64-bit. I checked the patch notes as well for the versions since 9.2 and did not see any removal of support for these files.

Does anyone have any suggestions as to how to fix this issue?

4 followers

AlphaHotelMusic 1 year ago | 1 comment

3 answers

  • apakaatti
    contribution
    1 answer
    1 vote received
    1 vote

    I've been struggling with the same issue. As far as I understand, it's indeed a codec issue. Live has traditionally used QuickTime for processing .m4a-files, but since April Apple has discontinued Windows support for QuickTime, so that's no longer an alternative.

     

    I have also tried the suggested fixes (go 64-bit, use Haalisplitter + ffdshow, run as administrator), but those have provided no help.

    1 year ago | 0 comments
  • Alfonx
    contribution
    2 answers
    3 votes received
    1 vote

    Hi all together. Do you have any updates?

    I am changing my Hardware in the next days.
    I am and i was using Ableton Live 9 (now: 9.7.5) 64 bit.
    I already accepted live can not load m4a-files. But now i am close to setting up my new pc and i want to check if there are new possibilities/solutions for import m4a in live.


    I just tried to import m4a in REAPER: Reaper (64 bit; Windows 10) can open m4a-files without problems. It's very disappointing to see a big DAW like Live can not. Yes, its all about money (m4a license) but REAPER is much cheaper than live - and REAPER can import m4a. That's crazy...

     

    6 months ago | 0 comments
  • DAYSUN
    contribution
    1 answer
    1 vote received
    1 vote

     Beyond Brutal... All my voice notes from my iPhone import as .m4a! I've been using them as quick song foundations for years. 

    This is very disappointing.  I hope they fix this.

    I can also attest that Live 9 still imports .m4a's without a complaint. 

    3 months ago | 0 comments

You need to be logged in, have a Live license, and have a username set in your account to be able to answer questions.

Answers is a new product and we'd like to hear your wishes, problems or ideas.