how do i get the cue/solo buttons to send midi to my midi controller such that the led lights go on/off in sync with ableton?

how do i get the cue/solo buttons to send midi to my midi controller such that the led lights go on/off in sync with ableton?

I have a controller that has led buttons but when mapped to the cue / solo buttons, the lights don't come on or off.

10 followers

vader 5 years ago | 0 comments

7 answers

  • FillClarke
    contribution
    24 answers
    -42 votes received
    1 vote

    In "preferences"- go to the MIDI tab.

    Select the midi controller and make sure both input and output are assigned to the correct midi port. Then activate all options (track, sync and remote) for this controller.

    This will enable ableton to send a midi signal back to your controller, activating the LED whenever you trigger a button.

    If you're working with a controller which has preset mappings from the manufacturer, make sure your LED and touch button are not assigned to a different MIDI channel- You should be able to change this by using the manufacturer software. (e.g. M-audio uses enima etc...)

    Also- 9/10 your manufacturer will also have a default ableton mapping nowadays anyway- just use that one then...

    5 years ago | 0 comments
  • vader
    contribution
    1 answer
    1 vote received
    1 vote

    That technique works for midi cc commands.  Apparently, the Cue / Solo buttons use Midi Note commands.  I don't think midi note commands are able to trigger LED for on/off but I could be wrong.  The LEDs work fine for other things like tracks, eq cuts, etc...just not for cue / solo.

    Any ideas?

    5 years ago | 0 comments
  • andy johnson
    contribution
    2 answers
    2 votes received
    1 vote

    Any news on this problem? Please

    4 years ago | 0 comments
  • Joaomig
    contribution
    1 answer
    1 vote received
    1 vote

    Looking for this solution also... Any workarounds?

    3 years ago | 0 comments
  • joseroys
    contribution
    2 answers
    2 votes received
    1 vote

    I'm looking for an answer as well.  Anyone find anything out?

    1 year ago | 0 comments
  • minim_v
    contribution
    1 answer
    1 vote received
    1 vote

    Ok, I spoofed all the midi msgs going out from Live to the output MIDI devices. No matter you assign a note or a cc to cue/solo buttons, Live doesn't send the feedback msg out. It's just not implemented, would have been nice though!

    10 months ago | 0 comments
  • Simsonatic
    contribution
    1 answer
    1 vote received
    1 vote

    I´m new to Live and after different midi mappings with different controllers, to find the best way to extend my DJ setup with parts of live performance, i was wondering too, why the cue/solo switches don´t send back any midi message.

    To get a LED response though, easiest way is to use any FX (EQ3 in my case) mapping the switches to the same controller buttons like cue/solo is mapped to, mute/switch off the used FX and (or) throw it on a dead Track, respectively any place where the FX don´t disturb.

    2 months ago | 0 comments

You need to be logged in, have a Live license, and have a username set in your account to be able to answer questions.

Answers is a new product and we'd like to hear your wishes, problems or ideas.