Can't get my bass station vst to work in Ableton 9

Hello, hope sombody can help.  I can't get my bass station vst to work in ableton 9 64bit mac.  It is greyed out in preferences.  Does anybody know of any problems with bass station and ableton 9?  I have been unable to find anything on internet.  

If incompatible does anybody know of any cheap alternatives?

 

Thanks a lot

 

Geoff

5 followers

geoffspence 1 year ago | 0 comments

3 answers

  • ASRay
    contribution
    2 answers
    1 vote received
    1 vote

    From what I understand 32-bit VST/AUs won't work in 64-bit versions of Ableton.

    1 year ago | 0 comments
  • halley
    contribution
    2 answers
    2 votes received
    1 vote

    The new BassStation plug-in (v2), being given in bundle with some of their new offerings, has been updated to be a 64-bit type plug-in... so should work fine with Ableton 64-bit.

    But I had the same problems...

    looking at the plug-in folder in terminal on os x I noticed that the permissions on the BassStation and Melodyne vsts are different from the other vsts

    drwxrwxr-x  ... Absynth 5 Stereo.vst
    drwxrwxr-x  ... Absynth 5.vst
    drwxr-xr-x  ... BassStation.vst
    drwxr-xr-x  ... BassStationStereo.vst
    drwxrwxr-x  ... Battery 3.vst

    ...
    drwxr-xr-x  ... Melodyne.vst

    (some users have apparently problems with melodyne as well).

    I tried changing the permissions as administrator (the 'sudo' command asks for your administrator password.

    Typed the following:

    prompt$ sudo chmod 775 VST/BassStation*

    prompt$ sudo chmod 775 http://BassStationStereo.vst/Contents
    prompt$ sudo chmod 775 http://BassStationStereo.vst/Contents/MacOS
    prompt$ sudo chmod 775 http://BassStationStereo.vst/Contents/PkgInfo
    prompt$ sudo chmod 775 http://BassStationStereo.vst/Contents/MacOS/BassStationStereo

    same as this second group but with the name "BassStation"...
    prompt$ sudo chmod 775 http://BassStation.vst/Contents

     

    After doing this changes, the rescan worked fine.

     

     

     

     

    10 months ago | 0 comments
  • halley
    contribution
    2 answers
    2 votes received
    1 vote

    the paths have been automatically corrected by the forum form...

    they obviously don't have the http protocol in front, just a backslash.

    these commands are supposed to be written after entering the plug-in folder in the terminal

    10 months ago | 0 comments

You need to be logged in, have a Live license, and have a username set in your account to be able to answer questions.

Answers is a new product and we'd like to hear your wishes, problems or ideas.