Ableton Push not working over USB

Hi Guys,

I went ahead and purchased a new Ableton Push less than a week ago. Got it 2 days ago, and it worked fine when I originally set it up. It installed the firmware update, and worked like a charm.

Turned it on for the second time today, and it seems the unit isnt getting any USB power? It needs to be plugged into a mains adapter to turn on, and it's stuck in "demo" mode when this is done. When connected to my Mac mini 2012 it is not being recognized as a device.

I have tried several USB cables, including the one that came with the unit, which worked originally. I have tested other devices such as a Maschine MK2, external soundcard, traktor x1 etc... everything else is working fine as usual.

I have just sent ableton an email asking for help, but I figured i would check here in the mean time to see if anyone has any help.

Any advice would be appreciated.


lucasmanning 4 months ago | 0 comments

1 answer

  • BabbaGaNushe
    1 answer
    2 votes received
    2 votes

    Im having the Same problem...

    11 days ago | 0 comments

You need to be logged in, have a Live license, and have a username set in your account to be able to answer questions.

Answers is a new product and we'd like to hear your wishes, problems or ideas.